Remove All Ads from XDA
Honor 9 Lite


254 posts
Thanks Meter: 110
By andu86, Senior Member on 17th June 2014, 01:44 PM
Post Reply Email Thread
2nd July 2015, 01:44 PM |#161  
2010radams's Avatar
Senior Member
Flag Workington, Cumbria
Thanks Meter: 184
Originally Posted by liobeir

What do you mean by "After all the above steps are done, flash the kernel from your firmware the same way as you did it the first time."?

Do i flash the same kernel i flashed before towelroot or?

No, you flash the kernel that was on your phone before you flashed the kernel to work with towelroot. Basically, you flash the stock kernel that was on your phone before you even thought about rooting your phone. So, if you were running stock kitkat COC1 firmware before you decided to root your phone, you need to flash the COC1 kernel.
12th October 2015, 01:06 PM |#162  
Junior Member
Flag Adelaide
Thanks Meter: 2
Towelroot tripped Knox on Australian I9195T
After doing lots of research on Samsung Galaxy S4 Mini sold in Australia as I9195T version. Awhile ago I updated the firmware via OTA. Telstra only released this 4.4.2 version in the middle of 2015 some 6 months later than other carriers or Countries. To Find out I lost Write Access to SDCard. this model having only 8MB of internal memory means you are always running out of space. Could not even do the OTA update from 4.2.2 to 4.4.2 Ran out of memory half way through.
So I moved lots of apps and freed up as much as I could. Finally got 4.4.2 installed and then No Write Access, found some apps allow Write Access. Anyway This perfectly good working turns to **** and no mention of this prior to update Typical of Samsung and Android lack of info. We the users have to do the research then decide to up date or not.
After the update the phone never really worked properly anyway. After more research most suggestions fixes or comments required a Master RESET of Factory reset. ie save all your data and apps. Remove SD Card so it can not be corrupted etc. Used ADB full update after finally getting drivers to work. But my S4 mini had not been fully operational since the firmware patch. So ADB Full Backup would not work. Used Helium Backup worked but does not fully backup everything. same as Kies only partial backup.

Anyway after all that I finally did a factory reset that was supposed to backup then reset. Found out that only backup some apps and settings. Then spent many hours over the next few days to restore everything back to normal. Still not sure every app is configured as it was prior to reset. Then finally I could do an ADB Full Backup of the internal Memory ONLY without 64GB SD Card which is half full. File size was about 3GB. Just to be sure prior to Rooting the device. I tried plenty of different types of One Click Rooting Apps, so I would not trip Knox, reading plenty of comments about many procedures to Root will trip KNOX. Found your method using Towelroot. Then found that the latest firmware passed July 2014 had been patched.
My firmware is I9195TDVUACOE3-I9195TTELCOE3 released on 03-07-2015 v4.4.2 with prior firmware being I9195TDVUABNB1-I9195TTELBNB1 v4.2.2 released on 02-09-13. There has been only one update from this model's release mid 2013 in Australia for 3 carriers Telstra, Vodaphone and different Model i9195 for Optus.
So I tried Towelroot using the 4.4.2 Boot file extracted from Firmware download from SAMMOBILE and used script as suggested to make root.tar.md5 file for ODIN. Downloaded it and tried Towelroot, to find it would not Root the phone. Phone locked up and would not boot. So I had to use method of remove battery and restart into Download Mode to again restore phone back to normal using root.tar.md5 file extracted from OC3 Latest version firmware.

I was glad I achieved a working phone again with KNOX still 0x0. Then more research realising that I must use same version boot file from 4.4.2, but a release prior to June 3 2014. But Did not have any options of early releases in this region. Seams to be many releases around Europe.
Found a software site that lists all Samsung's Firmware for I9195 models. I could have downloaded many 2-3GB files from several countries, but assumed wrongly that the boot files would be same for each release and only the carrier's or Country files differ in each Rom.

My only choice was to select from I9195XXUCNF7 series released on 13/6/14 or I9195XXUCNEA released on 27/5/14. So decided to try your boot file already indicated that would work with Towelroot.. I could have pick any Complete firmware from the 20+ Listed from any as listed. But what would I gain as suggested earlier.
But maybe I was wrong and you have to match firmware components and not use a different Boot file from another release. ie must be from XXUCNF7 and use earlier release being same as latest already updated. Must be XXUNCNF7 older and XXUNCOC3 Latest. So KNOX will not be tripped.
Anyway I went for XXUNCNF7 Boot so I could be rooted by Towelroot On my I9195TDVUCOE3 firmware. That worked OK. So Achieved that part, Then I reinstalled my latest boot TDVUCOE3, phone rebooted OK.

But on startup, I had a message in Yellow on top of the screen indicating Set Warranty bit : Kernel before booting with Samsung Symbol on Screen followed by Home screen with Icons. After bootup was completed I used SuperSU app to complete the root process. Did not disable KNOX and then used Root Checker to find Root was successful.
Next I installed SD Fix App to get write access back again.
Using Xplore to read Root directories found the permission.xls file modified as to allow Write access to Ext SD Card, taken away by Android update in 4.4.2. Suddenly I got my access back to the SD card and it allowed about 2GB of files to be transferred from Internal Memory to EXT SD Memory. I have now got 2.5GB Free instead of 500MB free of Internal Memory. Phone is now useable. ONLY ISSUE is NOW KNOX is 0x1 (Tripped).

Conclusion I think you cannot mix Firmware version or I9195T sold in Australia is different to I9195 European or International model or I9195L Latin American Model. But I have limited choices. I used factory STOCK Firmwares. I could have used Software extracted from I9195T Recovery process using ODIN or used PC Based TWRP or CWM, PC Kingroot , Framaroot. that would have tripped KNOX.
Pingpongroot, Kingroot, and OneClickRoot apps did not work on my latest version firmware. So now have a rooted phone working properly, KNOX Tripped. Does not really matter as phone is 2 years old and out of Warranty anyway.
I just wanted to experiment to get my phone working how it was when I purchased it.

The moral of the story DONT UPDATE FIRMWARE without RESEARCH. DONT USE OTA updates pushed on users by manufacturer's WHIMS. and BULL**** about safety, security etc. An update that reduces the functionality, is a breach of Consumer Law. " Item is NOT FIT For PURPOSE" breaches the code.
Samsung and Googles Android should be made to fix the problem of reduced access to SD Cards, especially models with only 8MB of internal memory. But they obviously don't care to fix it, by releasing a patch or new versions of 5.0 Lollipop for I9195 models.
So we have to root the phone and lose Warranty to fix it as users.

Anyway that's it folks
The Following 2 Users Say Thank You to BeeJ1109 For This Useful Post: [ View ] Gift BeeJ1109 Ad-Free
1st January 2016, 05:10 PM |#163  
Junior Member
Thanks Meter: 0
This method worked for me. Downloaded I9195XXUCOD3 firmware from and used the tool published in this post--> , to create an Odin friendly MD5 of COD3 kernel to restore. Phone is rooted and Knox counter remains 0x0

Big Thanks to mkh.mourad, geohot & andu86!
23rd January 2016, 11:30 AM |#164  
Hi. Could you just give me some more clues on how to extract kernel from full stock firmware. I've got COI4 and didn't find kernel only, yet I could download full stock firmware.
I understand that afterwards I have to pack it as a .tar.md5 as indicated and flash it with Odin.
Thx in advance

Édit : catched. Just needed to unzip firmware.tar take boot.img inside
Edit 2 : it worked perfectly
I downloaded my exact firmware from sammobile (
suppress .md5 suffix, unzip the .tar with 7zip. found boot.img.
Used trick given on former post to repackage boot.img into a .tar.md5.
Then applied post#1 guidelines.

I had some issues first time, once supersu downloaded : it was messed with knox, I probably wrongly answered and then I was not able to update supersu and was not fully rooted after reverting to original stock kernel.
So I redid once more, this time whole process went ok.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes