Remove All Ads from XDA
Honor View 10

[Solved!] Zopo C2 Hard Bricked

3 posts
Thanks Meter: 1
By iamdoki, Junior Member on 7th June 2014, 12:53 AM
Post Reply Email Thread
Hi Guys!

If you hard bricked your Zopo C2, don't panic! Fortunately, the MTK chipset is not easy to kill!
I brought you the solution!

First of all! Calm down, drink a cup of coffee or a cold beer, smoke a cigarette, and follow these steps:

1. Download files from the attachments!
What you will need:
- The Flashtool MTK Driver.rar
- SP Flash Tool, use this version!!!
- The correct preloader (you found A and B version, download which you need)

2. Unrar these files to separate folders.

3. Install the Flashtool MTK driver as administrator!

4. Open the SP Flashtool as Administrator!

5. Open the scatter file (the preloader which you downloaded at step 1.) These file only contain the preloader, not the ROM!

6. Click the Download icon, and connect your USB cable to your computer and your Phone. Don't take out the battery!

If you follow these easy steps, the program goes to the green ring on, and your phone is ready to wake up!
Attached Files
File Type: rar FlashTool MTK Driver.rar - [Click for QR Code] (339.4 KB, 2560 views)
File Type: rar preloader_a.rar - [Click for QR Code] (57.6 KB, 2201 views)
File Type: rar preloader_b.rar - [Click for QR Code] (58.8 KB, 2045 views)
File Type: 7z SP_Flash_Tool_Correct.7z - [Click for QR Code] (3.18 MB, 2836 views)
The Following User Says Thank You to iamdoki For This Useful Post: [ View ] Gift iamdoki Ad-Free
27th July 2014, 01:37 PM |#2  
Thanks Meter: 0
Talking Bricked C2 ?
my zopo c2 bricked, or semi-bricked.
Upgrading to latest rom from Zopo shop it flashed ok
Then I decided to press the firmware upgrade button, and it immediately started flashing the rom, about 4 min later the green circle appears on the pc screen. I remove the usb cable and tried to power on the device, nothing happened.
Also downloaded a few zopo zp980 roms, but there's no way to get red of the error message, the flash bar only gets red and then it stops.

Until now I've tried to upgrade or download but the same error message appears on the screen I don't know what to do with this brick.....
BDROM ERROR : S_FT_ENABLE_DRAM_FAIL (4032) with flash tool.
going to try your method hopefully it will work

---------- Post added at 01:37 PM ---------- Previous post was at 01:15 PM ----------

Thanks it worked perfectly now have a phone again
21st January 2015, 06:22 PM |#3  
Hovatek's Avatar
Senior Member
Flag Lagos
Thanks Meter: 37
Donate to Me
here's a video tutorial to help

24th December 2015, 11:54 AM |#4  
Junior Member
Thanks Meter: 0
Phone stuck on boot logo , and isn't detected by SP flash tool
I tried to remove the battery and add it after a while , (and click download) but it stays at 0
2nd February 2016, 09:28 PM |#5  
Junior Member
Thanks Meter: 0
Greetings experienced users,
I need an advice with my C2. I have this cell phone from Etotalk with their ROM for almost 3 years. Yesterday I wanted to check the internet. I pushed the power button the screen just dimly flickered and the screen stayed black and phone was not reacting.
I restarted it – screen with logo – boot animation – black screen again. I decided to try factory reset. I connected the phone to the pc + doublepress and I probably missed it and the phone started booting and black screen again. I restarted the phone again but this time its totally dead (I cant start it, cant charge it).
I tried to install new preloader by the your manual, but I was unsuccessfull. In SP flash tool I get only red line to 100% greyed button are highlighted but nothing happens. I see my phone in the system as MTK USB port (COM7).
Is there anyone with the same experience or any advice? Because my phone is now completely dead.

Thanks in advance
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes