FORUMS
Remove All Ads from XDA

[APP] MotoG Boot Logo Creator + Flasher v1.0 [05.Feb.2014]

908 posts
Thanks Meter: 645
 
By Kameo, Senior Member on 5th February 2014, 03:30 PM
Post Reply Email Thread
20th September 2015, 08:11 PM |#141  
Senior Member
Thanks Meter: 18
 
More
image quality is unrecognizable once the logo is completed, any hint please?
 
 
6th October 2015, 05:24 AM |#142  
mmims24's Avatar
Senior Member
Flag Millbrook
Thanks Meter: 53
 
More
Thanks for all the hard work you put into this app. Any chance it will be made compatible for Mac, or even an android app.

Sent from my falcon using XDA Free mobile app
26th December 2015, 02:17 PM |#143  
The Analog Kid's Avatar
Senior Member
Thanks Meter: 55
 
More
Quote:
Originally Posted by [-Stash-]

Thanks for this tool, it's great and I can confirm it works with progressive JPEGs exported from Photoshop (I've hit the thanks button ).

I created a simple boot logo, but here is the JPG I used with this tool to create the .bin (attached) just in case anyone else wants it.

Is this a flashable zip?
28th December 2015, 01:02 PM |#144  
Junior Member
Thanks Meter: 17
 
More
No it isn't. It's a bin file which you will need to use the command line to install. If someone points me to a guide for making flashable zips, I'd be happy to make one!
13th February 2016, 10:54 PM |#145  
Junior Member
Flag Pune
Thanks Meter: 0
 
More
Thank You Very Much!!
Quote:
Originally Posted by Kameo

Hi everyone, here's my last release : MotoG Logo Flasher.

A little app that will allow you to flash your own custom logo as the MotoG splashscreen.

Current functionality:
- Convert your custom picture to a raw picture.
- Compress this raw picture to a specific Motorola format (thanks to Carock for decyphering it).
- Then inject it into a working logo.bin for you to flash.
- It doesn't matter if your BootLoader is unlocked or not, you'll never see the warning logo (thanks to ffosilva's hack).

How to use:
- Download and extract the attached zip.
- Create a 720 x 1280 x 24b picture (i've tested it with bmp, but you can try with png or jpeg).
- Run my app [MGLF] and hit the [Create logo.bin] button.
- You'll see a preview of your picture and can then decide to flash it or not.
- If you choose to go on, you'll just have to wait a few seconds till the process ends. Et voila! You'll end up with a working logo.bin to flash.

- To test/flash it, just use the "flash logo.bat" file located in the app folder.
- The inbuilt exception catcher should handle all the bugs, don't hesitate to report them.
- If you ever want to flash the stock logo.bin: just copy the "original.logo.bin" from the [bin] folder and rename it as logo.bin.

Bugs:
None so far (you tell me).
Well at least, i know that some colors are not exactly the same but it's a bug in ImageMagic Convert.exe. Will look into it later if it really bothers some of you.

Download:
Just grab the attached zip file and hit the Thanks button.

MD5: ee5a93c6a9564913eaff62a00b79bf5c

Thanks to:
Carock, for decrypting the logo.bin compression algo.
fosilva, for his nowarning little hack.
Madshi, for his great madExcept lib.
And you for using it. Have a nice day and enjoy it.

Planned additions:
- Reboot/Flash from the app.
- Fix some bugs if ever found.



The logo flasher helped a lot. I can now create my custom boot logo. Your help is highly appreciated my friend.
Also I was curious as to what format the output file is produced, what are its contents and what the tool does exactly? Thanks again in advance
11th July 2016, 12:21 AM |#146  
Leproide's Avatar
Junior Member
Flag Verbania
Thanks Meter: 6
 
More
Hi
I tried to make my own logo, at the boot the color is like this:
#C3963A

Why?

(i cant link my image, need 10 post )

FIXED:
Boot creator invert color.
If I flash an inverted image and on my device show real color, in my case blue :3

Edit:

I made this custom variant for CM users
http://forum.xda-developers.com/moto...rning-t3417016

5th September 2016, 07:30 PM |#147  
Junior Member
Thanks Meter: 0
 
More
This only partially works for me on Moto G4+ XT 1644. When I boot into TWRP the logo.bin I flashed shows up correctly, but when booting normally I just get a black screen with white "N/A" on it. Any advice?
16th October 2016, 07:35 AM |#148  
JackyGreen's Avatar
Member
Flag Ganzhou
Thanks Meter: 26
 
More
If you are going to add Chinese translations ( both simplified and traditional Chinese )
I'm glad to help
26th October 2016, 12:23 AM |#149  
Junior Member
Flag Lyon
Thanks Meter: 0
 
More
Hi!
I can't get the software to work, whenever I try to open an image (png, bmp, etc...), it crashes...
Attached is the bug report. The error is some 'OLE error'.
Attached Files
File Type: txt bugreport.txt - [Click for QR Code] (28.4 KB, 12 views)
2nd November 2016, 01:43 PM |#150  
mysterio619's Avatar
Senior Member
Flag Bangalore
Thanks Meter: 198
 
More
will this work on oneplus 3?
7th January 2017, 07:42 PM |#151  
Junior Member
Thanks Meter: 0
 
More
Hi, Im having a problem when running flash logo.bat, it says that my device is not conected, waiting for device, even though my phone is conected, how do I fix it? Thanks
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes