Remove All Ads from XDA

[Q] Hard bricked kindle fire 2(omap4430)

5 posts
Thanks Meter: 0
By opporlando23, Junior Member on 7th January 2014, 10:02 AM
Post Reply Email Thread
First of all this is my first post and I am a complete NOOB.
Also I apologize in advance if I break any rules with this post and please excuse my terrible grammar and spelling.

Computer 1:Windows 7 Ultimate 32bit
Computer 2:Ubuntu 12.04 LTS
Device: Amazon Kindle Fire 2nd Gen

I will try to provide as much information as I can stating how I got here

Eastern Time:

11:00pm : Decided to root and flash a custom rom on my friends kindle fire hd 10.4.6 have rooted and flashed my first gen kindle and a galaxy s before successfully. So i looked around the forums and found this The last comment lead me to this site where I downloaded the following files

1)Kindle Fire USB driver


The had

and i rooted the device using the RunME shown

11:49pm: Happy and dandy rooted and superuser was installed no problem now I had to install TWRP so I followed and

I thought everything was fine until I realized that in the post the version he says to download is CM-10.1 and I had downloaded from the link he provided. I realized that after I was in TWRP after wiping all the caches and the system I went to install it and it gave me an error which i don't remember what it said.

12:40am: So now im trying to figure how the hell to mount the kindle back so I can transfer the rom out and put the correct one in. I see there is a mount option in TWRP but it would always show up as a hidden removeable disk and when i looked at the command line it said

"E: unable to locate volume information for usb storage mode"

So i googled that and found this post

I figured okay I don't have a fastboot cable so let me try the sideboot loader. But now my computer running windows 7 ultimate 32 bit was not recognizing the kindle like before. It came up as kindle fire2 and the previous drivers werent working

so when i ran cmd an issued the adb devices command nothing showed and I was unable to sideload anything.

So then i got to thinking the error said it could not locate volume information, there was an option in TWRP that said format or partition I don't remember so the idea in my noob brain was ill partition a small part of the memory inside to hold the correct ROM and than flash it using TWRP and problem solved. until this point I could turn my kindle off and on and be able to get into TWRP no problem just hitting the power button.

After the third try of partitioning and each time failing because it could not mount "/data"
i got fustrated and went looking for answers but the kindle was dying at 3% so i shut it off and let it charge while i looked. MISTAKE
i powered it off via the power button and the light disappeared when I went to turn it on again I had no luck BLACK SCREEN and nothing
SO i turned on my xbox and decided Ill play while it charges.

1:40am: no luck nothing on the screen cant get it to come up on the computer F Me i bricked this thing. Finally wiggle the usb around plug out of the hub and directly into the computer and BAM OMAP4430 is being connected and disconnected continuously

YES WE HAVE LIFE. So i began looking at what it is and found several post

First i found out that im in the "cpu's USB boot mode. You need to send the cpu something to boot over usb or it will loop forever trying to find something to boot off flash".

so I powered up my vmware and transfered all the files in I would need to run 2) Open a terminal and sudo or su to root. It's easier that way.

3) Unplug the USB or AC adapter if it's plugged into the KF. But have the USB cable's A end plugged into the PC. This is very important.

4) Turn the power completely off. Do a shutdown if actually running Android, or hold the power button until there's no LED or backlight.

5) Pry open the back cover. The iFixit teardown (Google it) gives some ideas on how to do it, but be really careful because it's easy to snap the tabs along the long sides. DID NOT DO THIS SINCE I HAD READ ELSEWHERE I WAS ALREADY IN THIS MODE

6) The power must still be off. If you accidentally powered it back on, turn it back off.

7) Run:

./usbboot aboot.bin u-boot.bin; ./fastboot boot twrp-blaze-2.0.0RC0.img
This will chain load aboot, FIREFIREFIRE, then TWRP.

This got me nothing expect waiting for

OMAP44xx device...
sending 2ndstage to target...
waiting for 2ndstage response...
unexpected 2ndstage response
< waiting for device >

and then the terminal just stood there so then on another thread I read

" run the script usb_fix_parts_and_install_fff_twrp and plug your device in while off when it says <waiting for omap44xx device> in the terminal. The script should run when your device boots up because it`s in this state. I don`t believe you will even need the short trick"

yes a solution finally after looking for so long!

3:37am: download the files run the script run the

root@ubuntu:/home/orlando/Desktop/rekindle/rekindle# ./fk

5837+1 records in
5837+1 records out
5977554 bytes (6.0 MB) copied, 4.69615 s, 1.3 MB/s
Stopping any running adb servers...
Done. Tools are in /root/firekit. Files copied to USB are likely in /cdrom
install_fff_twrp_from_stock - install FFF and TWRP while in stock Android
install_fff_twrp - install FFF and TWRP while in fastboot
fix_parts - restore partition table to stock while in fastboot
normal_boot - set the bootmode to boot android and reboot while in fastboot
usb_boot_twrp - USB boot TWRP without installing
usb_install_fff_twrp - USB boot FFF, install FFF and TWRP
usb_fix_parts_and_install_fff_twrp - USB boot FFF, restore partition
table to stock, install FFF and TWRP
Good luck. -pokey9000
root@ubuntu:~/firekit# usb_fix_parts_and_install_fff_twrp
Loading FFF through USB...
waiting for OMAP44xx device...
sending 2ndstage to target...
waiting for 2ndstage response...
unexpected 2ndstage response
Fixing partitions...
< waiting for device >


20 mins later


It froze there and the kindle kept connecting and disconnecting it is now 4:30am
it will still only connect and disconnect as OMAP4430

If the developers or someone who knows more than me would be kind enough to lead me in the right direction I would appreciate it

I have tried hard to fix this thing and no luck.
2nd June 2014, 10:58 AM |#2  
Junior Member
Thanks Meter: 8
Thumbs up +1
3rd November 2014, 02:30 PM |#3  
Junior Member
Thanks Meter: 0
Is this considered as terminal?

As a super hard core bricked?

*i'm here now all ill be doing now buying is broken Screen Kindle and assemble with my good screen
25th February 2016, 11:58 PM |#4  
stevedroid10's Avatar
Junior Member
Flag Rochester
Thanks Meter: 1
Try search on YouTube for Tekify lollipop or marshmallow on Kindle fire HD. He has a real easy to follow step by step. I used him on 2 kindles both with success in minutes.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes