FORUMS
Remove All Ads from XDA

[UNMAINTAINED][TOOL][LB][ROOT] Backup TA v9.11 for Windows [20140615]

603 posts
Thanks Meter: 1,454
 
By DevShaft, Senior Member on 23rd May 2013, 09:52 PM
Post Reply Email Thread
5th March 2016, 10:59 AM |#2071  
kulvertti's Avatar
Senior Member
Thanks Meter: 585
 
More
Quote:
Originally Posted by Mr.YatekomoSan

Hey guys I have one noob question. At the time of restoring the DRM Keys I need to have the same software version that when I made de backup? For example I made the backup on software version 23.4.A.1.232, do I need to get back to it before the restore or I can restore my DRM Keys on any software version?

Sent from my Xperia Z3

Nope.
 
 
5th March 2016, 11:52 AM |#2072  
Mr.Jay's Avatar
Senior Member
Thanks Meter: 111
 
More
Quote:
Originally Posted by kulvertti

Nope.

No what? ๐Ÿ™„

Sent from my Xperia Z3
5th March 2016, 12:03 PM |#2073  
kulvertti's Avatar
Senior Member
Thanks Meter: 585
 
More
Quote:
Originally Posted by Mr.YatekomoSan

No what? ๐Ÿ™„

Sent from my Xperia Z3

You don't need to be in same software version when you restore your TA backup.
The Following User Says Thank You to kulvertti For This Useful Post: [ View ] Gift kulvertti Ad-Free
9th March 2016, 08:43 AM |#2074  
Junior Member
Thanks Meter: 2
 
More
Restore unsuccessful
Hi,
I made this restore many 3 times in past withuot problems, but now this problem occures. It looks like saved backup is OK, but why does it need revertTA.img from SD card? I have xperia SP with internal memory refered as sdcard0 and sdcard as sdcard1. Which sdcard is this mentioned in error? Internal memory is wiped when playing with custom roms and SD card can be also formatted in mean time, so this could be something that was created on SD card while creating backup, or?

[ ------------------------------------------------------------ ]
[ Backup TA v9.11 for Sony Xperia ]
[ ------------------------------------------------------------ ]
[ 1. Backup ]
[ 2. Restore ]
[ 3. Restore dry-run ]
[ 4. Convert TA.img ]
[ 5. Quit ]
[ ------------------------------------------------------------ ]
Please make your decision: [1,2,3,4,5]?2

=======================================
RESTORE
=======================================


Are you sure you want to continue? [Y,N]?Y

Waiting for USB Debugging...OK
" superuser permission was granted before"

=======================================
CHOOSE BACKUP TO RESTORE
=======================================
[1] TA-backup-20150617.080819.zip
[Q] Quit
Please make your decision:1

Are you sure you want to restore 'TA-backup-20150617.080819.zip '? [Y,N]?Y

=======================================
EXTRACT BACKUP
=======================================

7-Zip (A) 9.20 Copyright (c) 1999-2010 Igor Pavlov 2010-11-18

Processing archive: backup\TA-backup-20150617.080819.zip

Extracting TA.blk
Extracting TA.img
Extracting TA.md5
Extracting TA.serial
Extracting TA.timestamp
Extracting TA.version

Everything is Ok

Files: 6
Size: 2097244
Compressed: 134407

=======================================
INTEGRITY CHECK
=======================================
OK

=======================================
COMPARE TA PARTITION WITH BACKUP
=======================================
OK

=======================================
BACKUP CURRENT TA PARTITION
=======================================
dd: can't open '/sdcard/revertTA.img': No such file or directory

=======================================
PUSH BACKUP TO SDCARD
=======================================
5247 KB/s (2097152 bytes in 0.390s)

=======================================
INTEGRITY CHECK
=======================================
FAILED - Backup has gone corrupted while pushing. Please try again.

*** Restore unsuccessful. ***

Press any key to continue . . .
EDIT:
I have found out ,that in Service menu under service tests and security are this 2 keys Marlin and WMLA -> both have [Key OK][active] -> does it means that TA partition was restored even there was error? (Xperia SP)
9th March 2016, 12:56 PM |#2075  
Junior Member
Flag Sosnowiec
Thanks Meter: 2
 
More
Up.
I have the same problem. I have Xperia M4 Aqua, stock system and root. :/

[ ------------------------------------------------------------ ]
[ Backup TA v9.11 for Sony Xperia ]
[ ------------------------------------------------------------ ]
[ 1. Backup ]
[ 2. Restore ]
[ 3. Restore dry-run ]
[ 4. Convert TA.img ]
[ 5. Quit ]
[ ------------------------------------------------------------ ]
Please make your decision: [1,2,3,4,5]?2

=======================================
RESTORE
=======================================
When you continue Backup TA will perform a restore of a TA partition
backup. There will be many integrity checks along the way to make sure
a restore will either complete successfully, revert when something goes
wrong while restoring or fail before the restore begins because of an
invalid backup. There is always a risk when writing to an important
partition like TA, but with these safeguards that risk is kept to an
absolute minimum.

Are you sure you want to continue? [Y,N]?Y

Waiting for USB Debugging...OK


=======================================
CHOOSE BACKUP TO RESTORE
=======================================
[1] TA-backup-354512076010673.zip
[Q] Quit
Please make your decision:1

Are you sure you want to restore 'TA-backup-xperiaM4.zip '? [Y,N]?Y

=======================================
EXTRACT BACKUP
=======================================

7-Zip (A) 9.20 Copyright (c) 1999-2010 Igor Pavlov 2010-11-18

Processing archive: backup\TA-backup-xperiaM4.zip

Extracting TA.blk
Extracting TA.img
Extracting TA.md5
Extracting TA.serial
Extracting TA.timestamp
Extracting TA.version

Everything is Ok

Files: 6
Size: 2097244
Compressed: 237899

=======================================
INTEGRITY CHECK
=======================================
OK

=======================================
COMPARE TA PARTITION WITH BACKUP
=======================================
OK

=======================================
BACKUP CURRENT TA PARTITION
=======================================
4096+0 records in
4096+0 records out
2097152 bytes (2.0MB) copied, 0.022116 seconds, 90.4MB/s

=======================================
PUSH BACKUP TO SDCARD
=======================================
4313 KB/s (2097152 bytes in 0.474s)

=======================================
INTEGRITY CHECK
=======================================
FAILED - Backup has gone corrupted while pushing. Please try again.

*** Restore unsuccessful. ***

Press any key to continue . . .

Please help me
The Following User Says Thank You to marek789 For This Useful Post: [ View ] Gift marek789 Ad-Free
11th March 2016, 07:35 AM |#2076  
Junior Member
Thanks Meter: 2
 
More
reflashed stock firmware 4.4 and then tried to restore TA partition, but it's giving me an error at the integrity check on the pushed TApartition.
opening the supposed md5 file of the pushed TApartition there's written this "/system/bin/sh: /data/local/tmp/busybox-backup-ta awk {'print \'}: not found" .
in the local md5 file is the correct hash key.
Someone can help me?
12th March 2016, 05:38 PM |#2077  
Junior Member
Thanks Meter: 1
 
More
not restoring here http://prntscr.com/ae4pq5 , can I flash this zip anywhere else or something?
PS: I got twrp recovery
PS: I am using sony oficial FTF
PS: I want my locked bootloader and ta partition back PLZZZZZZZ
15th March 2016, 06:21 AM |#2078  
Senior Member
Flag Kuwait
Thanks Meter: 178
 
More
Backup is not working. I get error while pulling /sdcard/backupTA.img saying it doesn't exist. I tried from Windows 7 too. But of no use.
15th March 2016, 09:59 AM |#2079  
Junior Member
Thanks Meter: 2
 
More
I have tried to unlock again -> the keys in service tests were with [Unknown error] , then I just relocked bootloader and it changed to [Key OK] .... so no more need to recover backup via TA Backup?

Unlovcked and relocked via flashtool ...
17th March 2016, 10:07 PM |#2080  
Soheil_rf's Avatar
Senior Member
Flag Tehran
Thanks Meter: 986
 
More
fix TA Backup Lollipop
Extract attachment to Backup-TA-9.11\scripts folder

Tested and worked fine on Xperia Z3 5.1.1
Attached Files
File Type: zip backup-restore.zip - [Click for QR Code] (4.3 KB, 1118 views)
The Following 12 Users Say Thank You to Soheil_rf For This Useful Post: [ View ] Gift Soheil_rf Ad-Free
18th March 2016, 06:50 PM |#2081  
David78130's Avatar
Senior Member
Flag Les Mureaux
Thanks Meter: 130
 
More
Thumbs up
Quote:
Originally Posted by Soheil_rf

Extract attachment to Backup-TA-9.11\scripts folder

Tested and worked fine on Xperia Z3 5.1.1

NO THANKS ?ยง?ยง?,!,,!! I give you 1000 !!! Worked fine on windows 10 and Z3 5.1.1 rooted & TWRP.
Post Reply Subscribe to Thread

Tags
backup, partition, restore, trim area
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes