Remove All Ads from XDA
H10 Turbo

SuperSU binary "Installation Failed" Error Fix

1 posts
Thanks Meter: 1
By moowoo1835, Junior Member on 25th March 2014, 09:38 AM
Post Reply Email Thread
This is the scenario that i have encountered during rooting my htc one XL for fun. But i have encountered a problem of SuperSU binary "installation failed" when trying to update the binary.

Here i am going to share the solution that have been tried out accidentically.

Device : HTC One XL ( i think other device may also counter this problem too when they trying to root with the ZIp version SuperSU apk.
Device's bootloader is unlocked (HTC required, i dont think samsung need this step)
recovery mode Clockworkmod is installed (i think all devices need this mod in order to install apk in the sd_card)
SuperSU apk is installed in recovery mode by install app in the sd_card

The superSU is installed successfully in the phone, you can see the app located in the home screen.
When you try to click in the app, it prompt it requires to update some binary files of the phone. however it will just return "Installation Failed".
Your root access is not stable.
For example:
You might contain root access by using root browser (on google play)
But you couldn't "su" in the linux terminal emulator (on google play)
Also you couldn't "su" by using android shell in the android sdk tools's .adb shell

Below is the steps i performed and it is worked.
  1. Update the latest version SuperSU in the google play
  2. Afterwards, it will prompt the binary update screen again
  3. Choose the Txxx/CWB instead of Normal
  4. My device cannot automatically boot up the recovery mode, thus i manually started the recovery mode
  5. binary will be updated when you go in recovery mode

Importance Note:
Actually I am not success in point 5 (binary will be updated when you go in recovery mode).
It means that the binary doesn't update when SuperSU is still the latest version (updated on google store).
and if you have also encountered this circumstance. reboot in the phone again, in the latest version of SuperSU, selected update binary by Txxx/CWB, and then uninstall the latest version of SuperSU by normal apps uninstallation (you can never able to uninstall the old version SuperSU in the phone normally because its installed in the recovery mode).

Now you can boot into the Recovery mode, it will update the binary automatically, And you can grant the actual root access for your phone after reboot the phone again.
The Following User Says Thank You to moowoo1835 For This Useful Post: [ View ] Gift moowoo1835 Ad-Free
3rd August 2014, 10:09 PM |#2  
Senior Member
Flag Paterson,N.J
Thanks Meter: 32
Do you think this will work for the Note 3 running 4.4.2 ? for some reason as of now on verizon note 3 there seems to be no fix for the supersu not updating binary on the new kitkat 4.4.2 im rooted using towelroot i let it update the binary once and i never opened it again to avoid it asking me to update again then failing ... so to avoid uninstall and reinstall i just let it do its magic once and never touch it again... it will update the first run but once you reboot .. youre f you also want to make sure you delete the file su in system/xbin/su then uninstall and install fresh to get this to update you binary .. but you can never open it again or it will ask to update and fail ... however all apps asking to grant permisson will be granted so apon screen pop up and your prompt to allow .... but i am however going to try this just dont know if i should choose the txxx/CWB as apose to normal
20th April 2016, 01:13 PM |#3  
Junior Member
Thanks Meter: 3
No Luck to me too.
I did what the top comment said but Super SU still says it needs to update binaries. I am using Version 2.65.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes