FORUMS
Remove All Ads from XDA

[Guide][Root+CWM] Samsung Trend plus GT-S7580

17 posts
Thanks Meter: 62
 
By djcliccone, Junior Member on 23rd January 2014, 01:47 AM
Post Reply Email Thread
15th January 2016, 11:43 AM |#141  
Member
Thanks Meter: 1
 
More
OK Thanks I will try .. is it possible only to extract it or I must use odin...?

i wonna flash it via terminal so, if I remane it *.tar and extract i wil see recovery.img but is it possible this file use and flash via terminal ?
 
 
15th January 2016, 04:41 PM |#142  
Lord_Flaya's Avatar
Senior Member
Flag Tomelilla
Thanks Meter: 120
 
More
You can extract the .img and flash. Why use terminal? I use rashr for this purpose, its in the play store. Good luck
16th February 2016, 07:52 AM |#143  
Senior Member
Thanks Meter: 26
 
More
Stock Recovery does not die
Quote:

This root completely compatible with xxuaml3, but not much for xxubna3...

Hello everyone, I'm trying to flash via Odin the CWM recovery in order to root my phone. Then I would like to switch to TWRP since it is the suggested recovery to flash CM11 (I read it is quite stable now).

Unfortunately, I got stuck at the very beginning.... When I flash via Odin and restart in recovery mode, I just find the old stock recovery. There is nothing I can do, I followed the instruction in the first page, I also try to rename a specific file via Root Explorer but, since I don't have any root access, I can't change that file name (it's in a system folder).

The quote I inserted could be the solution... at the moment i'm using the latest firmware available for Italy, which is XXUBOA1, so now i'm downloading the elder firmware XXUAML3 (from Malaysia I guess....), I will flash it via Odin and then, afer the initial system set-up, I will try to flash again the recovey,

Is there anything else I can do?

Thank you in advance guys.

PS. I tryed to flash also TWRP but I faced the same problem
16th February 2016, 12:22 PM |#144  
Senior Member
Thanks Meter: 26
 
More
Ok guys, after several attempts I solved the problem. I installed correctly TWRP, which is a much more user-friendly recovery (touch is enabled, better UI...) and it is also stable and fully compatible with Android 2.2.x and 4.4.x. Then I rooted the phone and installed CM11, which is at its penultimate build, the developer from the CM forum said he will release the EOL version in March. If you agree, I could spent one hour of my life collecting screenshots and useful links in order to write new updated guides, called [ROOT + TWRP] Samsung Galaxy Trend Plus and [CM 11 ] Samsung Galaxy Trend Plus. I will post these guides in this section (seems to be the best place, since our device has no "private" section on XDA).
3rd March 2016, 10:58 PM |#145  
riahc3's Avatar
Senior Member
Thanks Meter: 201
 
More
Odin does not see the phone...

Its a driver issue: Which is the one for Windows 7 64 bit? It does not get installed.
2nd May 2016, 12:00 PM |#146  
Member
Thanks Meter: 9
 
More
Hey guys! I was facing this mobile two nights ago. Here's my experience in order to future users that may find this useful.

So, I tried to update this from Gingerbread to CM Kitkat (cm-11-20160306-UNOFFICIAL-kylepro.zip, md5sum 5e1aefea8210bf82e55d6b7688f7fe3f) and every time I had one step forward, I got two backwards. I'm on Linux, so I tried to install Odin on a VirtualBox machine and flash the phone from it. But, when the phone was set on download mode, VirtualBox won't allow to the guest to recognize this:

Code:
"failed to created a proxy device for the usb device"
So I tried Odin on a native Windows 10 machine, without success. Every time I attempted to flash the recovery, the big red FAIL message appeared.

Hence, I discovered Heimdall, which is available on Linux. Good, under Linux I was able to update the phone with this tool, paying attention to this:
  1. Compile it from source, or heimdall will complain with messages like this:
    Code:
    ERROR: libusb error -7 whilst receiving packet.
  2. Disable temporarily cdc_acm module [source]
  3. (Don't confirmed, but I think it will help :P) Add the following rules to your udev (e.g, create a file /etc/udev/rules/80-heimdall.rules)
    Code:
    SUBSYSTEM=="usb_device", MODE="0666"
    ATTRS{idVendor}=="04e8", ENV{ID_MM_DEVICE_IGNORE}="1"
  4. In order to get KitKat working, you need TWRP as the recovery image, because CWM will complain with a message like this every time you try to install the CM image:
    Code:
    Can't install this package on top of incompatible data.

With these premises:
  1. On the Phone side:
    - Set it on ODIN mode:
    * Power it off
    * Press Vol down + Home + Power until a yellow ! exclamation arises
    * Vol up
    - Plug your phone to the Linux machine
  2. On the linux machine:
    - Unzip the TWRP file, and untar the resulting file. The final file shall be called recovery.img, and have this md5sum: 178ff9ea60d4bc08e86d3700f42f3426
    - Execute heimdall as root
    * Utilities tab
    / Detect device. Confirm that the message box says "Device detected"
    / Select a destination file path for the PIT
    / Click on Download once this button is available
    * Flash tab
    / Open the PIT file
    / Click on ADD and select RECOVERY. On File browse, select the "recovery.img".
    / Tick the "No reboot" checkbox
    / Click "Start"

If no problem arised, you should have the TWRP as the recovery partition. Then, you should perform a full Wipe of your phone (backup your data first) and install the ROM as usual.
The Following User Says Thank You to pacorrop For This Useful Post: [ View ] Gift pacorrop Ad-Free
22nd April 2017, 11:17 PM |#147  
dxdandy's Avatar
Junior Member
Flag Vinkovci
Thanks Meter: 4
 
More
Hello to everyone. I need help. My wife got second hand galaxy trend plus s7580 and it is locked on vip network. She is on other mobil network and is there any solution for unlocked. I had rooted it and now I am wondering if I install some custom rom would it be maby possible to use it on some other network or not ?

Thanks !!!
Post Reply Subscribe to Thread

Tags
cwm recovery, root, s7580, samsung galaxy trend plus
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes