Remove All Ads from XDA
Honor 9 Lite

[HOW-TO] Install & Use ADB tool | Android Debug Bridge | Drivers - Videos - Tutorial

2,825 posts
Thanks Meter: 1,412
By lavero.burgos, Senior Member on 1st February 2012, 07:12 AM
Post Reply Email Thread
2nd April 2014, 01:10 AM |#21  
Senior Member
Thanks Meter: 17
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\xena>adb reboot recovery
error: device offline


can anybody help me with this please
16th April 2014, 09:02 PM |#22  
Junior Member
Thanks Meter: 0
I'm experiencing a Restart Loop problem so I cannot turn my phone on. Can I still use ADB Tool to PULL all my Phone Memory data from my phone and paste it into a folder on my PC?
22nd April 2014, 10:16 AM |#23  
Junior Member
Thanks Meter: 5
Thanks for posting, it is a nice tuto very useful.
9th June 2014, 08:12 AM |#24  
Junior Member
Thanks Meter: 0
Post Cannot access adb in command terminal
I am facing an issue. I cannot access adb through the android terminal and Command prompt. My OS in tablet has blown off. I cannot access tablet content in my laptop. When I tried to write "adb shell" and then I wrote "su", I get this error:

/sbin/sh su: not found

I tried using adb push command and it gave me error:
/sbin/sh adb: not found

I don't have external micro sd card but I heard that it is possible to push files through adb.

Any idea what could be the problem?
Any sort of help would be appreciated.
12th July 2014, 06:26 AM |#25  
Junior Member
Thanks Meter: 0
New adb tool updated 7/12/14
Originally Posted by lavero.burgos


FIRST: You need drivers, you should have them already if you are rooted eather with Indirect or Cfoesch methods.
If you don't have them then download ADB + Fastboot + [There is NO need to install SDK on Windows]

To install Nook Tablet USB and ADB drivers correctly please watch the following video:
1. Windows
2. Ubuntu Linux

SECOND: In order to use "adb remount" you need to install [App]: ADB Root Hijack [ADB Runs as Root now] by Indirect


*All the examples refers to /data/app path you can change to /system/app or any other path you need in your NOOK tablet

- Plug your Nook tablet to your computer
- Open a CMD terminal on Windows:
Start>>run>> type cmd>> click OK (WinXP)
Start>> in search box type cmd>> right click Run as Administrator (Win7)
- Once opened type:

*Let's say your adb tools are in C:\nookroot folder

Installing an Aplication .apk

Put the .apk file into C:\nookroot folder and type

adb install appname.apk

Uninstalling an Aplication

There is an uninstall adb commans that always shows failure!!!
So we are going to use Adb Shell:

adb shell
# cd data/app
# ls
# rm -r appname.apk
# ls                  (You will not find this application, you just removed it!)
Ctrl+c to exit shell mode

Push & Pull commands


adb pull /data/app/appname.apk

If you want to PULL all the files located in a folder then:

adb pull /data/app test
to pull all the .apk's located /data/app and save them into a folder that it will create in C:\nookroot named test


adb push appname.apk /data/app
If you want to PUSH all the files located in a folder then:

adb push test /data/app
to push all the .apk's located in C:\nookroot\test folder to /data/app

Close ADB

adb reboot    (to reboot your Nook Tablet)
adb kill-server     (to stop adb server)
26th September 2014, 09:53 AM |#26  
Junior Member
Thanks Meter: 0
Thumbs up Bundle of thanks
Thanks you saved my life.
2nd November 2014, 08:11 PM |#27  
Junior Member
Thanks Meter: 2
Hi, the windows video is offline, and i get a "device is offline" error whenever I try to run adb shell...

What should I do?
6th March 2016, 05:54 AM |#28  
Junior Member
Thanks Meter: 0
i am getting panicked
first of all...i wiped the rom as my phone was softbricked , now i need to install a new rom but unfortunately my pc dosent recognize my device and its not rooted, fastboot is not working as it is stuck in "=>FASTBOOT mode..." i have a lenovo A7000-a the only thing working is twrp v2.8.6.0. i tried to flash a custom rom through sd card but twrp didnt detected the sd card.i dont have much money to buy a new one and want this working please suggest any way to recover my device thank you
11th May 2016, 08:07 PM |#29  
Thanks Meter: 8
all links are dead.
Please reupload again.

Thanks in advance
Post Reply Subscribe to Thread

adb, shell, tools

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes