FORUMS
Remove All Ads from XDA

[ How-To ] Fix SD card not being detected & USB port not working

1,645 posts
Thanks Meter: 9,139
 
By Calkulin, Recognized Developer on 5th June 2010, 01:51 AM
Post Reply Email Thread
5th June 2010, 02:18 AM |#11  
Member
Flag Frisco
Thanks Meter: 0
 
More
I'll think I'll wait on rooting my Evo when I get it. I don't want to get into any problems haha.
5th June 2010, 02:30 AM |#12  
Calkulin's Avatar
OP Recognized Developer
Thanks Meter: 9,139
 
Donate to Me
More
Quote:
Originally Posted by sruon

If it works... make sure this get stickied and shits


Actually it did fix it, I have the SD card & USB function back, so I'll update the first post with the instructions


So thanks a lot for that sruon, I owe you one now
5th June 2010, 02:32 AM |#13  
Senior Member
Thanks Meter: 2
 
More
No problem!
5th June 2010, 03:05 AM |#14  
Calkulin's Avatar
OP Recognized Developer
Thanks Meter: 9,139
 
Donate to Me
More
Ok updated the original post with the instructions cause I know I'm not going to be the only one with this problem
5th June 2010, 06:06 PM |#15  
Darth Pooh's Avatar
Senior Member
Thanks Meter: 207
 
More
Thanks for this mate. Worked like a charm... even with your files, I didn't need to muck around with the generator or a hex editor. I will tell you this tho, I dont ever wanna do that again. 10 minutes to type 5 command lines in a shell on an Evo sucks hard.
The Following User Says Thank You to Darth Pooh For This Useful Post: [ View ] Gift Darth Pooh Ad-Free
5th June 2010, 06:17 PM |#16  
Inactive Recognized Developer
Thanks Meter: 1,330
 
More
Quote:
Originally Posted by Calkulin

Ok updated the original post with the instructions cause I know I'm not going to be the only one with this problem

calkulin good to see you messin around already, you dont waste any time! any idea what caused this issue for you or how to avoid/prevent it?
5th June 2010, 06:21 PM |#17  
Senior Member
Flag PacNW
Thanks Meter: 7
 
More
Quote:
Originally Posted by joeykrim

calkulin good to see you messin around already, you dont waste any time! any idea what caused this issue for you or how to avoid/prevent it?

+1, i used many of his winmo roms. cant wait to see what he does with android
6th June 2010, 05:24 PM |#18  
Calkulin's Avatar
OP Recognized Developer
Thanks Meter: 9,139
 
Donate to Me
More
Quote:
Originally Posted by Darth Pooh

Thanks for this mate. Worked like a charm... even with your files, I didn't need to muck around with the generator or a hex editor. I will tell you this tho, I dont ever wanna do that again. 10 minutes to type 5 command lines in a shell on an Evo sucks hard.


Glad I could help but be sure to thank sruon as he is the one that posted the link


Quote:
Originally Posted by joeykrim

calkulin good to see you messin around already, you dont waste any time! any idea what caused this issue for you or how to avoid/prevent it?


I don't know what exactly caused it, I don't remember exactly what I did right before the restore failed but I know I was working on de-odexing the system and since 5pm was coming around, I decide to restore and it failed. So I really don't know if it was the failing of the restore or something else(had flashed the Froyo ROM about a hour before too).


Quote:
Originally Posted by dav1boy

+1, i used many of his winmo roms. cant wait to see what he does with android


I'm already working on something don't worry But I need to finish my v1.6 ROM for the Moment first
6th June 2010, 05:29 PM |#19  
p-slim's Avatar
Senior Member
Flag San Jose
Thanks Meter: 317
 
More
sorry calkulin, me and you go way back, i can't wait for you to start building roms for this bad boy. unfortunately the same thing happened to me, i think my friend broke it when i asked him to pull my sd card out, anyways after i took it out it never read another sd card again. i had to get my evo exchanged yesterday, so the 1st day i didn't even get to play with it.
6th June 2010, 06:09 PM |#20  
Calkulin's Avatar
OP Recognized Developer
Thanks Meter: 9,139
 
Donate to Me
More
Nice to see you p-slim, buy yeah I can see how someone can damage the SD card slot, it definitely is a pain to remove and insert a card, especially if you have short finger nails. But don't worry, mine only lasted 3 hours before I "thought" I had killed it, so your not alone
6th June 2010, 06:23 PM |#21  
Senior Member
Thanks Meter: 126
 
More
Nice to see you at work already Calk, used your Diamond kitchen+roms and can't wait to see what you and the rest of the community has in store. As far as the sd/usb issue goes, from what I've gathered/read, it just seems to be the underlying problem with the method in which we currently have to boot into recovery and flash roms. It is random from what I've gathered but I'm sure the more frequently you flash roms especially in succession will increase the chances of it occurring. That's why the fix for the Desire works on our Evo's, we use the same method for recovery and flashing roms.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes