Remove All Ads from XDA


1,012 posts
Thanks Meter: 163
By Ouzo, Senior Member on 10th May 2014, 11:40 AM
Post Reply Email Thread
17th March 2016, 04:03 PM |#1291  
Junior Member
Thanks Meter: 0
Originally Posted by stu1690

So today I went to replace the speaker on my g4s and i have broken the power button off of the board. The strip that connects the button to the board has cut n half.

Looks like my phone will be going to its grave shortly as I can't find spare parts for it anywhere!

I had kind of the same thing here. I don't know HOW to fix this, but I at least just ordered spare parts (power button) from some ali express shop. Who knows...

It sucks that these phones aren't readily made anymore. They're so awesome.
23rd March 2016, 08:21 AM |#1292  
Senior Member
Thanks Meter: 104
Originally Posted by Aeonia

Did you try flashing one of the compatibility patches and kernels by TeamForce that are supposed to fix this issue? They are on NeedRom. Try flashing stock kitkat then the compatibility v3 or v4 ...Tell me how it goes...

Has anyone successfully replaced a Jiayu G4S screen and has no issues whatsoever with flashing kitkat or lollipop?

@TsakosGr Did it work for you? I just ordered a Jiayu G4 screen + digitizer and am curious to see if it will work well....
4th May 2016, 01:24 AM |#1293  
Junior Member
Thanks Meter: 0
I dont know how to eliminate the comment so Im just editing it.
4th May 2016, 11:20 AM |#1294  
OP Senior Member
Thanks Meter: 163
Originally Posted by gusyfazos

Hi fellas! please I need some help Im desperate as hell!! :'( Here goes my story:
I've been using my jiayu G4S for a year (at the beginning I had to replace the loud speaker and change the ROM cause Chinese' was awful, I did it using flashtool without any problem).
My phone fell down to the floor once more, but this time the phone wouldnt work.
- When I plug it to the laptop or the charge it gets energy, and the simbols of charging are shown on the screen properly.
- When I try to turn it on it simply doesnt work.
- When I run the test memory with the flashtool it says that NAND FLASH WAS NOT DETECTED
- Of course the recovery mode doesnt work.
- I've tried to "install" different ROMs (officials & unofficials as well), I've tried to upgrade the firmware. Nothing worked.
- So I tried formating "the whole flash except bootloader" (didnt work) and the "whole flash".
- Ive tried dozends of different combinations of the mentioned operations, including pushing combinations of buttons, putting back the battery in the middle of the process, not removing it, etc.

- Everything, I've tried everything what I could read about or I thought about, without any positive outcome.

Showing the charging symbols, percentages and the green led makes me have some hope, but Im starting to believe that the NAND flash is physically broken

So, Could anyone help me pleaaaaase? I would really apreciatte any advise or option.
You can answer back in this forum or send an email to

Millions of thanks in advance

My gut feeling is that the NAND is dead, but I lack the experience to say for sure
24th June 2016, 05:21 PM |#1295  
Senior Member
Thanks Meter: 16
There are some flawless Cyanogenmod 13 roms available for this phone. I can send you some links if any of you is still interested
18th July 2016, 02:02 PM |#1296  
fxjerzy's Avatar
Junior Member
Flag Lenovo A820
Thanks Meter: 0
Originally Posted by Ouzo

Mine makes a slight hiss before and after a sound. For example, if I have a notification sound that is quiet, the rear speaker hisses for a second or so before playing the notification. If this is what you mean, then yes, I have the same thing. i can't check if this happens when the phone is on silent because I'm in a noisy environment, but I think it does what you describe.

Notifications also sound from the rear speaker when headphones are plugged in which really annoys me too (Samsung devices do this too).

Did you find a solution?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes