Remove All Ads from XDA
Honor View 10

[Q] Htc One m7 -wifi stuck "turning on"

2 posts
Thanks Meter: 0
By bag3ra, Junior Member on 29th April 2014, 05:22 AM
Post Reply Email Thread
17th July 2015, 02:04 PM |#11  
Flag Montreal, QC
Thanks Meter: 2
Hola, I seem to have a similar issue to the OP. After flashing a 5.1 GPE ROM, wifi never worked again.

I tried different ROMs, different TWRP, different firmwares, and even reformated partitions using mkfs.ext4. Wifi still stuck at "Turning on..."

Do you guys have any ideas? Thank youuuu!
19th July 2015, 06:38 AM |#12  
pwraggcan's Avatar
Senior Member
Flag London U.K.
Thanks Meter: 82
Donate to Me
Try going to the root folders and delete the wifi folder from data/misc then restart the phone. Might work.
20th July 2015, 03:31 PM |#13  
Flag Montreal, QC
Thanks Meter: 2
After running the command below on Maximus HD 46, I was able to turn on WiFi, but the connection would be unstable, with the adapter often turning off and on.
restorecon -FR /data/media/0
Originally Posted by pwraggcan

Try going to the root folders and delete the wifi folder from data/misc then restart the phone. Might work.

I tried removing wpa_supplicant.conf. Tried removing the entire folder, connection still resetting randomly.
30th June 2016, 09:46 PM |#14  
Junior Member
Thanks Meter: 0
How I fixed this issue.
Originally Posted by bag3ra

Hei guys !

I have a htc one with unlocked bootloader and s-off.

Yesterday my phone started to experience some trouble with the wi-fi connections. When i turn on the wi-fi it remains stuck on "turning on" and i can't turn it off anymore. I tried to more options by clicking on the 3 dots in the right corner but no succes..all options but "Advanced" are greyed out.

I already tried to flash a custom rom (Viper rom) and reflashed stock ruu and the problem persisted.

Any of you experienced similar problems?

Hello. I have created an account here just to share how I fixed this problem because I couldn't find that solution posted on any forum. It might be helpful for someone, but also I might have been the one that caused the issue in the first place. I have a rooted HTC One M7 running 5.0.2.

So, the "Turning on..." for me occured once my phone's battery completely drained. I have plugged the phone in the charger and it displayed 0%. Once the charge level reached 1% I turned on the phone and almost immediatelly turned mobile data off and wifi on. It was then when it got stuck. I have tried almost all the accepted solutions and none of them worked. As I didn't have time to keep trying to solve the issue I left the phone as it was, not trying to connect anymore but saying "Error" under Wifi in Settings.

I thought about what might have caused this and remembered that I have recently tried to use my phone as a wifi extender using the app called "fqrouter2". Within the app there is an option in configuration "Disable Wifi P2P" that should be, as recommended by the app, disabled if the app failed to work. I have, of course, tried it but it didn't work anyway. I have uninstalled the app and that was it. Wifi worked fine until my phone died. So I decided to reinstall the app and try the "Restore Wifi P2P" option. After restoring it I uninstalled the app and power cycled my phone. When it turned on wifi started working again as if nothing ever happened.

As I said, I might have been the cause of the problem in the first place and I doubt somebody had the exact same situation as mine, but I'll leave this here, just in case. Cheers
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes