FORUMS
Remove All Ads from XDA

[GUIDE] Return your European M8 to 100% Stock - S-OFF REQUIRED

15,283 posts
Thanks Meter: 4,042
 
By EddyOS, Senior Member on 29th April 2014, 12:20 PM
Post Reply Email Thread
13th February 2017, 05:16 PM |#891  
ainaz's Avatar
Senior Member
Flag Tasikmalaya, Bandung, Jakarta.
Thanks Meter: 31
 
More
Quote:
Originally Posted by ahmed.ismael

He mean to remove them from the result

To get getvar result do the following

Reboot the device to bootloader,connect the device to PC
Open CMD window
Type
fastboot getvar all
Copy the result and paste it here
( remove imei and serialno from the result before posting )

Ok, I will try . Thank's for answer

---------- Post added at 06:16 PM ---------- Previous post was at 05:58 PM ----------

Here it is @Einwod

INFOversion: 0.5
INFOversion-bootloader: 3.19.0.0000
INFOversion-baseband: 1.29.214500021.12G
INFOversion-cpld: None
INFOversion-microp: None
INFOversion-main: 6.12.401.4
INFOversion-misc: PVT SHIP S-OFF
INFOserialno: *********
INFOimei: *********
INFOimei2: Not Support
INFOmeid: 00000000000000
INFOproduct: m8_ul
INFOplatform: hTCBmsm8974
INFOmodelid: 0P6B10000
INFOcidnum: 11111111
INFObattery-status: good
INFObattery-voltage: 0mV
INFOpartition-layout: Generic
INFOsecurity: off
INFObuild-mode: SHIP
INFOboot-mode: FASTBOOT
INFOcommitno-bootloader: 76df2b54
INFOhbootpreupdate: 11
INFOgencheckpt: 0
 
 
13th February 2017, 05:23 PM |#892  
Senior Member
Thanks Meter: 1,266
 
More
Quote:
Originally Posted by ainaz

Ok, I will try . Thank's for answer

---------- Post added at 06:16 PM ---------- Previous post was at 05:58 PM ----------

Here it is @Einwod

INFOversion: 0.5
INFOversion-bootloader: 3.19.0.0000
INFOversion-baseband: 1.29.214500021.12G
INFOversion-cpld: None
INFOversion-microp: None
INFOversion-main: 6.12.401.4
INFOversion-misc: PVT SHIP S-OFF
INFOserialno: *********
INFOimei: *********
INFOimei2: Not Support
INFOmeid: 00000000000000
INFOproduct: m8_ul
INFOplatform: hTCBmsm8974
INFOmodelid: 0P6B10000
INFOcidnum: 11111111
INFObattery-status: good
INFObattery-voltage: 0mV
INFOpartition-layout: Generic
INFOsecurity: off
INFObuild-mode: SHIP
INFOboot-mode: FASTBOOT
INFOcommitno-bootloader: 76df2b54
INFOhbootpreupdate: 11
INFOgencheckpt: 0

It's international variant now
However you can convert it to any GSM variant

Sent from my HTC M8 using XDA Labs
13th February 2017, 05:33 PM |#893  
ainaz's Avatar
Senior Member
Flag Tasikmalaya, Bandung, Jakarta.
Thanks Meter: 31
 
More
Quote:
Originally Posted by ahmed.ismael

It's international variant now
However you can convert it to any GSM variant

Where was I to know that it is m8 international variant?
13th February 2017, 05:39 PM |#894  
Senior Member
Thanks Meter: 1,266
 
More
Quote:
Originally Posted by ainaz

Where was I to know that it is m8 international variant?

M8_ul = gsm variant
Mid 0P6B10000 = gsm variant
Version main ( 6.12.401.4 ) = WWE ( international )

Sent from my HTC M8 using XDA Labs
The Following 2 Users Say Thank You to ahmed.ismael For This Useful Post: [ View ] Gift ahmed.ismael Ad-Free
15th February 2017, 10:11 AM |#895  
ainaz's Avatar
Senior Member
Flag Tasikmalaya, Bandung, Jakarta.
Thanks Meter: 31
 
More
Quote:
Originally Posted by ahmed.ismael

M8_ul = gsm variant
Mid 0P6B10000 = gsm variant
Version main ( 6.12.401.4 ) = WWE ( international )

Ok thank's. But i have some question:
1. About GSM variant, btw can i use CDMA card
2. And What the meaning about CID 11111111
2. Is there latest RUU for 6.12.401.4 ? Cause i look at official website (HTC.com-support-rom-donwload), I do not look exactly like the 6.12.401.4. so.. which one i can download RUU from HTC.com. I'm still confused
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20170215-155533.png
Views:	54
Size:	225.8 KB
ID:	4042133   Click image for larger version

Name:	Screenshot_20170215-155554.png
Views:	54
Size:	236.3 KB
ID:	4042134   Click image for larger version

Name:	Screenshot_20170215-155617.png
Views:	54
Size:	214.4 KB
ID:	4042135  
15th February 2017, 10:43 AM |#896  
Einwod's Avatar
Senior Member
Flag Lardos, Rhodes, Greece.
Thanks Meter: 2,083
 
Donate to Me
More
Quote:
Originally Posted by ainaz

Ok thank's. But i have some question:
1. About GSM variant, btw can i use CDMA card
2. And What the meaning about CID 11111111
2. Is there latest RUU for 6.12.401.4 ? Cause i look at official website (HTC.com-support-rom-donwload), I do not look exactly like the 6.12.401.4. so.. which one i can download RUU from HTC.com. I'm still confused

1. Why do you want to use a CDMA card? What do you mean?
2. CID 11111111 means you have a device which is S-OFF and can flash just about any RUU. Be carefull, CDMA ROMs are NOT compatible, you cannot use a Sprint ROM on your device. Be very careful.
3. What you are showing is pages from the US site for downloads, Sprint, Verizon TMobile etc. The European ROMs are not released like this. Again, be very careful what you do.
15th February 2017, 01:05 PM |#897  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by Einwod

1. Why do you want to use a CDMA card? What do you mean?
2. CID 11111111 means you have a device which is S-OFF and can flash just about any RUU. Be carefull, CDMA ROMs are NOT compatible, you cannot use a Sprint ROM on your device. Be very careful.
3. What you are showing is pages from the US site for downloads, Sprint, Verizon TMobile etc. The European ROMs are not released like this. Again, be very careful what you do.

Hello Guys!

I am completely annoyed by trying EVERY KIND OF RUU in Exe format also in zip format but non of them worked for me, here are the full details of my phone, i am just wondering which firmware i should use, is it a Sprint version or what? but I confirm I was using GSM network with it here the only problem i had was the hotspot as that was inactive and so i start to upgrade as OTA update wasn't working so since then i am in trouble any help will be extremely appreciated please as i am completely tired of trying everything. Also please to advice what radio version is required as i have done the same radio version and also i have tried all the marshmallow versions which all of them are 6+ of Andriod ... so I just want to return to the Stock and enable the OTA ... I dont have any OS in my mobile by now, i have tried to change the MID and CID to Super CID and MID to 0P6B12000 which is developer version, here are the full details i get by fastboot getvar all:

(bootloader) version: 0.5
(bootloader) version-bootloader: 3.19.0.0000
(bootloader) version-baseband: 1.16.21331931.LA11G
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main: 6.20.502.5
(bootloader) version-misc: PVT SHIP S-OFF
(bootloader) serialno: **************
(bootloader) imei: 00000000000000
(bootloader) imei2: Not Support
(bootloader) meid: 00000000000000
(bootloader) product: m8_whl
(bootloader) platform: hTCBmsm8974
(bootloader) modelid: 0P6B12000
(bootloader) cidnum: 11111111
(bootloader) battery-status: good
(bootloader) battery-voltage: 0mV
(bootloader) partition-layout: Generic
(bootloader) security: off
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: 205bdca3
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0

I have S-OFF and my device is fully ROOTED and in the fastboot menu its says "*** Software status Official ***". and Radio is: 1.16.21331931.LA11G
MANY MANY Thanks in advance!
W
15th February 2017, 03:35 PM |#898  
redpoint73's Avatar
Recognized Contributor
Thanks Meter: 6,857
 
More
Quote:
Originally Posted by waqarhussain22

I am completely annoyed by trying EVERY KIND OF RUU in Exe format also in zip format but non of them worked for me, here are the full details of my phone, i am just wondering which firmware i should use, is it a Sprint version or what? but I confirm I was using GSM network with it here

Yes, you have the Sprint version, as indicated by product ID (m8_whl). The fact you used it on GSM networks is not relevant to whether its a "CDMA" version M8 or not. the "CDMA" versions (Sprint and Verizon) mean they support CDMA in addition to some GSM bands.

You can NOT flash RUUs, radios or firmware from other versions to the Sprint M8 (only flash RUU, radio, firmware intended for Sprint M8). They are not compatible, and trying to do so may lead to a radio brick, which is usually reversible, but can be permanent.

It also appears that AT&T RUU or firmware (version 6.20.502.5) was attempted to be flashed to the phone.

My recommendation would be to run the proper Sprint RUU. Try the latest Marshmallow one here: https://forum.xda-developers.com/sho....php?t=2729173

You may (probably) need to change back to the Sprint MID to run the RUU.

RUU will flash all the Sprint factory partitions, including ROM/OS and radio. Hopefully, this will get the phone up and running, and we go from there.

If you run the RUU, and have radio/SIM issues, you may need to start with an older RUU and work your way forward, in order to fix the radio problem (caused by flashing non-Sprint firmware).


Quote:
Originally Posted by waqarhussain22

the only problem i had was the hotspot as that was inactive and so i start to upgrade as OTA update wasn't working
Also please to advice what radio version is required as i have done the same radio version and also i have tried all the marshmallow versions which all of them are 6+ of Andriod ... so I just want to return to the Stock and enable the OTA ...

Most US carrier versions (Sprint included) won't receive OTAs when not connected to that specific carrier (in your case Sprint). And you can't "convert" the Sprint version to another carrier version to receive that versions OTAs (for reasons already mentioned).

Also, WiFi hotspot is disabled on many carrier versions, so that may still be the case after the RUU. If so, and you want to use WiFi hotspot; then your best bet is to flash a custom ROM, after you RUU and get the phone up and running. Most custom ROMs have WiFi hotspot working. Make sure you flash a custom ROM which specifically supports the Sprint M8.
15th February 2017, 04:10 PM |#899  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by redpoint73

Yes, you have the Sprint version, as indicated by product ID (m8_whl). The fact you used it on GSM networks is not relevant to whether its a "CDMA" version M8 or not. the "CDMA" versions (Sprint and Verizon) mean they support CDMA in addition to some GSM bands.

You can NOT flash RUUs, radios or firmware from other versions to the Sprint M8 (only flash RUU, radio, firmware intended for Sprint M8). They are not compatible, and trying to do so may lead to a radio brick, which is usually reversible, but can be permanent.

It also appears that AT&T RUU or firmware (version 6.20.502.5) was attempted to be flashed to the phone.

My recommendation would be to run the proper Sprint RUU. Try the latest Marshmallow one here: https://forum.xda-developers.com/sho....php?t=2729173

You may (probably) need to change back to the Sprint MID to run the RUU.

RUU will flash all the Sprint factory partitions, including ROM/OS and radio. Hopefully, this will get the phone up and running, and we go from there.

If you run the RUU, and have radio/SIM issues, you may need to start with an older RUU and work your way forward, in order to fix the radio problem (caused by flashing non-Sprint firmware).




Most US carrier versions (Sprint included) won't receive OTAs when not connected to that specific carrier (in your case Sprint). And you can't "convert" the Sprint version to another carrier version to receive that versions OTAs (for reasons already mentioned).

Also, WiFi hotspot is disabled on many carrier versions, so that may still be the case after the RUU. If so, and you want to use WiFi hotspot; then your best bet is to flash a custom ROM, after you RUU and get the phone up and running. Most custom ROMs have WiFi hotspot working. Make sure you flash a custom ROM which specifically supports the Sprint M8.

Millions of Thanks Mate for your feedback to the problem, I really appreciate your input.
I am going try to Flash with the Sprint one and will post if there is any issue out there.

Also, which Custom rom do you think is the best for me which should work with my GSM network like 3G and 4G if you can give me a link for that it will be awesome.

I also tried android 7.1 nougat LineAge and crDriod but both keep crashing and my Sim dont work with anyone.
I will appreciate if you can give me a link for the best and stable ROM for my Sprint device.
Thanks again.
W
15th February 2017, 04:27 PM |#900  
redpoint73's Avatar
Recognized Contributor
Thanks Meter: 6,857
 
More
Quote:
Originally Posted by waqarhussain22

Also, which Custom rom do you think is the best for me which should work with my GSM network like 3G and 4G if you can give me a link for that it will be awesome.

I also tried android 7.1 nougat LineAge and crDriod but both keep crashing and my Sim dont work with anyone.

I can't say which ROM is the "best" for you, as everyone has very different needs and preferences. They should all work with GSM networks. The no SIM issue may have been due to flashing wrong RUU or firmware, not the fault of the ROM.

Stick to the ROMs which specifically support Sprint, such as the Sprint M8 Dev section:
https://forum.xda-developers.com/spr...m8/development

Also, not necessary to quote my whole post (which is quite long). I know its the default when responding, but just delete it (or only include what you are directly responding to). Including the whole post just clutters up the forum. Additionally, your previous post quoted another post, which had nothing to do with your issue. It will result in that person being notified that you quoted them. Again, only quote what is relevant.

Also, if you don't mind, please click the "Thanks" button on any post you find helpful.
The Following User Says Thank You to redpoint73 For This Useful Post: [ View ] Gift redpoint73 Ad-Free
15th February 2017, 04:50 PM |#901  
Member
Thanks Meter: 2
 
More
Quote:
Originally Posted by redpoint73

"Thanks" button on any post you find helpful.

Thanks again for your prompt response ... sorry for the trouble, i just notice what you said is 100% correct, so I will be careful for this onward.

Regarding the RUU, I have tried a couple of I already downloaded, I dont know if its Harman or Regular Sprint version, however i have tried the regular RUU as i said I already downloaded almost everyone from the official website but this failed and i got 155 error to get the right firmware, i think the radio version is not correct and I must need the correct radio version before flashing the RUU?? so can you please help me with finding me the correct Radio version for my situation as I also tried lollipop as well but failed, so it must be the radio issue i reckon? i tried to google but failed to get the right version, there must be somewhere the Correct version for Marshmallow Sprint M8 so I can flash the Latest RUU??

I remember this had Kitkat Andriod 4.4.4 by default but i still doubt that I can do the Marshmallow?? i have flashed the AT&T / Developer Radio already which you can see, so i think I must should flash the Correct Radio for Marshmallow to flash the latest RUU??

Thanks again for your quick response, I deeply appreciate your help and support here.
Cheers.
W
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes