FORUMS
Remove All Ads from XDA

[Q] Black screen but charging led lights up

6 posts
Thanks Meter: 4
 
By snooze1973, Junior Member on 20th May 2014, 10:31 AM
Post Reply Email Thread
15th September 2016, 09:07 PM |#31  
Junior Member
Thanks Meter: 0
 
More
Hey there, sorry for bumping this but I'm having the same problem

My brother dropped his moto g and the screen shattered. I managed to get a bricked phone with the screen working fine so I replaced it. But unfortunately my brother's phone still has this problem
I know the battery is working because I tested it on the bricked one

Any ideas?
 
 
10th January 2017, 06:32 AM |#32  
Junior Member
Thanks Meter: 0
 
More
I had the same problem, just connect it with 2 amps and in less than 1 minute was online

---------- Post added at 08:32 AM ---------- Previous post was at 08:29 AM ----------

Quote:
Originally Posted by Filarh

I had the same problem, just connect it with 2 amps and in less than 1 minute was online

But this is not the official solution of the problem, I only recommend that you do not allow it to discharge less than 15 if you do not want to do this again
18th April 2017, 06:36 PM |#33  
Junior Member
Thanks Meter: 0
 
More
Hello!
My father's moto g2 had same problem with a new battery after 2 months from replacement.
I've checked the solutions in this thread without success so I've tried the following procedure and it has worked for me:

1) Open the phone removing the back cover
2) unplugg the battery connector
3) plug the phone to a charger (I've used usb cable connected to a pc)
4) screen becomes white with battery indicator, like when charging but at 0%
5) plug the battery connector again without disconnect the phone from usb cable
6) battery indicator shows real % of charge and phone will boot normally

Hope this trick can help someone.

Bye!!
Fabio
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes