Remove All Ads from XDA

Chromecast will not connect to my TELUS ROUTER

2 posts
Thanks Meter: 0
By mydrl, Junior Member on 26th September 2013, 06:41 AM
Post Reply Email Thread
1st August 2014, 09:30 PM |#41  
xasthe's Avatar
Junior Member
Flag Vancouver
Thanks Meter: 3
Not sure if this has been solved in another thread, but since searching turned this one up...

I have the Actiontec V1000H with Firmware: 31.121L.13

I have turned off the AP Pin, ensured UPnP is enabled and turned off NAT firewall in favour of High with some settings tweaked for my needs.

Since turning off the NAT firewall, my Chromecast has worked flawlessly with this modem/router.
1st August 2014, 11:11 PM |#42  
Senior Member
Thanks Meter: 114
You misunderstand the Actiontec settings. You can't turn off NAT. In the context of the Actiontec Firewall Security settings, NAT Only is the lowest security level, meaning "no protocol blocking". The other 3 settings High/Medium/Low add some additional protocol blocking on top of NAT Only.

Other people have noticed that changing the Firewall Security setting to High may get the Chromecast to work - and then it keeps on working when the Security level is set back to NAT Only, for a while at least. I haven't seen any explanation. Someone could probably figure it out by going through all the individual protocols that can be blocked in the table one at a time until they found the one that matters. Maybe it's something to do with DNS. Maybe it's nothing to do with any of the protocols and more about causing a reset. But I don't think anyone has the patience to track it down.
23rd August 2014, 03:18 AM |#43  
Senior Member
Thanks Meter: 114
I did some more testing with the Telus Actiontec V1000H router and the Chromecast since I was thinking of giving a Chromecast as a gift to someone who has the Telus router.

This was the sequence:

1. I turned off the 2.4 GHz WiFi on my own router and turned on the 2.4 GHz WiFi on the Actiontec, giving it the same SSID and password.

2. I plugged in the the Chromecast, and it successfully connected with the default WiFi settings and showed connected to the internet.

3. I connected my iPod Touch to the Actiontec WiFi and fired up the Youtube app. It showed a Chromecast icon, but when I clicked on it it showed the name of the Chromecast as "?". Nevertheless it successfully connected and played a Youtube video on my Chromecast. Afterward the Chromecast icon displayed the correct name of my Chromecast. I was also able to connect using the Chromecast setup app and look at the Chromecast settings.

4. My Android tablet disconnected from WiFi when I switched routers, so I reconnected it to the Actiontec WiFi and scanned for my Chromecast. Nothing - no Chromecast detected. The iPod could still see the Chromecast and communicate with it on the same WiFi network.

5. Following the trick that other people have used, I turned on High security blocking on the Actiontec router. Now my Android tablet suddenly could see the Chromecast and connect to it (makes no sense because all that setting does is block certain protocols). But now the iPod couldn't see the Chromecast any more. I turned off the High security and went back to the normal NAT-Only security setting on the Actiontec. The Android tablet could still see the Chromecast, and the iPod still couldn't.

6. I cycled the WiFi connection off and on for both devices, and rebooted the Chromecast. The situation remained the same - Android tablet could still see the Chromecast, the iPod couldn't - the reverse of the initial situation even though the router settings were back to the same as they were originally. I also noted that the Chromecast took a l-o-n-g time to connect after rebooting, whereas initially it was quick.

I can't figure out this pattern. There might not be a pattern - there may be an internal bug in the Actiontec firmware. Anyone else got any ideas?
23rd August 2014, 09:26 AM |#44  
bhiga's Avatar
Recognized Contributor
Thanks Meter: 1,027
Donate to Me
For completeness I would redo your test giving the Actiontec a different SSID - or forgetting the SSID on all devices first. I've seen weird behavior with some devices when an SSID is reused on a different AP.
23rd August 2014, 06:09 PM |#45  
Senior Member
Thanks Meter: 114
Ok, good suggestion. The results (see below) are more successful, but still confusing:

1. I once again turned off the WiFi on my regular router and turned on the WiFi on the Actiontec, giving it a new never-before-used SSID.

2. I plugged in the Chromecast, expecting it to tell me that it could not connect, and needed setup. Wrong! It connected successfully to the internet. And when I connected my iPod Touch and ran the Chromecast app, it could connect to the Chromecast. My guess is that somehow the Chromecast is remembering WiFi networks by something other than their SSID, and because it had connected to the Actiontec WiFi network before, it was able to reconnect to it even though it had a different SSID! I wouldn't have guessed that.

3. I reset the Chromecast with a long button push, and did the setup from scratch using the iPod Chromecast app. It appeared to go through the setup fine, specifying the new WiFi network and new device name, but when it tried to complete the setup on the Chromecast, something went wrong and the Chromecast got stuck. I eventually pulled the plug and rebooted it. On startup it had the new WiFi network SSID and connected successfully, but the device name had not been changed. The Chromecast app was able to connect to it. The Youtube app was able to see it, but could not play on it.

4. I updated my Chromecast app to the latest version (just in case), did a long-button-push reset again, and went through the entire setup again. This time it completed successfully. The Chromecast app could see the device, and Youtube could see it. But Youtube videos still wouldn't play correctly. The TV screen would blank and show a spinning circle, and the progress bar in the iPod Youtube app would show the video apparently playing, but nothing on the TV screen. I disconnected, updated the Youtube app to the latest version (just in case), tried again several times, different videos - same thing.

5. I got out the Android tablet and gave it a quick test. Same thing: it can see the Chromecast, but can't play anything on it.

6. I tried the set-security-to-High trick on the Actiontec. No help. Put it back to NAT-only.

6. I unplugged and rebooted the Chromecast again. It reconnected fine, and now everything suddenly worked. Youtube and a couple of other apps were able to play media successfully on the Chromecast from both the iPod and the Android tablet.

7. Everything was fine until I tried Netflix. The Chromecast went into the Netflix app successfully and loaded the content to 100%. Then it went back to 0% and tried again. Then it exited without playing anything, and the Netflix app on the iPod crashed and exited. I unplugged and rebooted the Chromecast again, tried Netflix again with the same video, and this time everything was fine. Another unplug and reboot, and everything stayed fine - for the moment.

8. I switched the WiFi back, did a long reset on the Chromecast and reconnected it to my normal router, did the setup again, gave it a quick test.. That all went perfectly smoothly, unlike the Actiontec.

So what can we conclude from this? The Chromecast definitely can work on the Telus Actiontec V1000H, but it's erratic. I encountered problems several times, and although each time I was able to get past the problem, I don't understand how or why. It might stabilize in long-term use, or it could be a frequent annoyance.

BTW, one other observation: I specified the country as United States during setup (as usual), and indeed the country code shown in the Chromecast properties after setup was United States as specified and remained so through several power cycles - even though I'm using Telus, a Canadian ISP.
23rd August 2014, 10:09 PM |#46  
Senior Member
Thanks Meter: 60
im having to reboot my actiontech randomly to get chromecast working... major PITA...
30th August 2014, 09:15 PM |#47  
Senior Member
Thanks Meter: 114
I tested the Chromecast again with the Telus Actiontec V1000H to be sure it would work again, and this time everything seemed to work perfectly.

I turned on the Actiontec WiFi network, then I powered up the Chromecast, connected to it from my Android tablet on my regular WiFi network and told it to switch to the Actiontec WiFi (BTW, I can do that in the Android Chromecast app, but not in the iOS Chromecast app). The Chromecast app warns me that the tablet needs to change WiFi networks too, and does that for me automatically. Everything switched over seamlessly, and I was able to connect all the Chromecast-enabled Android apps to my Chromecast on the Actiontec WiFi network. Then I tried my iPod, and it communicated with the Chromecast just fine too. No repeat of the previous erratic behavior, although I didn't give it a long-term test.
6th September 2014, 08:16 AM |#48  
sharp2G's Avatar
Senior Member
Thanks Meter: 73
Did anyone ever find a real fix for this...?
17th May 2017, 04:39 AM |#49  
Junior Member
Thanks Meter: 0
Switched my router settings from 5G to 2.4G in the wireless setup section/basic setup/frequency. Worked right away.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes