FORUMS
Remove All Ads from XDA

[TIP] USB OTG: power usage and other stuff

160 posts
Thanks Meter: 43
 
By brainwash123, Senior Member on 16th December 2012, 08:55 PM
Post Reply Email Thread
I'm going for a long trip and unable to bring my laptop, so I need to do everything from my RAZR. I bought a USB OTG cable and a USB Y-cable thinking it would be the final solution.

The main problem with the card readers as some of the USB sticks is that they all want >100mA and RAZR reports being unable to supply that amperage. You can debug this using USB Host Controller and enabling the 'DMesg display mode'.

Simple permanent solution:
buy a cheap unpowered usb hub. Since weight and space are my main concerns I cannot travel with powered hubs.

Complicated temporary solution, requiring root:
Check the dmesg output from the above application or by doing a tail -f /var/log/dmesg in terminal and see what port is being reported as underpowered. Most of the time it will be this: "usb 3-1: rejected 1 configuration due to insufficient available usb power". Of course that's not true since the power is provided by an external brick capable of supplying at least 1 amp.
You have several ways of doing this, I'm using root explorer as an example. Go into /sys/bus/usb/devices/3-1/ , click on the bConfigurationValue file, select 'Text Editor' from the prompt, type "1" into the editor, save and exit.
You will have to do this every time you plug something in so you might make it into a script, something like "echo 1>/sys/bus/usb/devices/3-1/bConfigurationValue".


Other issues: I'm taking two cameras with me, a Canon SX230HS and a Nikon D7000. The problem with new cameras is that they have given up on the Mass Storage protocol and switched completely to PTP (Picture Transfer Protocol).

Simple solution: use an SD Card reader to transfer photos. Use USB OTG Helper to help you with mounting, it's a free one-click solution.

Complicated solution: for Canon I'm using RawDroid. For Nikon I'm using DslrDashboard.
If you can afford it, PhotoMate should also work.


Oh, this should go into the Accessory forum, or maybe not even on this forum, but I was able to ditch the camera chargers (two wall bricks + two chargers) by buying a PIXO C-USB charger. It's one of those universal LiPo chargers with spring contacts. You can plug it into a USB port or USB charger and you can charge 1 cell or 2-cell LiIon/LiPo packs or AA/AAA batteries.

I am still looking for an efficient 2xAA/AAA -> USB high current supply for complete portability, but I might just build one myself. The reason is that you will find batteries everywhere but less so publicly available power sockets.
 
 
20th December 2012, 07:40 AM |#2  
Olao99's Avatar
Senior Member
Thanks Meter: 58
 
More
Hmm, I think that for a cheap USB power, you could use one of those smartphone battery backup usb batteries. The problem I see with AA or AAA is that they are less efficient due the extra space they need because of the packaging of each battery, and the materials (NIMH vs Lithium)

Also, taken from this thread: http://forum.xda-developers.com/show....php?t=1349038

You need a powered hub in order for the RAZR to accept it, and I think this is a kernel issue, and cannot be modified just with root (Because of the locked bootloader).

I think that probably what you need, as you stated before, an external source of power, and probably something like this powered usb hub:

http://www.ebay.com/itm/Black-Samsun.../160921077532?

It needs to be powered in order for it to work with our RAZR.
Have a look at the entire thread that I posted before, I think it could be helpful.
27th December 2012, 04:28 PM |#3  
OP Senior Member
Thanks Meter: 43
 
More
I am already on my long trip and the non powered usb hub worked perfectly. I already explained how you can 'fool' the kernel into thinking it has enough power, this is a non-issue. The thing with AA/AAA is not density but it is they are readily available in remote areas of the world where there is no power.
I already tested one AA/usb power supply I had for overload and magic smoke came out.
The Following User Says Thank You to brainwash123 For This Useful Post: [ View ] Gift brainwash123 Ad-Free
26th June 2017, 02:05 PM |#4  
Junior Member
Thanks Meter: 0
 
More
It worked for me. However it depends on how the hub and charger are connected. I had to connect the hub between the female plug of the otg-cable (a y-cable) and the usb stick and the charger to the male otg-cable plug. Connecting the charger directly to the hub didn't work.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes