FORUMS
Remove All Ads from XDA

[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,103 posts
Thanks Meter: 14,281
 
By zhuhang, Recognized Contributor on 15th March 2013, 04:42 AM
Post Reply Email Thread
16th August 2017, 10:47 AM |#26191  
Member
Flag Yaoundé
Thanks Meter: 8
 
More
Quote:
Originally Posted by eldervamp17

Cant get mine to work either. It wont install the driver. After launching the application it asks to install driver and i click ok, then it tells me driver installed and reboot. I then reboot but then when i launch the application it asks to install the driver. Keeps doing the same cycle and the driver just wont install. I got a Samsung galaxy s7 edge G935U Rooted. SU 2.82, busybox free. .

Use terminal emulator and enter the following

su
setenforce 0

This changes SeLinux to permissive
You can enter getenforce to check in which mode SE is right now
Once done, driver doesn't need to be installed again
Do that on every reboot
 
 
16th August 2017, 01:03 PM |#26192  
Member
Flag casablanca
Thanks Meter: 3
 
Donate to Me
More
hi everyone I changed a lot of settings. is there a way to go back to default?
16th August 2017, 05:50 PM |#26193  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by Youms

Use terminal emulator and enter the following

su
setenforce 0

This changes SeLinux to permissive
You can enter getenforce to check in which mode SE is right now
Once done, driver doesn't need to be installed again
Do that on every reboot

I entered those command using a terminal emulator program. Installed the viper4android version 2.5.0.5 application, launched and clicked yes to install driver. Looks like it installed, don't get a message to install driver but I don't think it's functional. When I click on driver status this is what it shows: Driver version: 2.5.0.4; Neon enable:No; Enable:No; Status:Abnormal; Audio Format:Unsupported; Processing:No; Sample Rate:0. When I click on sounds from my settings. I only see sound alive and no option to select viper4android
16th August 2017, 08:59 PM |#26194  
Member
Flag Yaoundé
Thanks Meter: 8
 
More
Quote:
Originally Posted by saikyom

hi everyone I changed a lot of settings. is there a way to go back to default?

If you could download the Aroma zip installer, there are default profiles in Modules>Viper4Arise. About 30 in number

---------- Post added at 08:59 PM ---------- Previous post was at 08:54 PM ----------

Quote:
Originally Posted by eldervamp17

I entered those command using a terminal emulator program. Installed the viper4android version 2.5.0.5 application, launched and clicked yes to install driver. Looks like it installed, don't get a message to install driver but I don't think it's functional. When I click on driver status this is what it shows: Driver version: 2.5.0.4; Neon enable:No; Enable:No; Status:Abnormal; Audio Format:Unsupported; Processing:No; Sample Rate:0. When I click on sounds from my settings. I only see sound alive and no option to select viper4android

Check that you are using Stericsons BusyBox installer
Have Magisk? Then disable and uninstall the Viper module if ever installed
Reboot and enter the above emulator codes once more

If you get abnormal driver, check with "getenforce" your Se linux status. Your rom may be reverting back to enforcing which is where the problem lies.
The Following User Says Thank You to Youms For This Useful Post: [ View ] Gift Youms Ad-Free
16th August 2017, 09:32 PM |#26195  
Senior Member
Flag KC
Thanks Meter: 12
 
More
LOS14.1 and Magisk 13.3. I can't get this to work at all. Is the only solution to wait for Magisk 13.5? Thanks.
16th August 2017, 11:55 PM |#26196  
Junior Member
Thanks Meter: 5
 
More
@Youms. Yep. Was in enforce mode. After changing it back to permissive the driver status mode was showing the info correctly. Ty
17th August 2017, 01:20 AM |#26197  
Member
Flag Yaoundé
Thanks Meter: 8
 
More
Quote:
Originally Posted by badtlc

LOS14.1 and Magisk 13.3. I can't get this to work at all. Is the only solution to wait for Magisk 13.5? Thanks.

Try detailing what you flashed, the errors displayed etc...
17th August 2017, 04:44 AM |#26198  
Senior Member
Thanks Meter: 59
 
More
I've got it running. But the difference it makes in the sound is very little.... The eq in power amp is way better. Is something wrong?its the magisk module that im using. [COLOR="Silver"]

---------- Post added at 04:44 AM ---------- Previous post was at 04:42 AM ----------

Quote:
Originally Posted by badtlc

LOS14.1 and Magisk 13.3. I can't get this to work at all. Is the only solution to wait for Magisk 13.5? Thanks.

Define can't get it to work? Its installed but you hear no difference? Fails to install driver? You forgot to install the apk?
17th August 2017, 08:15 AM |#26199  
Member
Flag Yaoundé
Thanks Meter: 8
 
More
Quote:
Originally Posted by godkingofcanada

I've got it running. But the difference it makes in the sound is very little.... The eq in power amp is way better. Is something wrong?its the magisk module that im using. [COLOR="Silver"]

---------- Post added at 04:44 AM ---------- Previous post was at 04:42 AM ----------


Define can't get it to work? Its installed but you hear no difference? Fails to install driver? You forgot to install the apk?

There is a 120Mb Aroma installer in xda forum that has several profiles. There's a real change when you choose a convolver(have extension .irs)
Do you have those profiles? [path : Sdcard/Viper4Android/ ]
No? Extract the zip to your Sdcard
Like real clean bass? In the viper app load my profile ("convolver_truebass") after extraction indeed.
Attached Thumbnails
Click image for larger version

Name:	Screenshot_20170817-080826.png
Views:	498
Size:	27.5 KB
ID:	4244029  
Attached Files
File Type: zip ViPER4Android.zip - [Click for QR Code] (7.37 MB, 78 views)
17th August 2017, 09:44 AM |#26200  
guitardedhero's Avatar
Recognized Contributor
Flag Little Rock
Thanks Meter: 22,059
 
Donate to Me
More
Sorry for the delay, I had multiple issues across multiple projects to address. Let me know if there is a need that this zip does not meet.
Attached Files
File Type: zip ViperFX-2.5.0.5_20170817_gh.zip - [Click for QR Code] (4.25 MB, 244 views)
The Following 15 Users Say Thank You to guitardedhero For This Useful Post: [ View ] Gift guitardedhero Ad-Free
17th August 2017, 11:08 AM |#26201  
Christiancs1969's Avatar
Senior Member
Flag london
Thanks Meter: 3,411
 
Donate to Me
More
No issues here working a ok

Sent from my SM-G930F using Tapatalk
Post Reply Subscribe to Thread

Tags
best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes