FORUMS
Remove All Ads from XDA
Honor View 10

[Guide+Video] How to Play Star Wars Jedi Knight 2 and 3 on Android

798 posts
Thanks Meter: 1,226
 
By RolandDeschain79, Recognized Contributor on 21st January 2014, 03:19 AM
Post Reply Email Thread
9th July 2014, 09:57 PM |#11  
RolandDeschain79's Avatar
OP Recognized Contributor
Flag Toronto
Thanks Meter: 1,226
 
More
Quote:
Originally Posted by TheBasterd

It says it needs to download 10mbs of additional data, but neither downloads nor plays! I have tried a lot of time and it never works.

Note 2 with Stock ROM.

Uninstall the app, reinstall the app. Download the patch and play.
 
 
7th August 2016, 06:30 PM |#12  
Junior Member
Thanks Meter: 0
 
More
Help
Im using jk3 and It says update 10mb additional and when I clicked sp or mp it says error contacting server 90 bad code 3
21st August 2016, 10:07 PM |#13  
Junior Member
Thanks Meter: 0
 
More
has anyone managed to get JK2 or JK3 to work on an amazon fire tv? box (not stick) should have plenty of power to run it. i purchased on my phone (LG Ultimate2) using the Amazon Underground app. then i used adb to pull the apk onto my computer. then i copied the apk onto a USB stick and installed from USB onto my fire tv. when i launch it, the screen goes black for a second then kicks me back to the fire tv OS.
23rd January 2017, 01:21 AM |#14  
cantenna's Avatar
Senior Member
Flag Newcastle
Thanks Meter: 469
 
More
Quote:
Originally Posted by nfs3freak

I just purchased the app and moved the files to my storage on my LG G2 (rooted).

When I hit Start Full, I get the update required to run, download now (0.5mb) and then after I get Error contacting server: 90 info: Bad code 257.

What do I need to do?

Sorry to kick this up, but on all beloko games, getting this exact same error. Please help
1st May 2017, 02:44 AM |#15  
Junior Member
Thanks Meter: 0
 
More
Admin i am try many times but giving erorr bad code 257 or bad code 3 and i am reinstall the game bu not working
27th November 2017, 03:58 PM |#16  
Feregorn's Avatar
Senior Member
Flag Athens, GR
Thanks Meter: 17
 
More
I don't know is this is real or not, but I can't find Beloko's Jedi Academy Touch game in the Playstore and neither on my purchases list. Have they been taken down or something?
15th December 2017, 12:38 AM |#17  
Junior Member
Thanks Meter: 1
 
More
Wow this app is amazing. Runs perfect on my Galaxy S8. I'm only having one issue though that I can't seem to figure out. Tried searching Google but no luck. Some reason when you select your forces powers on multiplayer you cant unselect something and choose something else. Once you use all your points on your force powers you can't seem to undo it. It's driving me nuts! Anyone know what to do?

As for the person looking for the app on Google play it's no longer on there. Amazon's app store has it though .
The Following User Says Thank You to Ironhayden1 For This Useful Post: [ View ] Gift Ironhayden1 Ad-Free
Post Reply Subscribe to Thread

Tags
how to play star wars jedi knight on android, star wars jedi knight 2: jedi outcast, star wars jedi knight 3: jedi academy on android, star wars on android

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes