FORUMS
Remove All Ads from XDA

 View Poll Results: How U like my 1st post?

Awesome
 
175 Vote(s)
53.52%
Not bad
 
48 Vote(s)
14.68%
Good
 
65 Vote(s)
19.88%
Awful
 
39 Vote(s)
11.93%

[FIX][SOLVED]Status 7 Error with CWM or TWRP Recovery on Rooted Android!

n/a posts
Thanks Meter: 0
 
By AndroTix, Guest on 11th November 2013, 08:43 PM
Post Reply Email Thread
28th March 2018, 08:10 AM |#121  
Junior Member
Thanks Meter: 4
 
More
its worked for mee too
Quote:
Originally Posted by PlayersHeaders

Hi, I did it, but now I get the error ,,Invalid zip file format!'', what to do?

---------- Post added at 11:21 PM ---------- Previous post was at 10:54 PM ----------

I FOUND A SOLUTION FINALLY! For the ,,invalid zip''-problem!

I've used 7zip.

DO NOT unzip your ROM!!! Just fix the updater-script IN the zip. Dont unzip and zip it like in the tutorial
Just open it in 7zip and:
Instruction:

Instruction


@androtix Please include this solution in to the thread, so that people can save their time!!


thank u so much , it was really good idea ! i used winrar for editing this file
The Following 2 Users Say Thank You to aryalireza For This Useful Post: [ View ] Gift aryalireza Ad-Free
18th April 2018, 03:08 PM |#122  
Junior Member
Thanks Meter: 1
 
More
not working please help
i have use this method but still not working its is happened after flashing miui rom in zuk z2 plus any have solution please let me know.
The Following User Says Thank You to raju ghorai For This Useful Post: [ View ] Gift raju ghorai Ad-Free
19th April 2018, 09:42 PM |#123  
Junior Member
Thanks Meter: 0
 
More
http://prntscr.com/j7izop
hello
can someone please tell me what the hell to delete. it's an update for huawei p9 lite B376
thanks
27th April 2018, 11:41 AM |#124  
Junior Member
Thanks Meter: 0
 
More
Miracles
You just saved my phone =)

Thx so much.
10th May 2018, 04:41 PM |#125  
Junior Member
Flag Augustenborg
Thanks Meter: 1
 
More
Hi Guys.

I have a OnePlus 3 A3003. I get this error 7 when I try to install a new ROM.
I have tried 4 different ROMS without luck and I tried TWRP 3.2.10 with no luck at all.
Then I tried the remove asserts in all the ROMS without luck.
Then I downgraded to TWRP 3.1.1.0 and I succeded with LineageOS from 01-04-2018 without removing asserts. But how come I can't install the other ROMS, any ideas? I haven't rooted the phone only unlocked the bootloader, but that should not be the problem right?
12th May 2018, 08:06 AM |#126  
Junior Member
Thanks Meter: 0
 
More
Thank You.
it helps alot.
7th July 2018, 07:28 AM |#127  
Junior Member
Thanks Meter: 0
 
More
did not work for me.. Redmi note 4x
17th July 2018, 09:17 PM |#128  
Junior Member
Flag Monsey ny
Thanks Meter: 0
 
Donate to Me
More
how do you zip the file
24th July 2018, 07:54 AM |#129  
Junior Member
Thanks Meter: 0
 
More
to "re-zip" the file, you have to use a program like 7-zip or another "file Zipping" program.

If you don't see the "Assert" lines, then you can leave it alone and just use the original zipped file, because the "assert" isn't the problem.

My problem was, I was using an older version of TWRP. I was using a 2.2 version, when I flashed a 2.8 version (flashed directly from the old TWRP I already had), I was then able to flash the ROM zip that was failing.

I'm working on an old Asus Tablet TF101, and flashed KatKiss 6.0 fyi.
5th August 2018, 02:46 PM |#130  
Junior Member
Thanks Meter: 0
 
More
ther is no assert in the file

this is my updater scrit:

getprop("ro.display.series") == "OnePlus 5T" || abort("E3004: This package is for "OnePlus 5T" devices; this is a "" + getprop("ro.display.series") + "".");
show_progress(0.750000, 0);
ui_print("Patching system image unconditionally...");
block_image_update("/dev/block/bootdevice/by-name/system", package_extract_file("system.transfer.list"), "system.new.dat", "system.patch.dat") ||
abort("E1001: Failed to update system image.");
show_progress(0.050000, 10);
show_progress(0.050000, 5);
package_extract_file("boot.img", "/dev/block/bootdevice/by-name/boot");
show_progress(0.200000, 10);
ui_print("Writing static_nvbk image...");
package_extract_file("RADIO/static_nvbk.bin", "/dev/block/bootdevice/by-name/oem_stanvbk");

# ---- radio update tasks ----

ui_print("Patching firmware images...");
ifelse(msm.boot_update("main"), (
package_extract_file("firmware-update/cmnlib64.mbn", "/dev/block/bootdevice/by-name/cmnlib64");
package_extract_file("firmware-update/cmnlib.mbn", "/dev/block/bootdevice/by-name/cmnlib");
package_extract_file("firmware-update/hyp.mbn", "/dev/block/bootdevice/by-name/hyp");
package_extract_file("firmware-update/pmic.elf", "/dev/block/bootdevice/by-name/pmic");
package_extract_file("firmware-update/tz.mbn", "/dev/block/bootdevice/by-name/tz");
package_extract_file("firmware-update/abl.elf", "/dev/block/bootdevice/by-name/abl");
package_extract_file("firmware-update/devcfg.mbn", "/dev/block/bootdevice/by-name/devcfg");
package_extract_file("firmware-update/keymaster.mbn", "/dev/block/bootdevice/by-name/keymaster");
package_extract_file("firmware-update/xbl.elf", "/dev/block/bootdevice/by-name/xbl");
package_extract_file("firmware-update/rpm.mbn", "/dev/block/bootdevice/by-name/rpm");
), "");
ifelse(msm.boot_update("backup"), (
package_extract_file("firmware-update/cmnlib64.mbn", "/dev/block/bootdevice/by-name/cmnlib64bak");
package_extract_file("firmware-update/cmnlib.mbn", "/dev/block/bootdevice/by-name/cmnlibbak");
package_extract_file("firmware-update/hyp.mbn", "/dev/block/bootdevice/by-name/hypbak");
package_extract_file("firmware-update/tz.mbn", "/dev/block/bootdevice/by-name/tzbak");
package_extract_file("firmware-update/abl.elf", "/dev/block/bootdevice/by-name/ablbak");
package_extract_file("firmware-update/keymaster.mbn", "/dev/block/bootdevice/by-name/keymasterbak");
package_extract_file("firmware-update/xbl.elf", "/dev/block/bootdevice/by-name/xblbak");
package_extract_file("firmware-update/rpm.mbn", "/dev/block/bootdevice/by-name/rpmbak");
), "");
msm.boot_update("finalize");
package_extract_file("firmware-update/logo.bin", "/dev/block/bootdevice/by-name/LOGO");
package_extract_file("firmware-update/NON-HLOS.bin", "/dev/block/bootdevice/by-name/modem");
package_extract_file("firmware-update/adspso.bin", "/dev/block/bootdevice/by-name/dsp");
package_extract_file("firmware-update/BTFM.bin", "/dev/block/bootdevice/by-name/bluetooth");
set_progress(1.000000);
9th August 2018, 06:51 PM |#131  
Junior Member
Thanks Meter: 0
 
More
still not working same error
still not working same error
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes