FORUMS
Remove All Ads from XDA

[Q] Fastboot 'FAILED (remote: signature verify fail)

277 posts
Thanks Meter: 126
 
By yumcax, Senior Member on 22nd November 2011, 05:29 AM
Post Reply Email Thread
26th January 2019, 01:37 AM |#21  
Junior Member
Thanks Meter: 1
 
More
I know this is extreme thread necro, but I didn't see a solution that worked for most people posted, so I thought I would share what worked for me, at least relevant to a phone where the unlock process is carried out via HTCdev.

Basically the problem (for me) appears to be that standard the fastboot.exe in most generic adb packages out there (including the ones I've seen posted on this site) will run produce this error "remote signature verify fail" if you try to use them to unlock your HTC device. For that to succeed, you must use the fastboot.exe downloaded from step 4 of the instructions on HTCdev.

Of course, if you just unzip the folder downloaded from step 4 there, it doesn't contain all the necessary files. for the fastboot command to run. So you also need to copy adb.exe and adbwinapi.dll from the standard package of adb tools (or the SDK install folder from step 1 if you were following the HTCdev instructions) into the folder where you unzip the contents of step 4. Then you can run a command prompt in that folder and (assuming you followed the steps up through 8 and have your unlock.bin in that folder as well), it should sucessfully unlock the bootloader. At least this worked for me.

Hope this helps someone else!
 
 
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes