FORUMS

[UTIL] Apktool - Tool for reverse engineering apk files

926 posts
Thanks Meter: 4,330
 
Post Reply Email Thread
4th February 2019, 12:40 PM |#5701  
Carotix's Avatar
Recognized Themer
Flag Ravenna
Thanks Meter: 36,085
 
Donate to Me
More
Quote:
Originally Posted by thereassaad

Fram-res.apk it's need old versions of apktool ( the version it's not in my mind right now ) & u need to delete some duplicates lines in style.xml & that's it ..

thanks my friend ,
i already tried 2.2.2 version and i deleted the duplicated lines but doesn't help .. there are other problems after ...
do you know which version of apktool i can use?
4th February 2019, 06:28 PM |#5702  
kramer04's Avatar
Senior Member
Flag France
Thanks Meter: 213
 
More
Quote:
Originally Posted by Carotix

thanks my friend ,
i already tried 2.2.2 version and i deleted the duplicated lines but doesn't help .. there are other problems after ...
do you know which version of apktool i can use?

i'm using apktool.2.3.4
see this post
https://forum.xda-developers.com/sho...postcount=5678
The Following User Says Thank You to kramer04 For This Useful Post: [ View ] Gift kramer04 Ad-Free
5th February 2019, 01:05 PM |#5703  
and2's Avatar
Senior Member
Flag Halle
Thanks Meter: 1,208
 
More
Quote:
Originally Posted by Carotix

hi all ,
i'm working on s8+ with beta Pie ...
i can decompile/recompile every app , sysui included ... but i can't recompile the framework-res.apk .... i tried different apktool versions but no match.
can someone help me?
thanks in advance

log

Hi mate,

may be this will help. It's my way.
The Following User Says Thank You to and2 For This Useful Post: [ View ] Gift and2 Ad-Free
8th February 2019, 07:37 PM |#5704  
Junior Member
Thanks Meter: 3
 
More
Trying compile systemui.apk getting this error

Exception in thread "main" org.jf.util.ExceptionWithContext: Exception occurred while writing code_item for method Landroid/support/graphics/drawable/AnimatedVectorDrawableCompat;->inflate(Landroid/content/res/Resources;Lorg/xmlpull/v1/XmlPullParser;Landroid/util/AttributeSet;Landroid/content/res/Resources$ThemeV
at org.jf.dexlib2.writer.DexWriter.writeDebugAndCodeI tems(DexWriter.java:825)
at org.jf.dexlib2.writer.DexWriter.writeTo(DexWriter. java:268)
at org.jf.dexlib2.writer.DexWriter.writeTo(DexWriter. java:246)
at brut.androlib.src.SmaliBuilder.build(SmaliBuilder. java:61)
at brut.androlib.src.SmaliBuilder.build(SmaliBuilder. java:36)
at brut.androlib.Androlib.buildSourcesSmali(Androlib. java:419)
at brut.androlib.Androlib.buildSources(Androlib.java: 350)
at brut.androlib.Androlib.build(Androlib.java:302)
at brut.androlib.Androlib.build(Androlib.java:269)
at brut.apktool.Main.cmdBuild(Main.java:238)
at brut.apktool.Main.main(Main.java:76)
Caused by: org.jf.util.ExceptionWithContext: Error while writing instruction at code offset 0x60
at org.jf.dexlib2.writer.DexWriter.writeCodeItem(DexW riter.java:1098)
at org.jf.dexlib2.writer.DexWriter.writeDebugAndCodeI tems(DexWriter.java:821)
... 10 more
Caused by: org.jf.util.ExceptionWithContext: Unsigned short value out of range: 65537
at org.jf.dexlib2.writer.DexDataWriter.writeUshort(De xDataWriter.java:116)
at org.jf.dexlib2.writer.InstructionWriter.write(Inst ructionWriter.java:348)
at org.jf.dexlib2.writer.DexWriter.writeCodeItem(DexW riter.java:1058)
... 11 more

How do I fix this?
10th February 2019, 11:14 AM |#5705  
Senior Member
Thanks Meter: 788
 
More
@iBotPeaches

My OS is Windows 7 64bit and Java JDK is 1.8.0 build 202.

I tried to compile apktool downloading the code from github, but after some of the latest updates I got several errors during test.

52 tests passed 12 tests with error.

If I compiled using the same github code under Linux (VMWare machine) is working fine.

Thanks.
Attached Files
File Type: txt apktool-windows-error-log.txt - [Click for QR Code] (45.7 KB, 50 views)
10th February 2019, 10:44 PM |#5706  
Senior Member
Jerusalem
Thanks Meter: 647
 
Donate to Me
More
Quote:
Originally Posted by bovirus

@iBotPeaches

My OS is Windows 7 64bit and Java JDK is 1.8.0 build 202.

I tried to compile apktool downloading the code from github, but after some of the latest updates I got several errors during test.

52 tests passed 12 tests with error.

If I compiled using the same github code under Linux (VMWare machine) is working fine.

Thanks.

It's a known issue with building in windows at the moment. Could you send me the latest compiled version? I don't have a Linux setup.
18th February 2019, 04:29 PM |#5707  
a.raul's Avatar
Senior Member
Flag Mordor
Thanks Meter: 511
 
More
Quote:
Originally Posted by Carotix

thanks my friend ,
i already tried 2.2.2 version and i deleted the duplicated lines but doesn't help .. there are other problems after ...
do you know which version of apktool i can use?

Good afternoon, I leave the styles.xml of origin and the modified eliminating the lines to be able to compile the framewor-res.apk in Samsung Beta Pie, decompiled and compiled with apktool 2.3.4

Regards
Attached Files
File Type: xml styles_mod.xml - [Click for QR Code] (597.4 KB, 40 views)
File Type: xml styles_origen.xml - [Click for QR Code] (598.0 KB, 18 views)
23rd February 2019, 09:14 AM |#5708  
Lanchon's Avatar
Senior Member
Thanks Meter: 4,484
 
Donate to Me
More
Quote:
Originally Posted by Azazel6002

Trying compile systemui.apk getting this error

Exception in thread "main" org.jf.util.ExceptionWithContext: Exception occurred while writing code_item for method [...]

How do I fix this?

i suggest you download the latest smali from JesusFreke's github, and try baksmali then smali your systemui.apk. it should reproduce the bug i guess. then try to repro using a single 'classes(#).dex' file from within systemui.apk (android APKs are zip files you can open with any zip tool). then create an issue in github with all the relevant data needed to repro (including the dex file, where the systemui.apk came from, etc), JF is very busy these days, but he'll look into well-reported bugs from time to time.
3rd March 2019, 11:53 AM |#5709  
iBotPeaches's Avatar
OP Recognized Developer
Flag Tampa
Thanks Meter: 4,330
 
Donate to Me
More
A new version has been released!

v2.4.0 (Released March 3rd, 2019)

Quote:

  • [#1893] - Updated baksmali/smali to v2.2.6
  • [#1918] - Fixed issue with new restriction with non-empty ids.xml file. (Thanks gino247)
  • [#1909] - Fixed issue with PlatformBuildVersion properties changing to unexpected values. (Thanks gino247)
  • [#1943] - Fixed issue with pending v5 Gradle upgrade, by taking point release v4.10.2. (Thanks Frieder Blumle)
  • [#1849] - Added no-crunch support via new parameters - -nc | --no-crunch. (Thanks Novex)
  • [#1975] - Added automatic tests on Windows environment.
  • [#1952] - Fixed issue when decoding .xsd files between aapt1/aapt2.
  • [#1976] - Fixed issue with decoding applications with a malformed chunk header. (Thanks sebras)
  • [#1996] - Fixed issue with Mac scripts stealing focus.
  • [#1893] - Fixed issue with array resource bag items having wrong type. (Thanks vbarthel-fr)
  • [#1994, #1922] - Updated baksmali/smali to v2.2.6
  • [#1522] - Fixed issue with 9patch images missing vertical or horizontal divs. (Thanks IgorEisberg)
  • Fixed issue with resolving references to non-standard framework files. (Thanks IgorEisberg)
  • Fixed issue with resolving SDK Version Codes that were references. (Thanks IgorEisberg)
  • Added 32bit binaries for unix and win for aapt1/aapt2.
  • Added ability for api-level to be passed to smali. (Thanks IgorEisberg)

Download: https://bitbucket.org/iBotPeaches/ap...tool_2.4.0.jar
md5 - 327b9389153ea29509963878e69012e4
sha256 - a0f116e8916d6f21160e1559847bb8b8c32ee71900f321cafe adbe37b87ebcc1

Details of Release: https://connortumbleson.com/2019/03/...-4-0-released/
The Following 26 Users Say Thank You to iBotPeaches For This Useful Post: [ View ]
10th March 2019, 08:23 AM |#5710  
Senior Member
Thanks Meter: 9
 
More
can't compile framework-res.apk,([ROM][9.0] Android Open Source Illusion Project [OFFICIAL]--honor view 10)
apktool d framework-res.apk (successed)
apktool b framework-res(failed)
try many times, it's failed. even if I didn't change anything to back-compile
please rename framework-res.7z.apk to framework-res.7z and unzip it
Attached Files
File Type: txt log.txt - [Click for QR Code] (35.2 KB, 106 views)
File Type: apk framework-res.7z.apk - [Click for QR Code] (10.87 MB, 332 views)
10th March 2019, 08:38 PM |#5711  
Thebear j koss's Avatar
Senior Member
Flag NYC
Thanks Meter: 20,984
 
More
Quote:
Originally Posted by lovekobeme

can't compile framework-res.apk,([ROM][9.0] Android Open Source Illusion Project [OFFICIAL]--honor view 10)
apktool d framework-res.apk (successed)
apktool b framework-res(failed)
try many times, it's failed. even if I didn't change anything to back-compile
please rename framework-res.7z.apk to framework-res.7z and unzip it

All the log says is failed. Lmao. Need a complete log with errors of why it failed.

Sent from my PH-1 using Thebear Blue XDA Labs
The Following 2 Users Say Thank You to Thebear j koss For This Useful Post: [ View ] Gift Thebear j koss Ad-Free
Post Reply Subscribe to Thread

Tags
apktool, apktools, customise apk, decompile, edit apk, recompile, reverse

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes