FORUMS
Remove All Ads from XDA

[Q] Disable Shift + Space = Lang on Keyboard dock?

2 posts
Thanks Meter: 0
 
By tntc, Junior Member on 24th February 2011, 08:49 AM
Post Reply Email Thread
I just bought my Galaxy Tab yesterday, and it's pretty awesome. I also bought the keyboard dock, and it's excellent except for one super annoying problem: If you hit space while holding shift, it changes the language. In my case, it doesn't do anything (Just says ENGLISH on the screen), but it's really annoying to have that pop up every time I type a sentence with caps or punctuation in it.

For example: Typing "WOW! THIS IS AWESOME!" would be easy. You just hold shift while typing the whole sentence. On the tab, at every space it acts as though I have pressed the Lang key on the keyboard. This only happens with the hardware keyboard.

I did some mucking around in system files (/system/usr/keylayout/), and noticed p1_keyboard.kl, but only the actual Lang key is mapped to LANG. When I commented that line out, my Lang key was disabled, but the Space+Shift still "worked" and popped "English" up on my screen. The Freedom Pro drivers have an option to disable shift+space, but the regular samsung keyboard does not. Any idea how to get rid of this incredibly annoying behavior?

Edit: I just noticed that this "feature" is documented in the manual. No way to disable it is mentioned.
 
 
1st March 2011, 02:29 AM |#2  
OP Junior Member
Thanks Meter: 0
 
More
Just a quick update: I've contacted Samsung Support via twitter, but they didn't have a galaxy tab available with a keyboard dock. Seriously. Samsung Support didn't have a galaxy tab with external keyboard to even test the issue. I'm trying e-mail next. Frankly, having shift+space change the language when there is a language button RIGHT NEXT TO THE SPACEBAR is insane.

I think I have to make my own solution to this one. Of course, I can't post in the developers section yet, so I can't really ask for help there either. I'm fairly certain that the solution isn't /system/usr/keylayout/p1_keyboard.kl because, while there is a LANG button mapped, disabling it merely disables the actual LANG button on the keyboard. Shift + Space continues to switch the language.

This is literally making me not use the keyboard, because if I type "I", and hold shift a bit too long, ENGLISH shows up on my screen. If I'm typing a sentence with lots of caps or acronyms, ENGLISH is on the screen pretty much the entire time because I'm holding shift. Any help at all would be appreciated.
27th September 2011, 08:37 PM |#3  
Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by tntc

Just a quick update: I've contacted Samsung Support via twitter, but they didn't have a galaxy tab available with a keyboard dock. Seriously. Samsung Support didn't have a galaxy tab with external keyboard to even test the issue. I'm trying e-mail next. Frankly, having shift+space change the language when there is a language button RIGHT NEXT TO THE SPACEBAR is insane.

I think I have to make my own solution to this one. Of course, I can't post in the developers section yet, so I can't really ask for help there either. I'm fairly certain that the solution isn't /system/usr/keylayout/p1_keyboard.kl because, while there is a LANG button mapped, disabling it merely disables the actual LANG button on the keyboard. Shift + Space continues to switch the language.

This is literally making me not use the keyboard, because if I type "I", and hold shift a bit too long, ENGLISH shows up on my screen. If I'm typing a sentence with lots of caps or acronyms, ENGLISH is on the screen pretty much the entire time because I'm holding shift. Any help at all would be appreciated.

Did you by chance get any answers to this issue? I am having the same issue and it's driving me nuts. Almost every sentence that I write I have to backspace and start over.
1st October 2015, 06:41 PM |#4  
Member
Flag Chino Hills, CA
Thanks Meter: 4
 
More
Hey everyone, I came across this post while searching for a way to disable the SHIFT+SPACE keyboard shortcut (Stupid!).
So, while it's default in Samsung Keyboard, other keyboards allow other options. I installed "Google keyboard", and now everything works great, and I don't have the annoying popup everytime I hold shift too long before a space!
11th April 2018, 06:53 PM |#5  
Junior Member
Thanks Meter: 1
 
More
Hello, I'm resurrecting this thread because shift space is still an issue in Samsung Keyboard. Gboard (what Google Keyboard is called now) solved this problem for me, too. -- Ronald Althenn, former Samsung call center analyst
12th April 2018, 07:32 PM |#6  
Junior Member
Thanks Meter: 0
 
More
I've installed GBoard, but Samsung Keyboard shortcuts still work. When I look at keyboard setting for my physical keyboard, I can see that both keyboard layouts (GBoard & Samsung) are present. I can't seem to find a way to force my device (Note 8) to only use GBoard layout.

Thoughts?
7th November 2018, 01:35 PM |#7  
Junior Member
Thanks Meter: 1
 
More
Sorry for the late reply. I dropped my phone recently and started having that same issue. Even with gboard installed, I am never going to need to change my language using shift space, ever, and yet even when I'm using sidesync just so I can see my screen, English pops up all the time and eats up my space. I am trying to find other ways of fixing this. I will post again soon.

---------- Post added at 02:35 PM ---------- Previous post was at 02:27 PM ----------

Okay, I think I've got it. When there is an external keyboard attached in sidesync, you must use the Select Keyboard notification and choose Gboard. This is where the proper command hooks get installed. Shift space comes out as a space when I type using gboard. If you have a "Select External Keyboard" notification, don't change it there, because shift space still popped up English for me until I used the first notification.

This is insanely complicated, I know. I wish I was a Samsung dev; I'd submit a change to fix that. I'll have a job soon, I hope.
The Following User Says Thank You to ralthenn For This Useful Post: [ View ] Gift ralthenn Ad-Free
28th March 2019, 10:02 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Please upvote
This issue reported in Samsung US Community, please upvote to have it fi.xed:
please google
Physical Keyboard: Shift+Space triggering language change makes external keyboard impossible to use "Communuity" "Samsung"


Quote:
Originally Posted by tntc

I just bought my Galaxy Tab yesterday, and it's pretty awesome. I also bought the keyboard dock, and it's excellent except for one super annoying problem: If you hit space while holding shift, it changes the language. In my case, it doesn't do anything (Just says ENGLISH on the screen), but it's really annoying to have that pop up every time I type a sentence with caps or punctuation in it.

For example: Typing "WOW! THIS IS AWESOME!" would be easy. You just hold shift while typing the whole sentence. On the tab, at every space it acts as though I have pressed the Lang key on the keyboard. This only happens with the hardware keyboard.

I did some mucking around in system files (/system/usr/keylayout/), and noticed p1_keyboard.kl, but only the actual Lang key is mapped to LANG. When I commented that line out, my Lang key was disabled, but the Space+Shift still "worked" and popped "English" up on my screen. The Freedom Pro drivers have an option to disable shift+space, but the regular samsung keyboard does not. Any idea how to get rid of this incredibly annoying behavior?

Edit: I just noticed that this "feature" is documented in the manual. No way to disable it is mentioned.

Post Reply Subscribe to Thread

Tags
galaxy, keyboard, problem, samsung, tab

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes