FORUMS
Remove All Ads from XDA

Fix wifi mac address problem u8800

37 posts
Thanks Meter: 11
 
By RajuMon, Member on 13th December 2013, 08:53 AM
Post Reply Email Thread
27th December 2014, 04:00 PM |#11  
Blefish's Avatar
Senior Member
Flag Paluküla, Hiiumaa
Thanks Meter: 2,940
 
Donate to Me
More
Quote:
Originally Posted by mohammad.nomaan

Hi
Tried both DFS.exe and DFS demo. I can see the updated IMEI on the device but the phone still doesn't show updated wifi
any suggestions
Thanks for helping on the IMEI part

Try switching the OTP NV filters on/off etc. I had similar issue on U8860 and somehow I was able to write all the info back eventually. I don't remember what I specifically changed though. Great to know IMEI is back though!
 
 
27th December 2014, 04:50 PM |#12  
mohammad.nomaan's Avatar
Senior Member
Flag Manama
Thanks Meter: 142
 
More
Quote:
Originally Posted by Blefish

Try switching the OTP NV filters on/off etc. I had similar issue on U8860 and somehow I was able to write all the info back eventually. I don't remember what I specifically changed though. Great to know IMEI is back though!

Thanks Blefish,
The IMEI is back as I wanted
I tried that option as well. As you can see on the screenshot, I see the WiFi keys in the application as before but the same does not show on my device.
Tried both OTP NV Enable & Disable but still the same result.
If you recommend, ill flash the official update again if that can bring back the wifi keys or else ill leave it as it coz your Ideos Setting app does have that option and you I hope we will have it in CM12 as well

EDIT
DFS Demo helped in ficing WiFi keys. NV option helps as Blefish pointed out
Now all if fine - IMEI & WIFI
thanks a lot for your help and assistance
Attached Thumbnails
Click image for larger version

Name:	DFS_Demo_U8800.jpg
Views:	154
Size:	101.4 KB
ID:	3084406  
30th December 2014, 10:04 AM |#13  
JekaPinsk's Avatar
Senior Member
Thanks Meter: 174
 
More
Quote:
Originally Posted by Blefish

Try switching the OTP NV filters on/off etc. I had similar issue on U8860 and somehow I was able to write all the info back eventually. I don't remember what I specifically changed though. Great to know IMEI is back though!

Hi Blefish, I would like to know if your SN is correct (in settings) after using DFS.
On my Honor I have everyting OK only when I restore it via 5iromtoolbox, but I cant flash any rom except B939 after that
I wonder if you have SN the same as MAC in settings, too
30th December 2014, 12:15 PM |#14  
Blefish's Avatar
Senior Member
Flag Paluküla, Hiiumaa
Thanks Meter: 2,940
 
Donate to Me
More
Quote:
Originally Posted by JekaPinsk

Hi Blefish, I would like to know if your SN is correct (in settings) after using DFS.
On my Honor I have everyting OK only when I restore it via 5iromtoolbox, but I cant flash any rom except B939 after that
I wonder if you have SN the same as MAC in settings, too

In my U8800 everything is ok, however, U8860 had zero imei and zero BT/MAC address (which was set to a random one). The serial number shown in the projectmenu tool (Huawei firmware stock) shows correct serial number (the 16 digit one, same as on the phone behind the battery).

In U8800pro/U8860 ICS release, Huawei is using the Settings->Status serial number same as MAC address. If the serial number shows unknown, MAC addresses are incorrect too.
30th December 2014, 01:21 PM |#15  
JekaPinsk's Avatar
Senior Member
Thanks Meter: 174
 
More
Quote:
Originally Posted by Blefish

In U8800pro/U8860 ICS release, Huawei is using the Settings->Status serial number same as MAC address. If the serial number shows unknown, MAC addresses are incorrect too.

On B919 my MAC was ok bun SN was unknown
30th December 2014, 02:06 PM |#16  
Blefish's Avatar
Senior Member
Flag Paluküla, Hiiumaa
Thanks Meter: 2,940
 
Donate to Me
More
Quote:
Originally Posted by JekaPinsk

On B919 my MAC was ok bun SN was unknown

BT MAC aswell? I don't remember which one it used.
30th December 2014, 03:07 PM |#17  
JekaPinsk's Avatar
Senior Member
Thanks Meter: 174
 
More
Quote:
Originally Posted by Blefish

BT MAC aswell? I don't remember which one it used.

Yes. Until I made changes to BT MAC it showed nothing, but now I have it working.
PS: Why new branches?
30th December 2014, 06:47 PM |#18  
Blefish's Avatar
Senior Member
Flag Paluküla, Hiiumaa
Thanks Meter: 2,940
 
Donate to Me
More
Quote:
Originally Posted by JekaPinsk

Yes. Until I made changes to BT MAC it showed nothing, but now I have it working.
PS: Why new branches?

For TWRP (and maybe more) .
The Following User Says Thank You to Blefish For This Useful Post: [ View ] Gift Blefish Ad-Free
29th April 2019, 01:34 AM |#19  
Junior Member
Thanks Meter: 0
 
More
Hello guys,

my U8800-51 is on the latest LegacyHuawei CyanogenMod 11.0 by Mr Blefish but i ended up without no WIFI MAC and BLuetooth. So i tried as stated on this post to downgrade to android 2.3 but when it gets to part 2/2 of the installation, gives me an error... Then, i proceeded to use DFS v14 to try to write the MAC adress (still on CyanogenMod) but it failed to find the COM PORT through PC (ADB install correct and showing the device, USB debuggin enable). The only way i managed to see the port in the device manager and DFS is tu putting the phone on the PINK SCREEN (Download mode, right?). but, DFS throw me some errors like CPS_BPSR and so on.

I also tried enabling DIAG port through ADB but didn't work.

So far, it has failed... But maybe you can help me.

I understand this is a very old phone, but i live in a 3rd world country where phones are ver expensive (not to mention an Hyperinflation process that we are living through). So, i have to try everything to save it.

Thanks in advance for you help

Regards
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes