FORUMS
Remove All Ads from XDA

[Kitkat] CM11 Android 4.4.4 for the Droid X (2015)

1,390 posts
Thanks Meter: 1,246
 
By Aaahh, Senior Member on 5th March 2014, 03:26 AM
Post Reply Email Thread
16th April 2019, 05:59 PM |#3391  
Quote:
Originally Posted by Bobcus Leper

Good to have you back! Unfortunately I recycled my DX last year, due to hardware failures...

Thats ok. I was completely unplugged, but I still have mine and decided to try something out. I noticed some recent activity here and got to tinkering as I update my old devices. I will say that it is a CM11 update, and not CM12/12.1.
The Following 2 Users Say Thank You to palmbeach05 For This Useful Post: [ View ] Gift palmbeach05 Ad-Free
 
 
2nd May 2019, 10:20 AM |#3392  
The update i had mentioned is good to go, but not uploaded yet. Having issues with gapps. Anyone want to try to help out with this? I have no issue uploading the update.
2nd May 2019, 10:27 AM |#3393  
Senior Member
Thanks Meter: 167
 
More
Quote:
Originally Posted by palmbeach05

The update i had mentioned is good to go, but not uploaded yet. Having issues with gapps. Anyone want to try to help out with this? I have no issue uploading the update.

Not a pro, but do know gapps is likely no longer supported for much anything prior to KitKat. Maybe even invluding KK by now. I've ceased the periodic powering up and updating the 2 LG Allys, DX, and DX2 I have. It was too much a struggle for their wee processors to handle.

Sent from my LM-V405 using Tapatalk
2nd May 2019, 10:39 AM |#3394  
Quote:
Originally Posted by Einsteindks

Not a pro, but do know gapps is likely no longer supported for much anything prior to KitKat. Maybe even invluding KK by now. I've ceased the periodic powering up and updating the 2 LG Allys, DX, and DX2 I have. It was too much a struggle for their wee processors to handle.

I've looked into that yes. They are still supporting 4.1 and up, but you have to go track down those specific app updates. Most of the focus is, as you hint at, is aimed at 5.0 and higher. It could very well be a processor thing with the newer 4.4 updated gapps. I'm not ruling anything out. But, as i mentioned earlier, i was away for a bit of time, and i'm trying to give back to the dev community. If it (the gapps) is a dead end issue, i can accept that.
The Following User Says Thank You to palmbeach05 For This Useful Post: [ View ] Gift palmbeach05 Ad-Free
2nd May 2019, 12:38 PM |#3395  
Senior Member
Thanks Meter: 167
 
More
Quote:
Originally Posted by palmbeach05

I've looked into that yes. They are still supporting 4.1 and up, but you have to go track down those specific app updates. Most of the focus is, as you hint at, is aimed at 5.0 and higher. It could very well be a processor thing with the newer 4.4 updated gapps. I'm not ruling anything out. But, as i mentioned earlier, i was away for a bit of time, and i'm trying to give back to the dev community. If it (the gapps) is a dead end issue, i can accept that.

As time goes by, gapps gets bigger, and OE system partitions are too small to take even the basic of update packages. It surpassed selecting which stayed in, and which ones got converted to user opps.

Sent from my LM-V405 using Tapatalk
The Following User Says Thank You to Einsteindks For This Useful Post: [ View ] Gift Einsteindks Ad-Free
2nd May 2019, 01:59 PM |#3396  
Quote:
Originally Posted by Einsteindks

As time goes by, gapps gets bigger, and OE system partitions are too small to take even the basic of update packages. It surpassed selecting which stayed in, and which ones got converted to user opps.

That tells me what i should do, because i am seeing what you're talking about. There is a very noticeable difference in the sizes of the gapps. Even if i were to put pico gapps on this, still has an issue as pico jumps to a nearly 200mb zip (4-11-19).
3rd May 2019, 02:39 AM |#3397  
Senior Member
Thanks Meter: 167
 
More
Damned Google Play Services!

Sent from my LM-V405 using Tapatalk
7th May 2019, 11:58 AM |#3398  
*****CM11 Update*****

Ported from @Quarx's last release

Changelog
-Base: cm-11-20150112-UNOFFICIAL-shadow
-Port: cm11-20161124-NIGHTLY-mb52x
-Sync'd up to 11/24/2016
[email protected]m.ksy's and @Aaahh's 1/24/15 kernel
-Busybox updated to 1.30.1
-Supersu updated to Chainfire's SuperSU v2.82-SR5 (includes Pro option)
[email protected]oggie7797's init.d scripts added
-CM12's compatible music app added
-Areo Control (updated to v2.2.2), OmniSwitch, Seeder apps included
-cmdline updated to reflect mb52x builds

Install instructions
-Backup current CM11
-Wipe data, cache, dalvik, and system
-Flash rom
-DO NOT FLASH GAPPS
-Restore data only from your backup

NOTICE
As you all can see, there has been discussion regarding gapps. In the best interest of device performance, it is not recommended to flash any gapps package until a fix is found. Gmail should work if restored from backup.

Stagefright vulnerabilities still exist, as any attempt to port the patched system/lib files results in a bootloop.

Defy kernels (rom and recovery) do run, however it is not included. Camera borks, cdma signal disabled if included for ROM, vibration disabled if included for recovery.

Magisk not added, as I am still unsure if it would be fully compatible (bootstrap build vs standard boot.img build).

Download

https://drive.google.com/file/d/1nv_...w?usp=drivesdk
The Following User Says Thank You to palmbeach05 For This Useful Post: [ View ] Gift palmbeach05 Ad-Free
28th May 2019, 10:57 AM |#3399  
*****CM11 Update*****(Projected Final Release)*******

Ported from @walter79's last release

Changelog
-Base: cm-11-20150112-UNOFFICIAL-shadow
-Port: lineage-11-20180813-UNOFFICIAL-mb52x
-Sync'd up to 08/13/2018
@m.ksy's and @Aaahh's 1/24/15 kernel
-Busybox updated to 1.30.1
-Supersu updated to Chainfire's SuperSU v2.82-SR5 (includes Pro option)
[email protected]'s init.d scripts added
-CM12's compatible music app added
-Areo Control (updated to v2.2.2), OmniSwitch, Seeder apps included
-cmdline updated to reflect mb52x builds

Install instructions
-Backup current CM11
-Wipe data, cache, dalvik, and system
-Flash rom
-DO NOT FLASH GAPPS
-Restore data only from your backup

NOTICE
As you all can see, there has been discussion regarding gapps. In the best interest of device performance, it is not recommended to flash any gapps package until a fix is found. Gmail should work if restored from backup.

Stagefright vulnerabilities still exist, as any attempt to port the patched system/lib files results in a bootloop.

Defy kernels (rom and recovery) do run, however it is not included. Camera borks, cdma signal disabled if included for ROM, vibration disabled if included for recovery.

Magisk not added.

This is to be expected as the final update and/or port unless a repo sync and build from scratch is done.

Download

https://drive.google.com/open?id=1cR...trDqeoUoofvTdY
The Following User Says Thank You to palmbeach05 For This Useful Post: [ View ] Gift palmbeach05 Ad-Free
Post Reply Subscribe to Thread

Tags
cm11 4.4 kitkat, droidx

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes