FORUMS
Remove All Ads from XDA

[APP][2.0+] MiXplorer v6.x Released (fully-featured file manager)

5,498 posts
Thanks Meter: 28,734
 
By HootanParsa, Recognized Developer on 17th May 2011, 03:12 PM
Post Reply Email Thread
Today, 12:26 AM |#30351  
Senior Member
Thanks Meter: 265
 
More
[Bug Report]
Wrongly reported free space. (the operation succeeded without problem)
Impatient "TIMEOUT"... (the `cp` actually works, if given enough time)
Code:
I/MiX>  ----- Operation started ----------------------
I/MiX>  Action: COPY
D/COUNT>  Total: 984315281 bytes
W/Storage>  Not enough free space!
908.41 MiB/938.72 MiB
I/OPERATION>  #1 COPY ---------------------------------------
		SRC: /data/data/com.mixplorer.beta/0.mp4
		DST: /data/media/0/!
I/Root>  ls -ld "/data/media/0/!/0.mp4"
E/Root>  STD-E >> ls: /data/media/0/!/0.mp4: No such file or directory
D/OPERATION>  DIRECT COPY
I/Root>  cp -fp "/data/data/com.mixplorer.beta/0.mp4" "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
I/Root>  chmod 644 "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 8359ms. Try again!
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 12737ms. Try again!
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 17071ms. Try again!
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 21477ms. Try again!
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 27049ms. Try again!
WTF/Root>  Get file with delay >> NULL
W/MiX>  NULL or Dst length != Src length
D/OH:>  default
I/Root>  ls -ld "/data/media/0/!/0.mp4"
D/Root>  TIMEOUT
I/Root>  mv -f "/data/data/com.mixplorer.beta/cache/0.mp4_248665864332319" "/data/media/0/!/0.mp4"
I/Root>  ls -ld "/data/media/0/!/0.mp4"
I/Root>  chown 0:0 "/data/media/0/!/0.mp4"
I/Root>  ls -ld "/data/media/0/!/0.mp4"
I/Root>  chmod 644 "/data/media/0/!/0.mp4"
I/Root>  chown 0:0 "/data/media/0/!/0.mp4"
I/OPERATION>  #1 COPY DONE -------

W/Storage>  Not enough free space!
908.41 MiB/938.72 MiB
I/OPERATION>  #2 COPY ---------------------------------------
		SRC: /data/data/com.mixplorer.beta/1.mp4
		DST: /data/media/0/!
I/Root>  ls -ld "/data/media/0/!/1.mp4"
E/Root>  STD-E >> ls: /data/media/0/!/1.mp4: No such file or directory
D/OPERATION>  DIRECT COPY
I/Root>  cp -fp "/data/data/com.mixplorer.beta/1.mp4" "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
I/Root>  chmod 644 "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
I/Root>  ls -ld "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
I/Root>  ls -ld "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 8505ms. Try again!
I/Root>  ls -ld "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 13869ms. Try again!
I/Root>  ls -ld "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 18397ms. Try again!
I/Root>  ls -ld "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 22705ms. Try again!
I/Root>  ls -ld "/data/media/0/!/1.mp4"
D/Root>  TIMEOUT
WTF/Root>  File not exists! Time: 27878ms. Try again!
WTF/Root>  Get file with delay >> NULL
W/MiX>  NULL or Dst length != Src length
D/OH:>  default
I/Root>  ls -ld "/data/media/0/!/1.mp4"
I/Root>  ls -ld "/data/media/0/!/1.mp4"
I/Root>  chown 0:0 "/data/media/0/!/1.mp4"
I/OPERATION>  #2 COPY DONE -------
	 
I/MiX>  Copied 2 files
1m 55s
I/MiX>  ----- Operation finished. 1m 55s -------------
And "root_direct_copy" seemed only work on the real file system?..
On fuse, the old method is used regardless of the flag.

* And what's the cause of them?.. (blocking execution?..)
`ls -ld` worked fine with ongoing `cp`. (tested the very commands in shell, using MiX's busybox)
The Following 2 Users Say Thank You to gdgsdg123 For This Useful Post: [ View ] Gift gdgsdg123 Ad-Free
 
 
Today, 12:32 AM |#30352  
IronTechmonkey's Avatar
Recognized Contributor
Thanks Meter: 7,879
 
More
Quote:
Originally Posted by onlytanmoy

@Hootan Parsa I am using the latest v6.38.0, when I go to music from the left side panel and select some songs and then open with Rocketplayer, it will just play the first song and stop after playing, it won't move to the next track. Please can something be done about this?

I've been meaning to post about what may (or may not) be a loophole in that restriction by Google and this seems a reasonable time to do so but first some FYI regarding the history of this report:

This first came up in this thread last July 2018 https://forum.xda-developers.com/sho...ostcount=25291, where it may have been related to an issue with text files reported reported by @pocketrule here http://forum.xda-developers.com/show...ostcount=25290. It was then emphasized and reported directly to HP here: https://forum.xda-developers.com/sho...ostcount=27759, and here with a quote from the developer of Tasker about it in January 2019 https://forum.xda-developers.com/sho...ostcount=27764.

Along the way HP seemed to have been able to work around it and MiX offered us more access than other apps did under the restriction. Sadly most of the loopholes seem to have closed but I still see one: The image viewing app "Simple Tools Gallery Pro" is able to scroll through images in the same folder as the image that was opened from MiX to Simple Gallery, hence this question:

@HootanParsa, if there are no more of your magical workarounds which could be applied to this scenario, do you know if this is something that the receiving app could do something to support, even if specifically related to MiX? If this is possible at all, then there is some incentive for those developers to do so as it allows people to user their app more freely and it might be worth asking them (which I might do depending on what you think).
The Following 3 Users Say Thank You to IronTechmonkey For This Useful Post: [ View ] Gift IronTechmonkey Ad-Free
Today, 01:20 AM |#30353  
Junior Member
Thanks Meter: 2
 
More
On Oreo I got continuous view redraws (also with an empty folder). Tried different settings, reinstallation but didn't help.

[%CPU]
41.6 com.mixplorer
16.3 msurfaceflinger
8.3 [email protected]
The Following 2 Users Say Thank You to Mizun For This Useful Post: [ View ] Gift Mizun Ad-Free
Today, 07:32 AM |#30354  
Senior Member
Flag Singapore
Thanks Meter: 188
 
More
Is there a setting in v6.39.0-Beta_B19062610 to get the old icons back?
The Following 2 Users Say Thank You to neekless For This Useful Post: [ View ] Gift neekless Ad-Free
Today, 08:10 AM |#30355  
HootanParsa's Avatar
OP Recognized Developer
Thanks Meter: 28,734
 
More
Quote:
Originally Posted by duh1

Bug in most recent version 6.38.0 (with Allow Root on) -- previously had setting Update Media Store (after each operation) turned on without issue. Now when I do any operation, such as rename or move, on some APK files, a second later it jumps to the install screen, even bypassing Open With dialog and without permission for MiXplorer to install APKs. When Update Media Store is turned off, the issue stops...

Could you please try again to make sure it's not happening when you disable 'Update Media Store'? Thanks.
The Following User Says Thank You to HootanParsa For This Useful Post: [ View ]
Today, 09:32 AM |#30356  
Senior Member
Thanks Meter: 265
 
More
Quote:
Originally Posted by neekless

Is there a setting in v6.39.0-Beta_B19062610 to get the old icons back?

Skin config, "THUMB_ROUNDED_CORNER", 100%.
Post Reply Subscribe to Thread

Tags
chm, cloud, encfs, epub, mix

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes