FORUMS
Remove All Ads from XDA

Help needed.... My Nook HD+ shows error during registration.

26 posts
Thanks Meter: 1
 
By mashac, Junior Member on 11th September 2013, 10:41 AM
Post Reply Email Thread
Hi friends, I got my Nook HD+ today(India). The first time I turn it on, it prompted to install a critical update. I connected it to my wifi network and it downloaded and updated fine. After updating, at the registration process it again checked for critical updates and from this time onwards it keep saying that

" Network Problem: A network-related error occurred. You may have lost connectivity to the local wireless network. Press continue and we'll try to test your connection"

When I press continue it shows " Checking connection" and then detect my wifi fine (Signal strength shows excellent). Then again when I click "continue with setup", this whole procedure is repeating. My Galaxy tab 2 and Laptop are working fine with the same wifi network.

Please, some experts help me about what to do. I'm clueless about what to do next.
 
 
11th September 2013, 11:29 AM |#2  
artesea's Avatar
Senior Member
Flag Lincoln
Thanks Meter: 86
 
More
There is a known issue with the latest stock Nook firmware moaning about loss of wireless.
Are you able to skip these steps for the time being?
Otherwise I would suggest just flashing one of the Cyanogenmod firmwares instead.
11th September 2013, 11:34 AM |#3  
OP Junior Member
Thanks Meter: 1
 
More
Thanks for the reply artesea. No, I can't skip those steps. All it does is booting to the same procedure again and there is no option to skip. Is it worth waiting for this problem to get fixed by B&N? I really wanna experience the stock OS.
11th September 2013, 12:26 PM |#4  
artesea's Avatar
Senior Member
Flag Lincoln
Thanks Meter: 86
 
More
From what others are saying it looks like B&N might have a server down, once it's back up it should just start to work. However if the latest firmware is pointing in the completely wrong direction (IP or domain they don't own) then it might require a firmware patch. Not sure if the device will update if you aren't getting past the reg screens. But a flashable file should be available either direct from them, or someone on these forums.
Keep an eye on this thread where it was first reported
http://forum.xda-developers.com/show....php?t=2431280
11th September 2013, 05:29 PM |#5  
OP Junior Member
Thanks Meter: 1
 
More
Thanks artesea. One more question. Does doing the factory reset and turning off the wifi will allow me to use the device without registering?
11th September 2013, 06:22 PM |#6  
leapinlar's Avatar
Senior Member
Thanks Meter: 3,880
 
Donate to Me
More
Quote:
Originally Posted by mashac

Thanks artesea. One more question. Does doing the factory reset and turning off the wifi will allow me to use the device without registering?

There is a way to skip registration. Look at my HD/HD+ Tips thread linked in my signature and look for the item about skipping OOBE.

Sent from my Nook HD+ running CM10.1 on emmc.
11th September 2013, 06:48 PM |#7  
OP Junior Member
Thanks Meter: 1
 
More
Thanks artesea and leapinlar for the help. My Nook HD+ detected my wifi again out of nowhere and after another update I successfully registered my device. Thanks again guys.
13th February 2019, 10:25 PM |#8  
Junior Member
Thanks Meter: 0
 
More
Mine is doing the same thing on February 13, 2018. Really making me mad. Any help is appreciated.
19th July 2019, 04:02 PM |#9  
Junior Member
Thanks Meter: 0
 
More
Mine is doing the same thing and it was working fine until then I thought I had to do something with the nook itself so I factory reset it. Now it will not connect to my wifi at all I have even tried my hotspot on my phone but it didn't work. My nook has worked fine up until this point and I have had it for over 5 years. I know it has nothing to do with my battery because I just replaced it at the beginning of this year. It just makes me mad that it will not connect to my wifi.
10th August 2019, 09:22 PM |#10  
Junior Member
Thanks Meter: 0
 
More
Can't get past the 'Network Problem' error
I seem to have the same problem as the OP of this thread. I cannot get past a prompt on the stock ROM setup of my Nook HD+ where it says a network-related error has occurred. I'm connected to my home wi-fi just fine but setup will not go past this error. From what I've read it's caused by a security patch needing to be installed on the Nook. In the past, it updated automatically from an OTA update released by B&N but that is not happening any more. Have had it plugged in for days with no update occurring.

Have downloaded the patch file from B&N's website but I can't manually install it because Windows cannot recognize the Nook as a USB device. Have tried updating drivers, uninstalling/reinstalling the device in Windows but nothing works. If I could get that to work, apparently I can just drag & drop the file onto the Nook in Windows and it will install and update the Nook.

So, if anyone can offer a solution to my problem, it would be GREATLY appreciated. I went back to stock ROM because after trying Cyanogen & Lineage the Nook was just too slow to run either one successfully.

Solved: Right after I posted this, I found what is apparently a newer version of the stock ROM than I had previously installed. In case anyone needs this stock ROM it's in the [Stock][Android 4.0.4 ICS] Nook HD/Nook HD+ [Hummingbird/Ovation] 2.2.1 [2018 Update] thread. After installing it, setup went flawlessly and I'm back to full stock ROM. Thanks to secretwolf98 for posting this!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes