FORUMS
Remove All Ads from XDA

[SHARE] Xperia M : C1904 15.1.C.1.17 Stock Indian Generic Firmware .ftf

841 posts
Thanks Meter: 536
 
By jereMarfil24, Senior Member on 30th September 2013, 08:52 AM
Post Reply Email Thread
18th November 2013, 02:47 AM |#11  
Senior Member
Flag bangalore
Thanks Meter: 65
 
More
Quote:
Originally Posted by jereMarfil24

Introduction:-


Hello Friends .. I have shared you stock indian firmware for Xperia M single SIM : C1904

This build is major update and having major fixes and more stability also its smooth then .A. build


Disclaimer:-


I'm not taking any responsibility if you brick your device while flashing your device

You are doing this your own risk.

Skip this , If you don't want to soft brick.

I Hope you have read this carefully, Now move to next steps :

Downloads :-

Firmware :

<< Read More >>

Direct Download : Google Docs - Click Here to Download !!

Direct Download : MEGA - Click Here to Download !

Torrent Download : Click Here to Download !!

Requirement :-

Flashtool

Firmware

Instructions:-

First install flashtool

Now Copy the firmware

And Paste it to /C://flashtool/firmwares Then open flashtool

And Click to flash the device (thunder icon)

Now select Flashmode

And now select the firmware and flash it

Now it will say to connect your device via fashmode then follow it

It will take 2 or 3 minutes to complete the flashing process. Device will take some time to load and it will stay at Sony logo for long period. So don’t worry be patience the device will loaded without any problems.

And You're Done ! Your Device is flashed , Enjoy !

I Hope that this Guide and post helped you

Credits :-

Ram Prasad For making ftf , torrent file

Waledac for making mirror downloads : MEGA , Google Docs

Me for sharing them :P

Thanks bro,this fw really helped me

Sent from my C1904 using XDA Premium 4 mobile app
 
 
3rd October 2015, 01:28 PM |#12  
Junior Member
Thanks Meter: 0
 
More
I Got A Problem My Xperia C1904 Is Decrypted Its Say "Type Password To Decrypt Storage" So I Tried Flashing With The Firmware With Flashtool But Its Say's There Is An Error In "KERNEL.SIN ERROR"
What Should I Do? Please Help.
7th October 2015, 11:24 AM |#13  
Senior Member
Thanks Meter: 3
 
More
Quote:
Originally Posted by Arsalansarkar3d

I Got A Problem My Xperia C1904 Is Decrypted Its Say "Type Password To Decrypt Storage" So I Tried Flashing With The Firmware With Flashtool But Its Say's There Is An Error In "KERNEL.SIN ERROR"
What Should I Do? Please Help.

Same problem is there wid me , so I have tried the process to unbrick it , all the things were going properly but suddenly errors were coming , can someone please help me in this ..??:what:
Thanks
Attached Thumbnails
Click image for larger version

Name:	1444213462042.jpg
Views:	152
Size:	68.1 KB
ID:	3498578  
11th August 2019, 12:40 AM |#14  
Junior Member
Thanks Meter: 0
 
More
Hi my friends firs of all thank you for all your sipport and the links here .
i have a problem when i finish flashing my phone takes to long loading.... it keeps showing the screen where the coloring clouds are is been more than 30 minutes and it keeps showing the same screen is it normal ? i have tried others ftf file for my xperia m c1904 some i get errors while flashing others phone dont turn on and this one flashing was all ok no errors shown but my cellphone keeps loading on coloring clouds any help please!!!!!
19th August 2019, 02:08 AM |#15  
Junior Member
Thanks Meter: 0
 
More
another error
hi friends let me tell you i just manage to install the firmware to my xperia c1904 but all links i found on the net even here in te forums didn´t worked for me maybe because Flashtool dont know why but the only firmware i installed was for the c1905 people here says it works for both c1905 and c1904 but couldnt install it with the newest vercion of flashtool the one worked for me was the version 0.9.0.22.3 built on 08-06-2016, with this vercion i did flash my cellphone and it worked but in like a week is been like 8 days since i flash it and got the problem again the cellphone ran out of battery so it turned off the i charge it to full and when i turned on i got the coloring clouds loop can´t pass that screen right now i just re flash it again and the phone is back again but i hope this time keeps it like it is working thank you all hope you understand me
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes