FORUMS
Remove All Ads from XDA

[APP][ROOT] LMT Launcher v2.9

1,767 posts
Thanks Meter: 6,679
 
By noname81, Senior Member on 2nd November 2011, 09:51 PM
Post Reply Email Thread
14th November 2019, 10:30 AM |#14061  
OP Senior Member
Thanks Meter: 6,679
 
More
Quote:
Originally Posted by shaggyskunk

Actually - LMT IS working - But using the same Settings for Activation Position & Gravity - LMT is opening - But in a slightly different position than expected... 🐧

So you're talking about a y offset problem, when you bring up the pie? Then I know what you're talking about and I'll try to fix it. This happens on phones with a notch. The Android framework has some weird handling for it and I'll try to work around it in all use cases.
The Following 4 Users Say Thank You to noname81 For This Useful Post: [ View ] Gift noname81 Ad-Free
14th November 2019, 01:26 PM |#14062  
shaggyskunk's Avatar
Recognized Contributor
Flag IDK
Thanks Meter: 15,810
 
More
Quote:
Originally Posted by noname81

So you're talking about a y offset problem, when you bring up the pie? Then I know what you're talking about and I'll try to fix it. This happens on phones with a notch. The Android framework has some weird handling for it and I'll try to work around it in all use cases.

I think that we're talking about the same thing - Except the S10+ doesn't have a notch - just the ugly hole in the screen.

I've posted a screen shot which shows where the Activation area is set in LMT & the red dot marks where it seems to actually be active - LMT is definitely working - It's just taking a bit of time to get used to when it's actually responding to a swipe... I hope that explains things?

Sent from my SM-G975U using XDA Labs
Attached Thumbnails
Click image for larger version

Name:	14 November 2019 072234 GMT-0500.jpg
Views:	532
Size:	151.1 KB
ID:	4876041  
The Following 2 Users Say Thank You to shaggyskunk For This Useful Post: [ View ] Gift shaggyskunk Ad-Free
14th November 2019, 05:27 PM |#14063  
Junior Member
Flag Delhi
Thanks Meter: 7
 
More
Quote:
Originally Posted by noname81

Can all you guys with issues provide a logcat? It seems that lmt has issues on multiple Android 10 devices, but since it's not happening on my phone, I need more input to track down the issue. Thanks!

The issue is that whenever I provide root access to LMT, it starts crashing and fails to launch after the next start (works fine until the app is not killed/phone is not rebooted).

PFA logcat. Let me know if something else is needed.

Thanks.
Attached Files
File Type: txt logcat.txt - [Click for QR Code] (2.1 KB, 10 views)
14th November 2019, 06:12 PM |#14064  
OP Senior Member
Thanks Meter: 6,679
 
More
Quote:
Originally Posted by s7dhansh

The issue is that whenever I provide root access to LMT, it starts crashing and fails to launch after the next start (works fine until the app is not killed/phone is not rebooted).

PFA logcat. Let me know if something else is needed.

Thanks.

I don't see a cause for the crash in the logcat. I see battery utils and lmt in the logcat though. Could it be, that you have to whitelist/exclude lmt in your battery optimization settings?
The Following User Says Thank You to noname81 For This Useful Post: [ View ] Gift noname81 Ad-Free
14th November 2019, 06:55 PM |#14065  
Junior Member
Flag Delhi
Thanks Meter: 7
 
More
Quote:
Originally Posted by noname81

I don't see a cause for the crash in the logcat. I see battery utils and lmt in the logcat though. Could it be, that you have to whitelist/exclude lmt in your battery optimization settings?

Yes, I too was not able to figure out anything. The logcat is mostly same for root and non-rrot lmt start. But the app crashes. I have tried your whitelisting suggestion, but it did not help. If you have any other ideas to see more logs somehow, I can try that. I have so far used Logcat Extreme and Logcat Reader for the logs - both giving same results.
The Following User Says Thank You to s7dhansh For This Useful Post: [ View ] Gift s7dhansh Ad-Free
15th November 2019, 11:04 AM |#14066  
Senior Member
Thanks Meter: 730
 
More
Quote:
Originally Posted by s7dhansh

Yes, I too was not able to figure out anything. The logcat is mostly same for root and non-rrot lmt start. But the app crashes. I have tried your whitelisting suggestion, but it did not help. If you have any other ideas to see more logs somehow, I can try that. I have so far used Logcat Extreme and Logcat Reader for the logs - both giving same results.

In MatLog you can change Log Level. Maybe that can give a more detailed log?
The Following User Says Thank You to Artim_96 For This Useful Post: [ View ] Gift Artim_96 Ad-Free
21st November 2019, 03:17 AM |#14067  
Senior Member
Thanks Meter: 4
 
More
Update - I resigned myself to getting used to the new way of LMT - better LMT than no LMT right? But I just restarted my tab S4 and boom! LMT was off but when I turned it back on it behaved like normal. Properly unfurling around my thumb or finger instantly! Woooo! I didn't do anything special, just restarted the tablet like countless other times.

Quote:
Originally Posted by minionhunter

Thank you!

I wound up just uninstalling it and reinstalled it. It didn't fix the behavior. It's weird, it kind of slides out from the place I touch and doesn't unfurl.

I would love to get it to stop that and just do the unfurl.

---------- Post added at 09:28 AM ---------- Previous post was at 09:19 AM ----------



Thank you!

I wound up just uninstalling it and reinstalled it. It didn't fix the behavior. It's weird, it kind of slides out from the place I touch and doesn't unfurl.

I would love to get it to stop that and just do the unfurl.



---------- Post added at 09:08 PM ---------- Previous post was at 09:06 PM ----------

Quote:
Originally Posted by shaggyskunk

I think that we're talking about the same thing - Except the S10+ doesn't have a notch - just the ugly hole in the screen.

I've posted a screen shot which shows where the Activation area is set in LMT & the red dot marks where it seems to actually be active - LMT is definitely working - It's just taking a bit of time to get used to when it's actually responding to a swipe... I hope that explains things?

Sent from my SM-G975U using XDA Labs

I've seen that on my Tab S4, it stays until I use the side and then it is gone.

---------- Post added at 09:17 PM ---------- Previous post was at 09:08 PM ----------

I have one bug in my current Tab S4 with LMT. I would love to see it fixed or told I'm an idiot and to just check or uncheck a setting.

Right now when I am in the view all recentapps I can't activate LMT. I have to either touch an app or the screen
I can't active the LMT pie.

Is there a way to get this back?

My Samsung GS4, Samsung Note 4, Samsung Note 12.2 all have LMT pie feature working in the recentapps screen.

My Samsung Tab S4 the LMT pie feature does not work in the recentapps screen.

I'm running 3.1 with all features active but I only use it for the pie feature.

I love LMT.

Thank you for any assistance you can provide.
The Following User Says Thank You to minionhunter For This Useful Post: [ View ] Gift minionhunter Ad-Free
23rd November 2019, 03:57 PM |#14068  
Senior Member
Thanks Meter: 4
 
More
I apologize for the above post, I couldn't get the quotes fixed.

I'm looking for a way to get LMT to work in the "recent apps" screen on my Samsung galaxy tab S4. All my other Samsung phones and tablets LMT works in that field that shows all the running apps, but not on my Tab S4.

I'm running Oreo (not Pie)
I have good lock running and task changer is the only thing I can think of that maybe could be causing the problem? I've updated it but nothing changed. I've installed and uninstaled LMT. I've uninstaled task changer.

Can anyone suggest something that might work to restore LMT functionality in the recent apps screen?

---------- Post added at 09:57 AM ---------- Previous post was at 09:57 AM ----------

I apologize for the above post, I couldn't get the quotes fixed.

I'm looking for a way to get LMT to work in the "recent apps" screen on my Samsung galaxy tab S4. All my other Samsung phones and tablets LMT works in that field that shows all the running apps, but not on my Tab S4.

I'm running Oreo (not Pie)
I have good lock running and task changer is the only thing I can think of that maybe could be causing the problem? I've updated it but nothing changed. I've installed and uninstaled LMT. I've uninstaled task changer.

Can anyone suggest something that might work to restore LMT functionality in the recent apps screen?
24th November 2019, 10:55 AM |#14069  
kenkiller's Avatar
Senior Member
Thanks Meter: 554
 
More
Just to check, is there any requisite to make blacklist work? I put YouTube kids as one of the blacklisted app, but LMT still gets activated when in the app.
24th November 2019, 02:36 PM |#14070  
OP Senior Member
Thanks Meter: 6,679
 
More
Quote:
Originally Posted by minionhunter

I apologize for the above post, I couldn't get the quotes fixed.

I'm looking for a way to get LMT to work in the "recent apps" screen on my Samsung galaxy tab S4. All my other Samsung phones and tablets LMT works in that field that shows all the running apps, but not on my Tab S4.

I'm running Oreo (not Pie)
I have good lock running and task changer is the only thing I can think of that maybe could be causing the problem? I've updated it but nothing changed. I've installed and uninstaled LMT. I've uninstaled task changer.

Can anyone suggest something that might work to restore LMT functionality in the recent apps screen?

---------- Post added at 09:57 AM ---------- Previous post was at 09:57 AM ----------

I apologize for the above post, I couldn't get the quotes fixed.

I'm looking for a way to get LMT to work in the "recent apps" screen on my Samsung galaxy tab S4. All my other Samsung phones and tablets LMT works in that field that shows all the running apps, but not on my Tab S4.

I'm running Oreo (not Pie)
I have good lock running and task changer is the only thing I can think of that maybe could be causing the problem? I've updated it but nothing changed. I've installed and uninstaled LMT. I've uninstaled task changer.

Can anyone suggest something that might work to restore LMT functionality in the recent apps screen?

Hi, I assume that Samsung broke or deactivated overlay apps on recent screen, so there is not much I can do. You could activate lmt's debug activation areas for the pie and navigate to the recent screen to check if and where they show up.
The Following User Says Thank You to noname81 For This Useful Post: [ View ] Gift noname81 Ad-Free
24th November 2019, 02:37 PM |#14071  
OP Senior Member
Thanks Meter: 6,679
 
More
Quote:
Originally Posted by kenkiller

Just to check, is there any requisite to make blacklist work? I put YouTube kids as one of the blacklisted app, but LMT still gets activated when in the app.

You need root or you have to whitelist lmt for usage stats (system settings) for this feature to work.
The Following User Says Thank You to noname81 For This Useful Post: [ View ] Gift noname81 Ad-Free
Post Reply Subscribe to Thread

Tags
android, gesture, launcher, lmt, pie

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes