Remove All Ads from XDA

[Q] Limited Service, Emergency Calls Only - No Signal

126 posts
Thanks Meter: 9
By linj, Senior Member on 18th November 2010, 10:26 AM
Post Reply Email Thread
8th November 2011, 05:17 AM |#11  
ccgbiz's Avatar
Junior Member
Thanks Meter: 0
Thumbs up Required sim card upgrade!

Visited a T-MOBILE store and the SIM card was 2G and they upgraded
the SIM card. It resolved the issue.

We thank everyone who contributed to this issue.

T-MOBILE representative stated the HTC HD2 could never achieve
4G. Attempted to upgrade us to a Galaxy 4GS II. We will never
pay retail for a phone.

HTC HD2 running Android.
25th December 2011, 02:55 PM |#12  
Junior Member
Thanks Meter: 0
Network Mode
I had this issue as well on my HTC Sensation. What worked for me was to set Network Mode to "GSM Only" (Settings/Wireless & Networks/Mobile Networks/Network Mode).

It was weird, when I had 4 bars I could make/receive calls, but when reception was 2-3 bars it wouldn't. It has been less than 24 hrs so not completely sure the problem has gone away but worth a shot.

Bonne chance.
25th April 2012, 01:19 PM |#13  
Junior Member
Flag Debrecen
Thanks Meter: 0
Lightbulb My solution
Hey Guys!

I had the same problem after upgrading my Moto Milestone 2 to 2.3.6 Vivo ROM. When I went to class at university I had "Emergency calls only" - not "limited service" or "no service". So I had receiption... Also I could select any other provider but not my own (T-Mobile Hungary). The same thing happened when I was at home, in the house. The strange thing was that I didn't have any problem at any other place. Also, when I locked my screen and didn't use the phone, I had bars and could receive calls&sms, but after waking up the phone, the bars went down to 0 and got the "Emergency calls only" message.

I Googled a bit and found an answer which was worth a try before asking for a new SIM card from my provider ('cause that was the only solution I found in every other forum).
So the things to do are:
  • dial *#*#4636#*#*
  • go to Phone information
  • Scroll down to "Set preferred network type"
  • Select "GSM auto (PRL)"
My default was "GSM only" and after setting to auto I had full bars.
One thing to note: I don't use 2G or 3G or 4G or any other G. I just use WiFi for browsing and other than that, GSM to receive calls and send SMS. If you need 3G I think you need to change to some other settings. But you should give it a try.

2nd December 2019, 09:17 AM |#14  
bmaz121's Avatar
Flag Santa Ana, CA
Thanks Meter: 6
Donate to Me
Emergency calls only; When Android pie sleeps
I notice several times since I loaded Android Pie on my Oneplus One that the system, to save battery, is shutting down apps, even system apps. One of these is the phone service causing my phone to read Emergency calls only. After picking it up, about 30 sec, it registers 3 bars as normal. I am concerned that I am missing calls and text messages because after it turns on I get text messages. So, what is going on here? Any Ideas?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes