FORUMS

 View Poll Results: Was this thread helpful?

Yes, I am happy with the replies.
 
1,207 Vote(s)
59.25%
Yes, kind of.
 
481 Vote(s)
23.61%
No, needs improvement.
 
349 Vote(s)
17.13%

[Ask Any Question][Newbie Friendly]

14,044 posts
Thanks Meter: 5,056
 
By Droidriven, Senior Member on 29th April 2013, 12:24 PM
Post Reply Email Thread
22nd March 2020, 08:42 PM |#30491  
Junior Member
Thanks Meter: 0
 
More
Help please
I'm so confused my eyelashes hurt. I have the dreaded Galaxy S8+, G955u Snapdragon 835 Android 9

Can it be somewhat reliably rooted? If so, which of the numerous extremely confusing methods should I use?

I simply want to run "disk drill" or "dr fone" and try and recover as many of the photos and videos as possible. Is there a better way to can search access to the internal storage where user deleted data remains?

Any and all suggestions are welcome. I would prefer not to destroy the phone because rooting it and poking around at the insides sounds fun, but I dont mind whatever needs to be done to retrieve as much data as possible.

Kinda important I get to the files.

Thanks y'all

Cathead
22nd March 2020, 10:35 PM |#30492  
Recognized Contributor
Flag Sydney
Thanks Meter: 2,966
 
More
Quote:
Originally Posted by slylittleatomicbomb

Hello all!

Samsung SM-N910F
Lineage 16.0 (unofficial)
Rooted with Magisk

I've been slogging away at this one but thought I could use a hint or two!

I can't ADB pull from /system even after remounting with rw permissions and changing the directory permissions, the commands I am using are as follows...

Code:
adb shell
su
mount -o remount,rw /system
chmod 777 /system
exit
exit
adb root
adb pull /system/build.prop
adb: error: failed to copy 'system/build.prop' to '.\build.prop' : remote open failed: Permission denied
I'm using a user debug build of lineage with ro.secure=0 and ro.debuggable=1

The strange thing is when I enter
Code:
adb root
I don't get an error message but I don't get any form of confirmation either (I know this is sometimes the case for other commands but it seems weird)

I can move build.prop to /sdcard and adb pull from there and also seem to have no problem using ADB push to /data/data which seems strange?

Any help is much appreciated!

I don;t know your device, but I have built an app that allows you to access many system files (including build.prop) save then off and you could then transfer them to your PC.
https://forum.xda-developers.com/and...ation-t3806260
You can find build.prop in the menu under:
Various Ungrouped Extras>build.prop
23rd March 2020, 03:34 AM |#30493  
Junior Member
Thanks Meter: 5
 
More
Quote:
Originally Posted by Droidriven

Use adb commands to mount system when you connect while in recovery, then try the adb pull command.

I'm not sure, but, TWRP might allow using adb/adb shell commands to enter the PIN to unlock TWRP.

Sent from my SM-S767VL using Tapatalk

do you know the shell commands to unlock twrp? or can you suggest other recovery that i can flash that do not have encryption .

thanks
23rd March 2020, 04:21 AM |#30494  
Quote:
Originally Posted by mCoY20

do you know the shell commands to unlock twrp? or can you suggest other recovery that i can flash that do not have encryption .



thanks

I can't remember where TWRP stores its password/pin, but, if you can find the location where that is stored, you can use adb commands to delete it, and you can also delete the normal lockscreen password/PIN that blocks you from accessing the device via USB when booted into system.

Where the lockscreen data is stored or the specific file names are not necessarily the same for all devices/android versions. You will have to do some searching to find the storage locations and specific names of these files.

Sent from my SM-S767VL using Tapatalk
The Following 2 Users Say Thank You to Droidriven For This Useful Post: [ View ] Gift Droidriven Ad-Free
25th March 2020, 09:28 AM |#30495  
Junior Member
Thanks Meter: 0
 
More
Bricked device unable to boot into Stock Recovery
I messed up the flashing process with my Pixel 2 while downgrading from android 11 to 10. Now it is stuck on bootloader and I'm not able to boot into stock recovery as well. The adb and fastboot is not recognising the device. I need help to fix my bricked phone.
26th March 2020, 03:20 PM |#30496  
Junior Member
Flag Tucson
Thanks Meter: 0
 
More
So I'm not sure how but when I boot into recovery mode it does not have the delvik partition selector not are there any recovery logs. I used as maid pro to see where my files were as I was missing close to 12 gigs of storage and in the path
/storage/self/ it said that area was restricted. And there are a couple places where I can actually read some of the stuff that says like

#!/system/bin/sh
# Script to start "bmgr" on the device, which has a very rudimentary
# shell.
#
base=/system
export CLASSPATH=$base/framework/bmgr.jar
exec app_process $base/bin com.android.commands.bmgr.Bmgr "[email protected]"

And this is the part that bugs me, I just want my phone to be normal again and get my OTA updates and I can't even get them. Someone's been dicking around with my internet connection as well..

/dev/root / ext4 ro,seclabel,relatime,block_validity,delalloc,barri er,user_xattr 0 0
tmpfs /dev tmpfs rw,seclabel,nosuid,relatime,size=1433368k,nr_inode s=358342,mode=755 0 0
devpts /dev/pts devpts rw,seclabel,relatime,mode=600,ptmxmode=000 0 0
none /dev/stune cgroup rw,nosuid,nodev,noexec,relatime,schedtune 0 0
none /dev/cpuctl cgroup rw,nosuid,nodev,noexec,relatime,cpu 0 0
none /dev/cpuset cgroup rw,nosuid,nodev,noexec,relatime,cpuset,noprefix,re lease_agent=/sbin/cpuset_release_agent 0 0
cg2_bpf /dev/cg2_bpf cgroup2 rw,nosuid,nodev,noexec,relatime 0 0
adb /dev/usb-ffs/adb functionfs rw,relatime 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,seclabel,relatime 0 0
selinuxfs /sys/fs/selinux selinuxfs rw,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,seclabel,relatime 0 0
tracefs /sys/kernel/debug/tracing tracefs rw,seclabel,relatime 0 0
bpf /sys/fs/bpf bpf rw,nosuid,nodev,noexec,relatime 0 0
pstore /sys/fs/pstore pstore rw,seclabel,nosuid,nodev,noexec,relatime 0 0


PLEASE HELP ME
28th March 2020, 07:43 AM |#30497  
Junior Member
Flag colombo
Thanks Meter: 1
 
More
U]note
[/U] my H30 U10 IS INTERNATIONAL VERSION.
I FLASHED A WRONG TWRP AND NOW MY PHONE IS RESTARTS OVER AND OVER AGAIN. when i try to flash my phone via sp flash tool always occor ERROR:2004 .
my bootloader also i think locked but anyways i can still run fastboot and rescue mode in h30 u10(huawei honor 3c)but when i give fast boot command it always fails .
EX: when i give fastboot flash recovery recovery .img
IT says,
sending recovery.....
okay
failed(remote:command not allowed)
for every command it says like that
so i tried to use diffrent methods ... but didnt work(ALSO IM NOT A PROFESSIONAL GUY. IM JUST CURIOUS TO DO THINGS AND ALWAYS GET THE WORST RESULTS... THANKS TO U GUYS I LEARNED SOO MANY FACTS FROM UR FORUMS)....anyways...i need to work it.. i knw its still not broken its the firmware some fault..

i tried to get META mode but it i cannot find the ground (gnd)in it... pn mother board it didnt mentioned....so i dont knw really wHAT TO DO ...

I KNW U GUYS ARE EXPERT TO SOLVE THIS.. so please guys help me out..im also provide the things maybe useful to solve this mysterius thing

model :h30 U10_(locked bootloader version)
ANDROID VERSION:jelly bean
COUNTRY I BOUGHT:srilanaka
BUILD NUMBER:NOT SURE
REMOVABLE BATTERY
(ALSO i removed the back cover to find the test points )_hardware preloader mod
ALSO bought year:2013
also one thing .....WHEN I CONNECTED TO THE COMPUTER IT DISSCONECTS RECONNECTS ALLOVER AGAIN....... AND also to be mention i cant go to recovery mode also(factory recovery also not working)... if u guys know how to solve this problem please provide me with step by step ....(BECAUSE STILL IM A 17 YEAR OLD CHILD)
28th March 2020, 01:14 PM |#30498  
Quote:
Originally Posted by Shashin somanayake

U]note

[/U] my H30 U10 IS INTERNATIONAL VERSION.

I FLASHED A WRONG TWRP AND NOW MY PHONE IS RESTARTS OVER AND OVER AGAIN. when i try to flash my phone via sp flash tool always occor ERROR:2004 .

my bootloader also i think locked but anyways i can still run fastboot and rescue mode in h30 u10(huawei honor 3c)but when i give fast boot command it always fails .

EX: when i give fastboot flash recovery recovery .img

IT says,

sending recovery.....

okay

failed(remote:command not allowed)

for every command it says like that

so i tried to use diffrent methods ... but didnt work(ALSO IM NOT A PROFESSIONAL GUY. IM JUST CURIOUS TO DO THINGS AND ALWAYS GET THE WORST RESULTS... THANKS TO U GUYS I LEARNED SOO MANY FACTS FROM UR FORUMS)....anyways...i need to work it.. i knw its still not broken its the firmware some fault..



i tried to get META mode but it i cannot find the ground (gnd)in it... pn mother board it didnt mentioned....so i dont knw really wHAT TO DO ...



I KNW U GUYS ARE EXPERT TO SOLVE THIS.. so please guys help me out..im also provide the things maybe useful to solve this mysterius thing



model :h30 U10_(locked bootloader version)

ANDROID VERSION:jelly bean

COUNTRY I BOUGHT:srilanaka

BUILD NUMBER:NOT SURE

REMOVABLE BATTERY

(ALSO i removed the back cover to find the test points )_hardware preloader mod

ALSO bought year:2013

also one thing .....WHEN I CONNECTED TO THE COMPUTER IT DISSCONECTS RECONNECTS ALLOVER AGAIN....... AND also to be mention i cant go to recovery mode also(factory recovery also not working)... if u guys know how to solve this problem please provide me with step by step ....(BECAUSE STILL IM A 17 YEAR OLD CHILD)

First, read this:

https://forum.xda-developers.com/and...error-t3692259

Then take a look at this method using your device's stock firmware.

https://m.youtube.com/watch?v=A9KmM6l0sIs

Sent from my SM-S767VL using Tapatalk
The Following User Says Thank You to Droidriven For This Useful Post: [ View ] Gift Droidriven Ad-Free
29th March 2020, 12:35 PM |#30499  
Junior Member
Flag colombo
Thanks Meter: 1
 
More
Quote:
Originally Posted by Droidriven

First, read this:

https://forum.xda-developers.com/and...error-t3692259

Then take a look at this method using your device's stock firmware.

https://m.youtube.com/watch?v=A9KmM6l0sIs


Still didn't work.my phone didn't get into download the dload
29th March 2020, 12:53 PM |#30500  
Recognized Contributor
Flag Sydney
Thanks Meter: 2,966
 
More
Where to post LOS bugs on unofficial ROM?
I am testing two unofficial LOS based ROMs. I went back to LOS as its the source and I wanted to check if it had the same issue; and it did.

So i looked as to where I could post the error, and found the following: https://wiki.lineageos.org/bugreport-howto.html
Quote:

What not to report
Bugs in unofficial builds or anything not downloaded from our official portal



So, I am guessing the bug is also in official builds, but there is nowhere I can find to post the bug.

I also looked at their downloads, and all the devices I checked are actually Pie, and Not Android 10.

Does anyone know where I could post the error? or if someone is running an official LOS Android 10 build, I could detail it for them to check and if they also have the error, they could post it in their thread.
The Following User Says Thank You to DiamondJohn For This Useful Post: [ View ] Gift DiamondJohn Ad-Free
29th March 2020, 03:26 PM |#30501  
Quote:
Originally Posted by Shashin somanayake

Still didn't work.my phone didn't get into download the dload

If your device is connecting, disconnecting, reconnecting over and over when you connect it to PC, it is because it is a timing thing. It can be tricky, but, if you do the steps in the right order and at exactly the right moment, you will get the device to connect to the flashtool properly.

There are threads and videos describing how to make a successful connection even when the device is connecting, disconnecting, reconnecting over and over.

If you still can't get connected after doing exactly what the guides and videos describe, then, your device can't be repaired by you. You will have to try sending the device to a reputable repair shop where they may be able to recover the device or they will replace your motherboard.

Sent from my SM-S767VL using Tapatalk
The Following User Says Thank You to Droidriven For This Useful Post: [ View ] Gift Droidriven Ad-Free
Post Reply Subscribe to Thread

Tags
ask any question, bricked phone, cwm roms and kernels, help thread, noob, noob friendly, question, rcs in action

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes