FORUMS

[Q/A][06-09-12]General Chat, All XDA Members Welcome !!

23,846 posts
Thanks Meter: 23,302
 
Post Reply Email Thread
8th December 2014, 12:39 AM |#291  
DeadCode1's Avatar
Senior Member
Flag Osaka
Thanks Meter: 35
 
Donate to Me
More
Phone Install Flastools and Flashing a new firmware
Install Flastools and Flashing a new firmware


OK this is how i flash my firmware.
I have a Windows 8.1 running PC so this is the steps i did.

First you need to download two files so first download below files.

IS11S_4.0.1.B.0.112_KDDI.ftf

https://mega.co.nz/#!kVInSCQQ!bx7sX1...By6CBW5UjAcqww

flashtool-0.9.18.3-windows.exe

https://mega.co.nz/#!JVpBjTaI!fV-1Jg...-aUsIreEm_gvFk

Then you need to install flashtool-0.9.18.3-windows.exe. Just double click and install it and Remember the installing folder (Example - "C:\Flashtool" or "C:\Program Files\Flashtool" like that) and then go to that folder. Inside that folder go to drivers folder and install Flashtool-drivers.exe. Click next check the Flashmode Drivers and Fastboot Drivers (Very important you select those) and go down the menu and select the phone model (Read all well). Then install. If your installation finis without warning errors then you ok. If your installation finis with warning errors then do next step.

Go to PC Settings (Charms Bar) > Change PC Settings > Update And Recovery > Recovery > Restart Now (Advanced Startup)
it will restart to Advance Startup automatically

In Advance Startup -
Troubleshoot > Advanced Settings > Start-up Settings > Restart

After rebooted you will get a screen says. Here to choose options for that we have to use function keys. Now press "F7" to select "Disable Driver Signature Enforcement" .

Now your PC will boot with Disabled Driver Signature Enforcement and you will be able to install Flashtool/Fastboot drivers. so again install the Flashtool-drivers.exe and will finish without errors.

after that again go to falshtool installed folder and go to Firmwares folder and if you see any files already on that firmwares folder delete them. Then copy IS11S_4.0.1.B.0.112_KDDI.ftf file that you download before to firmwares folder. and then run FlashTool.exe (If your PC 64bit then run FlashTool64.exe)

Now on your device go to (Very important to do all the steps below)
01. settings > Application settings > Development > check USB debugging
02. settings > Application settings > uncheck Unknown sources
03. settings > Sony Ericsson > Connectivity > USB connection mode > choose Mass storage mode

Then connect your device to PC using Original USB cable.

Go to flashtool software click on flash icon.
Then chose Flashmode > ok
Then new window will open (Firmware Selector) then you can see the IS11S_4.0.1.B.0.112_KDDI.ftf file already on that.
Now just click on FLASH.!

That's all wait it to finish. and your device will restart automatically. and DONE.!

I couldn't remember where i download those files but i already had those so i upload it for you and anyone who want to download those.

And if this post helps you then be kind enough to click on THANKS for me.!

Enjoy.!

By - DeadCode - Knowledge is free
12th May 2015, 02:50 PM |#292  
Junior Member
Thanks Meter: 0
 
More
Hi!
I am interested in finding out how to remove keypad lock on Sony Ericsson Xperia Arc without losing the data or apps on the phone. Is it possible? If so, some step by step solution would be much appreciated as I am totally new to this (haven't rooted, flashed or done nearly anything with Android).

In the hopes of help
16th June 2015, 05:34 PM |#293  
Junior Member
Thanks Meter: 0
 
More
Hello guys,
i had some success into installing a custom rom (4.4.4 android, carbon kk) and so i already modified my kernel, right now my kernel is indicated as 3.4.0-LX+
and so, as a general question i was wondering : when you dont know if your kernel is compatible with a rom, is there a danger if you only wipe/install a new rom (which wouldn't be packed with its own kernel - there would be a question 2 : how can you know inside the file structure if there is a kernel packed with it ?) and try to boot normally ?
Why do I ask ? i want to install some rom based on cm11 for example and can't find a compatibility list. Of course the author provided a kernel so I could install both, but still i would want to try to see if the rom works with my actual kernal, hence the question about a possible danger (brick, loop, etc)
+ with my model of phone (ericsson arc S), i dont always succeed in booting in flashmode because the hotkeys while booting... i dont remember each time if its volume down, or menu, etc (dont laugh, in every tutorial this is different xD) so there is a big possibility that i reboot in normal mode.

Thanks
10th November 2015, 12:24 PM |#294  
Sandro8771's Avatar
Senior Member
Flag Penang
Thanks Meter: 16
 
More
I've had an xperia arc lt15i since early 2012.
Ran many a custom roms and kernels. Served me good all these days.
Last, was on stock firmware but still with root.
Today, all of a sudden the device just stopped working.
I mean, when I woke up this morning my device did not.
It did not boot up. Tried many times taking battery out, inserting it again.
Even reflashed stock firmware again still the same.
Phone just does not boot up. Screen is dark. Just a slight backlight and total darkness.
Any ideas?
1st February 2016, 02:05 AM |#295  
invertedskull's Avatar
Senior Member
Flag Melbourne
Thanks Meter: 52
 
More
Hi all. Really quick question... Will flashing stock firmware (I've flashed 4.1.B.0.587), unroot a rooted SE device? And will it lock an unlocked bootloader?

I suspect I've lost root due to flashing 4.1.B.0.587., and am having no luck re-rooting.
8th August 2016, 02:26 PM |#296  
invertedskull's Avatar
Senior Member
Flag Melbourne
Thanks Meter: 52
 
More
6 Months later no reply, but that's ok. I found success re-rooting with eRoot tool. Only thing missing in many of the instructions was the USB connection mode, it had to be MSC mode to work. Hopefully someone uses this info.

But now I have another problem, I got CWM Recovery installed but could only access it by using an app called x-Parts (formerly CWM Xperia Tools, or something like that). V7 didn't work for me, but V5 (when it was the old name) did work. Got into Recovery, flashed a ROM, but something really screwy must be going on because upon rebooting I was back to a factory reset of the stock ROM that I already had. Tried another ROM, and now I'm stuck in a "SONY" screen bootloop.

I think I have to flash stock again using fastboot / Flash Tool. *sigh*
19th April 2020, 08:09 PM |#297  
Junior Member
Thanks Meter: 0
 
More
are there new way to root without pc? I dont have it yet

also I need some confirmation,
ntt docomo so-01c. its my device
lt15i
anzu
x12
are they same devices??
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes