FORUMS

[EFS-cwm-Restore] Restore zip for your EFS

4,296 posts
Thanks Meter: 19,316
 
By civato, Inactive Recognized Contributor on 20th June 2013, 03:46 PM
Post Reply Email Thread
19th April 2016, 07:12 PM |#11  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by arminrr

Thanks for the zip, I have my EFS backup, but I didn't know what to do if I had this problem!

can you pls upload your n5110 efs backup in 4 shared mediafire or mega i down back my efs so i brick my phone need help ls..
19th May 2016, 08:07 PM |#12  
Junior Member
Thanks Meter: 0
 
More
Problem!!!
I flashed it via TWRP Recovery It shows that INSTALLATION SUCCESSFUL but after my phone boots up. I tried to found the EFS folder it only contains bluetooth folder. but I had so many files and folders in my EFS Backup.img file. Why It could not work.
29th January 2017, 02:01 AM |#13  
Junior Member
Thanks Meter: 0
 
More
Hi Please take a minute to reply
Quote:
Originally Posted by civato

Story behind this zip file:

I messed up my tablet and I could only get into download mode , meaning I could flash a insecure boot.img and custom recovery.
I noticed that my EFS partition was erased when I entered a stock recovery, I got all kind of EFS error messages in recovery.

At first I tried to restore my system with a original ROM ODIN package but that doesn't restore your EFS. So no luck and still stuck in a bootloop.
So what to do? No adb , no EFS backup on my internalSD , I couldn't get acces to my internal SD.

I google around and I didn't find anything to restore EFS from within recovery or Odin. I didn't have a EFS.img backup on my internalSD so the emwo recovery was no help.

I do have a EFS backup that I took with EFS pro.
That generates a .tar and a .img file.
So I made myself a update package that I could flash from cwm. As I made the recovery I knew in what partition EFS is stored so that was easy.
This is the updater script , it should work on GT-N51... (10, 00, 20) as they all store the EFS in this partition.

Code:
show_progress(0.3,72);
ui_print(" ");
ui_print("1. START INSTALLATION");
package_extract_file("EFS.img", "/dev/block/mmcblk0p3");
set_progress(0.99);
ui_print("------------------------------------------");
set_progress(1.0);

I renamed the EFS image backup that I took with efsPro to EFS.img and dropped it in the zip I made with the updeter script.

Flashed it with cwm and voila, running again without any problems.

SO in the attachments is the zip .

Open it with 7zip or winrar , drag and drop your EFS.img (needs to be this name) into the zip where the EFS-dummy text file is. put it on your externalSD , boot to recovery and flash it.

So I hope this helps the people out that come into the same situation as I did.

Will this method work for stock recovery too? thanks
9th February 2018, 05:56 PM |#14  
Junior Member
Thanks Meter: 1
 
More
i know this is old but i find this video that explain how to recovery the efs bad i try and works:

https://www.youtube.com/watch?v=Y-LZvVLEC5o

adb shell
su
cd /dev/block/platform
cd dw_mmc
cd by-name
ls -l

(copy de code of block and put in .....)

example: mmcblk0p3

mke2fs /dev/block/......
mount -w -t ext4 /dev/block/.......
reboot
23rd April 2020, 05:31 PM |#15  
Junior Member
Thanks Meter: 0
 
More
can any one uploda efs.img for n5100.. tia
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes