FORUMS

[MOD][Flashable] Remove all Bloatware apps from system/app Partition within 2 Seconds

134 posts
Thanks Meter: 140
 
By broadways, Senior Member on 21st December 2012, 01:55 PM
Post Reply Email Thread
3rd May 2017, 03:51 PM |#101  
Senior Member
Thanks Meter: 121
 
More
Having the same "Updater process ended with signal: 11" error as well.

Have the gut feeling that maybe flashable zip need some kind of signing now?
But signature verification is off.

---------- Post added at 10:51 PM ---------- Previous post was at 10:32 PM ----------


@Tex99 @Ja_som
Found another template and copied the contents of the updater-script in this template to that of the linked template.
http://rootmygalaxy.net/create-andro...flashable-zip/

I think it might be the updater-binary that needed updating?
Remember to backup before flashing just in case.
11th August 2017, 05:05 AM |#102  
Junior Member
Thanks Meter: 0
 
More
failed apply update bloatkill.zip
it's said: (Status 0)
Installation aborted.

my phone is samsung ace 3 (stock rom)
11th August 2017, 09:04 AM |#103  
Quote:
Originally Posted by undist

failed apply update bloatkill.zip
it's said: (Status 0)
Installation aborted.

my phone is samsung ace 3 (stock rom)

Maybe your phone don't have busybox?
18th November 2019, 07:55 PM |#104  
Junior Member
Thanks Meter: 0
 
More
Hi broadways,
I have tried your debloat script on Galaxy Note4 (SM-N910F), but when I select the zip file, this is what I get:

Supportd API: 3

# MANUAL MODE #
-- Applying Multi-CSC . . .
Applied the CSC-code : MET
Succesfully applied multi-CSC .

-- Install /sdcard/bloatkill.zip . . .
Finding Update package . . .
Opening Update package . . .
Verifying Update package . . .
E: failed to verify whole-file signature
E: signature verification failed

Finding Update package . . .
Opening Update package . . .
Verifying Update package . . .
E: failed to verify whole-file signature
E: signature verification failed

Installation aborted .


Am I doind something wrong?
Does the phone have to be rooted?
(I need to use banking app so I can't afford to root my phone.)

Very much appreciated,
invisibletint

================================================== ================================================== =============================
[QUOTE=broadways;35725682]What is this?
It's a zip file which can remove bloatware apps(found in system/app partition) from stock recovery. It can remove more than 20 apps within 2-3 seconds.

Why do I need it?
Assume you have flashed a new rom. You now have to go through the pain of removing dozens of apps from system/app which you might not need. eg: some people hardly use google maps/swype/youtube/email/weather.apk or those several samsung apps/widgets found in stock rom.

...

---------- Post added at 09:55 PM ---------- Previous post was at 09:33 PM ----------

Quote:
Originally Posted by mai77

using aroma, it would even be more customizable. One could tag the individual apk's to remove.

Do I need a ROOTED phone to install Aroma?

I have just tried and the errors I am getting are:

E : Footer is wrong
E : signature verification failed


Any advice?

Thanks,
18th November 2019, 09:38 PM |#105  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by TheFixItMan

As I keep saying this is for the galaxy y 5360

All it is is an updater script saying to delete certain apks
The apks in your phone may have different names and if on KitKat and above you also have priv-app
So edit the updater script to match the apps you want to delete

Also it's not flashing because you need to replace the update binary in the meta-inf folder of the zip with one for your phone - take it from a flashable zip that works on your phone

If this is the first .zip I have ever tried then, perhaps I won't have another one that works . . .
I still don't know where I can get an apropriate update binary for let say Note 4 (SM-N910F) . . . have just googled Note 4 update binary for hours .

Would a stock firmware have the update binary inside?

Thanks anyway,
18th November 2019, 11:13 PM |#106  
TheFixItMan's Avatar
Senior Member
Flag London
Thanks Meter: 3,938
 
More
Quote:
Originally Posted by invisibletitn

If this is the first .zip I have ever tried then, perhaps I won't have another one that works . . .
I still don't know where I can get an apropriate update binary for let say Note 4 (SM-N910F) . . . have just googled Note 4 update binary for hours .

Would a stock firmware have the update binary inside?

Thanks anyway,

Any flashable zip for your device - goto your own phone forum and download any rom zip for example
You will find a meta-inf folder inside

Updater script is what is to be flashed changed deleted etc upon flashing
Update binary will be there to allow flashing on your device
19th November 2019, 05:34 PM |#107  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by TheFixItMan

Any flashable zip for your device - goto your own phone forum and download any rom zip for example
You will find a meta-inf folder inside

Updater script is what is to be flashed changed deleted etc upon flashing
Update binary will be there to allow flashing on your device


Thanks for the advice. . .
It is verymuch appreciated.
Perhps this last bit of information about where to get the binary isn't news to most of you experienced ones, but it is certainly news to me.

Thanks a lot...
19th November 2019, 06:47 PM |#108  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by TheFixItMan

Any flashable zip for your device - goto your own phone forum and download any rom zip for example
You will find a meta-inf folder inside

Updater script is what is to be flashed changed deleted etc upon flashing
Update binary will be there to allow flashing on your device

I have tried but no success.

I can see three files here:
[CERT.RSA]
-------------------------------------------------------------------------
[CERT.SF]
Signature-Version: 1.0
Created-By: 1.0 (Android SignApk)
SHA1-Digest-Manifest: uIKYtlNDwrYOYTQ/lwS++FttUIo=

Name: META-INF/com/google/android/updater-script
SHA1-Digest: gKe4AIXxB+reRFVK6j3QY4sBvA4=

Name: META-INF/com/google/android/update-binary
SHA1-Digest: 9kLL1smYyZTRlc3lDjkYvpS+/Sw=
-------------------------------------------------------------------------
[MANIFEST.MF]
Manifest-Version: 1.0
Created-By: 1.0 (Android SignApk)

Name: META-INF/com/google/android/updater-script
SHA1-Digest: ZVvfNOb6TP50VUyLjCZsFyC15Fk=

Name: META-INF/com/google/android/update-binary
SHA1-Digest: bPhs0p0OBccax3q5KeHPEo1mwTk=
-------------------------------------------------------------------------

Do those hash values have to be recalculated somehow?
19th November 2019, 07:36 PM |#109  
TheFixItMan's Avatar
Senior Member
Flag London
Thanks Meter: 3,938
 
More
Quote:
Originally Posted by invisibletint

I have tried but no success.

I can see three files here:
[CERT.RSA]
-------------------------------------------------------------------------
[CERT.SF]
Signature-Version: 1.0
Created-By: 1.0 (Android SignApk)
SHA1-Digest-Manifest: uIKYtlNDwrYOYTQ/lwS++FttUIo=

Name: META-INF/com/google/android/updater-script
SHA1-Digest: gKe4AIXxB+reRFVK6j3QY4sBvA4=

Name: META-INF/com/google/android/update-binary
SHA1-Digest: 9kLL1smYyZTRlc3lDjkYvpS+/Sw=
-------------------------------------------------------------------------
[MANIFEST.MF]
Manifest-Version: 1.0
Created-By: 1.0 (Android SignApk)

Name: META-INF/com/google/android/updater-script
SHA1-Digest: ZVvfNOb6TP50VUyLjCZsFyC15Fk=

Name: META-INF/com/google/android/update-binary
SHA1-Digest: bPhs0p0OBccax3q5KeHPEo1mwTk=
-------------------------------------------------------------------------

Do those hash values have to be recalculated somehow?

What are you actually trying to do?

If you want to remove bloatware like I said goto your own device forum and there is a thread there for it

Also - all you need to do to add/remove change any apps is to write or edit your own updater script

See
https://forum.xda-developers.com/not...odels-t3813051

Flashable zip for your device
http://www.mediafire.com/file/xyh95y...LoatScript.zip

Like I said - edit the updater script for apps you want to remove or change
13th May 2020, 08:10 AM |#110  
Junior Member
Thanks Meter: 0
 
More
Updater script error
Twrp shows error i.e. "Updater process ended with signal: 11" is there any fix for it.
Post Reply Subscribe to Thread

Tags
bloatware, flash, remove, updater-script

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes