FORUMS
Remove All Ads from XDA
Win Honor 9 Lite

[DISCONTINUED][RECOVERY] TWRP 2.7.0.0 [4.4 KitKat Compatible] - 3/25/2014

195 posts
Thanks Meter: 419
 
Post Reply Email Thread
NOTICE: I no longer have a copy of the recovery image since goo.im went down. If anyone still has it, feel free to post a link. I'll leave the instructions here. Also, I won't be updating this since I no longer have a TF201 and ROM development seems to have shifted to a modified bootloader, which requires a different recovery image anyway.

Original post:
Warning: You must be on the 4.1.1 Bootloader to use this. Androwook and other stock based ROMs supply their own recovery.

With 4.4 based ROMs starting to come to our tablet, and official TWRP not flashing them, I thought I'd take a crack at updating it. As some of you may know, attempting to flash a KitKat ROM using the current version of TWRP fails, resulting in a "set_metadata_recursive" error. This updated version, based on the OmniROM fork of TWRP, fixes that.

Latest Version: 2.7.0.0-Voyager2k_v1.2

Instructions:
1.(Highly Recommended) Enable NVFlash if you haven't already. Check here for details.
2. Make sure you are on the 4.1.1 Jellybean Bootloader. If you are already running ParanoidAndroid or CyanogenMod, you're fine.
3. Download the recovery image here. The latest file is recovery1.2.img. EDIT: Links are broken. See above
4. You can use the same instructions that are on the TWRP page, but for convenience, I'll add them here. You have two options:
A. Fastboot. Boot the tablet into fastboot and use "fastboot -i 0x0b05 flash recovery recoveryX.X.img" (no quotes, replace X.X with whatever numbers are in the filename) from your computer to flash the recovery.
B. Flash from terminal within the tablet. Open a terminal emulator within android and type "su" (no quotes) to get root access. Then type "dd if=/sdcard/recovery.img of=/dev/block/mmcblk0p4" (no quotes, replace X.X with whatever numbers are in the filename) to flash the recovery and reboot normally. This is critical, as the recovery won't flash until the system has rebooted normally.
If successful, the version number should read: "2.7.0.0-Voyager2k-vX.X" (X.X being my revision number)

Known Issues:
1. /system/media doesn't get backed up for some reason. Restoring backups works, but you won't have sounds or a boot animation. (I think this is fixed in the newest version, but I'm waiting on other reports before I remove this item)

Ususal disclaimer: I am not responsible if this messes up your tablet in any way.

Credits:
TWRP for making the recovery
Built from the OmniROM fork. Source is here.
The Following 20 Users Say Thank You to Voyager2k For This Useful Post: [ View ] Gift Voyager2k Ad-Free
 
 
3rd January 2014, 03:31 AM |#2  
OP Senior Member
Thanks Meter: 419
 
More
Changelog:

Version 1.1 - 2/19/2014
Added support for the dock keyboard
Fixed /system/media not backing up properly
Synced with latest OmniROM recovery sources

Version 1.2 - 3/25/2014
Updated to TWRP version 2.7.0.0
A little cleanup behind the scenes
The Following 2 Users Say Thank You to Voyager2k For This Useful Post: [ View ] Gift Voyager2k Ad-Free
3rd January 2014, 03:32 AM |#3  
OP Senior Member
Thanks Meter: 419
 
More
one more.
3rd January 2014, 11:06 AM |#4  
tHoMaS-1's Avatar
Senior Member
Thanks Meter: 375
 
Donate to Me
More
Thumbs up
Works Great! Flashed without problems via fastboot

Thank You!

Now I just need an awesome 4.4. ROM to flash
3rd January 2014, 01:03 PM |#5  
Member
Flag Spremberg
Thanks Meter: 3
 
More
works also with the second instruction over the tablet
3rd January 2014, 03:20 PM |#6  
Junior Member
Thanks Meter: 1
 
More
Excellent news

I tried through the Terminal but despite no error was presented it didn't worked. The recovery presented was the old CWM. After flashing through fastboot the new recovery popped out like a charm

Thanks.
4th January 2014, 11:26 AM |#7  
Tempie007's Avatar
Senior Member
Thanks Meter: 72
 
More
thanks, it works through terminal. jut make sure to be root (su) and adjust the path of the recovery image

Sent from my EPAD using Tapatalk
4th January 2014, 05:03 PM |#8  
mm284781423's Avatar
Junior Member
Chengdu
Thanks Meter: 2
 
More
thanks! This rec works and I have flashed cm11. Terminal works. U should insert "su" first

Sent from my GT-N7102 using Tapatalk
4th January 2014, 10:44 PM |#9  
Senior Member
Thanks Meter: 320
 
More
To use the second method you need to run su command first before using dd

Sent from my TF300T on OmniROM (4.4.2) using Tapatalk 4
6th January 2014, 03:16 PM |#10  
Junior Member
Thanks Meter: 1
 
More
Thumbs up Terminal
Just would like to ditto.

The process worked in the terminal on the device.

Thank you for this!
15th January 2014, 09:54 AM |#11  
Dasdranamin's Avatar
Member
Flag Munich
Thanks Meter: 33
 
More
Bug report!
BUG REPORT!

There is a BUG in this version of TWRP:
It does not make any backup folder named media!
For example /system/media.
As result after recovery the folder /system has no this subfolder media and correspondingly missing boot animation and system sounds.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes