FORUMS
Remove All Ads from XDA

[GUIDE] Making infrastructure wifi hotspot on ubuntu 12.04/12.10

32 posts
Thanks Meter: 37
 
By ogyct, Member on 23rd November 2012, 02:20 PM
Post Reply Email Thread
13th April 2013, 12:09 PM |#11  
drv.vyas27's Avatar
Member
Flag mumbai
Thanks Meter: 2
 
More
stuck at # what to do please help
15th April 2013, 10:22 AM |#12  
Member
Flag Mumbai
Thanks Meter: 5
 
More
Unhappy getting an error
here's the error i'm getting

Code:
SIOCSIFFLAGS: Operation not possible due to RF-kill
 * Restarting DNS forwarder and DHCP server dnsmasq                                                                                                    
dnsmasq: failed to create listening socket for 127.0.0.1: Address already in use
                                                                                                                                                [fail]
net.ipv4.ip_forward = 1
Configuration file: /etc/hostapd.conf
Could not set interface wlan0 flags: Operation not possible due to RF-kill
nl80211: Failed to set interface wlan0 into AP mode
nl80211 driver initialization failed.
ELOOP: remaining socket: sock=4 eloop_data=0x8e20908 user_data=0x8e20e88 handler=0x807c5e0
ELOOP: remaining socket: sock=6 eloop_data=0x8e22ca0 user_data=(nil) handler=0x8086770
net.ipv4.ip_forward = 0
 * Stopping DNS forwarder and DHCP server dnsmasq                                                                                                       * (not running)
27th April 2013, 02:40 PM |#13  
Junior Member
Thanks Meter: 0
 
More
It doesn't work!
It's a pity!
6th May 2013, 02:42 PM |#14  
mehediatcom's Avatar
Junior Member
Flag Dhaka
Thanks Meter: 9
 
More
Thumbs up Thanks
THANKS BRO IT REALLY WORKED LIKE A CHRAM!!!!!
6th May 2013, 04:13 PM |#15  
Member
Thanks Meter: 1
 
More
Thanks!
22nd May 2013, 06:55 PM |#16  
sarkar1990's Avatar
Senior Member
Flag New Delhi
Thanks Meter: 531
 
Donate to Me
More
Quote:
Originally Posted by ogyct

As many of you know, most of our android(not only android) devices can't connect to ad hoc hotspots. There's a solution for win7/8 users to set up infrastructure hotspot on their laptop using software like connectify and so on. Ubuntu also allows to create wifi hotspot to share internet, but it will be ad hoc one.
So here's the guide how to set up infrastructure hotspot on ubuntu 12.04/12.10. Unlike some other methods described on the internet, this one will not break default network manager.

1. First of all you should make sure, that your wifi adapter supports infrastructure hotspots. If you used connectify on your windows system and it worked, skip this step.

open terminal and type: sudo lshw | less

find -network section and make sure that driver is ath5k or ath9k, this solution will only work for those drivers, but should fit the needs for the most laptop users.



2. We now need to install 2 additional tools to make out hotspot, 1st one is hostapd(hotspot server), 2nd one is dnsmasq(dns dhcp server)

in terminal type: sudo apt-get install hostapd dnsmasq

3. stop those services if started already, and prevent them from starting on system start up.

in terminal type:
sudo service hostapd stop
sudo service dnsmasq stop
sudo update-rc.d hostapd disable
sudo update-rc.d dnsmasq disable


4. Now we need to set up config files.
in terminal type: sudo gedit /etc/dnsmasq.conf
or sudo kate /etc/dnsmasq.conf if you use kde

add those lines to the config file

Code:
# Bind to only one interface
bind-interfaces
# Choose interface for binding
interface=wlan0
# Specify range of IP addresses for DHCP leasses
dhcp-range=192.168.150.2,192.168.150.10
5. hostapd config

in terminal type: sudo gedit /etc/hostapd.conf

and add those lines

Code:
# Define interface
interface=wlan0
# Select driver
driver=nl80211
# Set access point name
ssid=myhotspot
# Set access point harware mode to 802.11g
hw_mode=g
# Set WIFI channel (can be easily changed)
channel=6
# Enable WPA2 only (1 for WPA, 2 for WPA2, 3 for WPA + WPA2)
wpa=2
wpa_passphrase=mypassword
You can change ssid name and password for anything you want here. Current config will create hotspot named myhotspot with mypassword password.

6. Now create anywhere you want a file named start.sh
edit it with any text editor like this:

Code:
#!/bin/bash
# Start
# Configure IP address for WLAN
sudo ifconfig wlan0 192.168.150.1
# Start DHCP/DNS server
sudo service dnsmasq restart
# Enable routing
sudo sysctl net.ipv4.ip_forward=1
# Enable NAT
sudo iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
# Run access point daemon
sudo hostapd /etc/hostapd.conf
# Stop
# Disable NAT
sudo iptables -D POSTROUTING -t nat -o ppp0 -j MASQUERADE
# Disable routing
sudo sysctl net.ipv4.ip_forward=0
# Disable DHCP/DNS server
sudo service dnsmasq stop
sudo service hostapd stop
You will probably need to change ppp0 in this to eth0 (or any other number which refers to your wired connection.

7. Last step. Now you can start your hotspot by starting our script. just run it using sudo sh
for me it looks like this sudo sh /home/ogyct/Desktop/start.sh because I have it on my desktop


I am not sure who is the author of this guide, I only translated it to english. But anyway if this helped, hit the thanks button. Good day

This is running awesome. Just one question. How do I stop the script?

I find disabling and enabling wifi works. But is there any other way?
27th May 2013, 02:58 AM |#17  
Junior Member
Thanks Meter: 0
 
More
Hi, this script works perfectly. I was having issues with ubuntu shared wifi not being visible with android.

Now the hard question. I have a box that is already acting as a router sharing ip with dnsmasq over eth1
i added a wifi card wlan0 and i want to share not only internet but also the services running on my box

the problem is this script uses a different ip range and i cannot access my nfs shares.

my network is 192.168.128.x and i have set up this script in other range.

Setting it up in 192.168.128.10x for instance will not work

Is it possible to make this wifi share part of my network?

regards.
3rd June 2013, 01:37 PM |#18  
Junior Member
Thanks Meter: 0
 
More
Thumbs up worked !!!
Quote:
Originally Posted by ogyct

As many of you know, most of our android(not only android) devices can't connect to ad hoc hotspots. There's a solution for win7/8 users to set up infrastructure hotspot on their laptop using software like connectify and so on. Ubuntu also allows to create wifi hotspot to share internet, but it will be ad hoc one.
So here's the guide how to set up infrastructure hotspot on ubuntu 12.04/12.10. Unlike some other methods described on the internet, this one will not break default network manager.

1. First of all you should make sure, that your wifi adapter supports infrastructure hotspots. If you used connectify on your windows system and it worked, skip this step.

open terminal and type: sudo lshw | less

find -network section and make sure that driver is ath5k or ath9k, this solution will only work for those drivers, but should fit the needs for the most laptop users.



2. We now need to install 2 additional tools to make out hotspot, 1st one is hostapd(hotspot server), 2nd one is dnsmasq(dns dhcp server)

in terminal type: sudo apt-get install hostapd dnsmasq

3. stop those services if started already, and prevent them from starting on system start up.

in terminal type:
sudo service hostapd stop
sudo service dnsmasq stop
sudo update-rc.d hostapd disable
sudo update-rc.d dnsmasq disable


4. Now we need to set up config files.
in terminal type: sudo gedit /etc/dnsmasq.conf
or sudo kate /etc/dnsmasq.conf if you use kde

add those lines to the config file

Code:
# Bind to only one interface
bind-interfaces
# Choose interface for binding
interface=wlan0
# Specify range of IP addresses for DHCP leasses
dhcp-range=192.168.150.2,192.168.150.10
5. hostapd config

in terminal type: sudo gedit /etc/hostapd.conf

and add those lines

Code:
# Define interface
interface=wlan0
# Select driver
driver=nl80211
# Set access point name
ssid=myhotspot
# Set access point harware mode to 802.11g
hw_mode=g
# Set WIFI channel (can be easily changed)
channel=6
# Enable WPA2 only (1 for WPA, 2 for WPA2, 3 for WPA + WPA2)
wpa=2
wpa_passphrase=mypassword
You can change ssid name and password for anything you want here. Current config will create hotspot named myhotspot with mypassword password.

6. Now create anywhere you want a file named start.sh
edit it with any text editor like this:

Code:
#!/bin/bash
# Start
# Configure IP address for WLAN
sudo ifconfig wlan0 192.168.150.1
# Start DHCP/DNS server
sudo service dnsmasq restart
# Enable routing
sudo sysctl net.ipv4.ip_forward=1
# Enable NAT
sudo iptables -t nat -A POSTROUTING -o ppp0 -j MASQUERADE
# Run access point daemon
sudo hostapd /etc/hostapd.conf
# Stop
# Disable NAT
sudo iptables -D POSTROUTING -t nat -o ppp0 -j MASQUERADE
# Disable routing
sudo sysctl net.ipv4.ip_forward=0
# Disable DHCP/DNS server
sudo service dnsmasq stop
sudo service hostapd stop
You will probably need to change ppp0 in this to eth0 (or any other number which refers to your wired connection.

7. Last step. Now you can start your hotspot by starting our script. just run it using sudo sh
for me it looks like this sudo sh /home/ogyct/Desktop/start.sh because I have it on my desktop


I am not sure who is the author of this guide, I only translated it to english. But anyway if this helped, hit the thanks button. Good day


Thank you.
Its worked successfully in Xperia J.
19th June 2013, 04:45 AM |#19  
Junior Member
San Diego
Thanks Meter: 5
 
More
Worked in Linux Mint v15 (based on Ubuntu 13.04)
johnp
20th June 2013, 01:04 PM |#20  
OP Member
Thanks Meter: 37
 
More
A little update, I am glad if this guide helped. but in case it didn't try this one http://www.webupd8.org/2013/06/how-t...ot-access.html. I didn't check this myself, but that script seems to be smart.
22nd July 2013, 02:04 PM |#21  
Junior Member
Thanks Meter: 0
 
More
Exclamation Big Fail
i did just like you said, it didn't work... i don't care, but now i removed the two packages you mentioned and my wireless broke.... the hotspot won't stop anymore, any solution ? i installed the packages again and stop them but the wireless haven't been fixed
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes