Remove All Ads from XDA
Win Honor 9 Lite

[APP][25MAR10]Gen.Y DualBOOT v1.0.6.0[W|Q|VGA][CAB|EXT]

947 posts
Thanks Meter: 572
By yozgatg, Senior Member on 26th January 2010, 07:53 PM
Post Reply Email Thread
28th January 2010, 10:36 PM |#201  
Junior Member
Thanks Meter: 2
it should only take a couple of minutes...tops...and getting the solution depends on what device you are using.
28th January 2010, 10:41 PM |#202  
Senior Member
Flag Bennebroek
Thanks Meter: 1
Why isn't the app starting on Miri's V3.5 21889?
28th January 2010, 11:16 PM |#203  
yozgatg's Avatar
OP Senior Member
Thanks Meter: 572
Donate to Me
Originally Posted by ammmze

Hey there,

This is a pretty good idea...for a non-invasive dual-boot...I like.

I did have to remake the images so they worked with the Omnia's screen which has a a WQVGA screen (240x400)...I will attach those pictures for anyone else that wants them.

Now I just need to figure out why I can't get it to find android...if storage boot mode is set to internal I get...
"An error occured on sub __main_androidexistcheck.

An error occurred retrieving the registry key"

However if I set it to the storage card it just disables android its not erroring out. I don't think it will be able to read the storage card because it is formatted to ext3...when I am in ubuntu I will try putting it on the card and we shall see.

Anyways here are pictures for omnia users...just overwrite the ones in \Program Files\Gen.Y\DualBOOT\

did you cook in the EXT (the "unfixed" v1.03)?
if so, u should have one registry key that is missing:
Go to the registry and add the following key:
ps, i didn't know the the Omnia had android, i'll try to build a native WQVGA solution soon
29th January 2010, 12:15 AM |#204  
chaoscreater's Avatar
Senior Member
Flag Auckland
Thanks Meter: 58
Originally Posted by ajclai08

I'm sorry but this simply isnt true. Without "renaming" the just have to enter the program and press "Start" inside haret. Otherwise why would have to rename it in the 1st place?? I know this because I've been booting android on my SD card since dec 2008.

And Yes it's all "Duel booting" if you have Windows on your NAND, and Android on your SD...Your duel booting no matter if your using a graphical interface( Like this app) to do so.

I'm curious as to where you downloaded XDAndroid, because in the package, none of the readme or instructions says that. It doesn't even come with a default.txt file. All you do is go inside the folder "STARTUP CONFIG", and extract the startup.txt file for your particular phone, basically every folder will have a startup.txt file and each folder will be for a different phone, e.g. RAPH800, DIAM800 etc, and you simply just take out the startup.txt for your particular phone. I got it from here btw:

and btw even though the instruction on the website says this:


1: Remove all previous Android files, if present
2: Copy the contents of the archive to the root of the storage card, if on
the Raphael, or to the root of the internal storage if on the Diamond.
3: Go into the startups folder and choose the startup.txt for your
device model and rename it to startup.txt and copy it out to the root folder, overwriting the existing one.

4: Disconnect the device, launch Haret and enjoy!

but that's not required since they're already called startup.txt in the first place, there's no renaming needed.

And btw, i did try to boot haret.exe without startup.txt (because i forgot to extract it to my storage card during one of my Android updates), and it doesn't work. Maybe the one you downloaded is different to mine since it seems yours come with a default.txt which you have to rename. I don't have that.

And btw, i know this because i've been running Android since the VERY FIRST version when it came out.

And as for the technical idea on dual booting, it's NOT. Even using this program, it's NOT dual booting. You do realize that you have to be running Windows Mobile "FIRST", and then run an "EMULATED" linux to launch Android, right?? You're not running 2 separate operating system from the ground up, you have to go through Windows Mobile to emulate linux no matter what, and it's plain annoying.

But this program does make it seem a bit more better to at least say it's dual booting, because it launches straight away without you actually have to click haret.exe to launch it. Although that's what i'd like to say, it's not the case for me because i'm still having problems to get this thing to work. I can run XDAndroid 2.1 (latest version) fine, but using this app doesn't work for me.

and as for the main matter of this topic, i'm STILL getting this problem even though i tried the latest v1.03 version:


Basic4ppc (title of the window that shows the error)

An error occured on sub_main_bootandroid.

An error occured retrieving the registry key. Continue?

I installed it to my internal memory, not my storage card. I tried both the VGA versions, the one for internal storage, and the one for storage card. I installed both to my internal memory on my phone and it just won't work, it keeps showing that error.
29th January 2010, 12:58 AM |#205  
waza123's Avatar
Flag Рига
Thanks Meter: 5
very nice soft !

But i would like to see Android OS on HTC HD2
29th January 2010, 12:58 AM |#206  
Thanks Meter: 3
Is it possible to uninstall DualBoot when you want too, or is it permanent once installed?
29th January 2010, 01:50 AM |#207  
Thanks Meter: 1
Installed and nothing happens.

Running TPCElite ROM

I can run GenY from the program folder and I changed the registry key to look for Android in the /Android/ folder of my SD but still doesn't boot at startup.

When DualBOOT ran I could tell it to boot Android and it took me to haret so it works. Just not on startup. Oh and I'm running the QVGA version if that helps...

Great start otherwise.
29th January 2010, 03:40 AM |#208  
kwill's Avatar
Senior Member
Flag Austin, TX
Thanks Meter: 27
Thanks SOOO much for this yozgatg! Works perfect and is just what we all needed.
29th January 2010, 03:46 AM |#209  
Zahurtex's Avatar
Senior Member
Thanks Meter: 221
Thanks works perfectly on my TP2...rom: Valkyrie 5.6Leo F-5
29th January 2010, 03:50 AM |#210  
Senior Member
Flag Confusion
Thanks Meter: 99
Donate to Me
works great on my Sprint touch pro now to just find a good copy of android to run on it lol
29th January 2010, 04:27 AM |#211  
JM-PDA's Avatar
Senior Member
Flag Sacramento, CA
Thanks Meter: 62
Originally Posted by Mr. Megiddo

Installed and nothing happens.

Running TPCElite ROM

I can run GenY from the program folder and I changed the registry key to look for Android in the /Android/ folder of my SD but still doesn't boot at startup.

When DualBOOT ran I could tell it to boot Android and it took me to haret so it works. Just not on startup. Oh and I'm running the QVGA version if that helps...

Great start otherwise.

I am experiencing the exact same situation running the stock ROM on a Sprint HTC Touch (Vogue).
I installed "Gen.Y DualBOOT QVGA v1.03 - Storage" to my SD Card.

Here are my "HKEY_CURRENT_USER\Software\Gen.Y\DualBOOT" settings:
"AutoBootEnabled"=1: enable autoboot
"FastBootEnabled"=0: disable fastboot
"AutoBootAndroid"=1: boot Android
"StorageBootMode"=1: boot from Storage Card (SDMemory)
"AndroidBootFolder"=1: boot from \Android\ folder on storage (e.g. \Storage Card\Android\haret.exe)

When I boot up my phone, it goes straight to windows.
However, once in windows, I can use file explorer to run the genyboot.exe. Genyboot window comes up perfectly and detects that Android is installed correctly. After the countdown bar finishes, it sits on the Haret window waiting for me to click the RUN button.

I would love to be able to use this app to boot into Android faster.
Please advise.
Thank you very much!
Post Reply Subscribe to Thread

android dualboot, android fastboot

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes