FORUMS
Remove All Ads from XDA

Use APKTool on Android!

24 posts
Thanks Meter: 73
 
Post Reply Email Thread
20th October 2013, 03:51 PM |#11  
Member
Flag Mumbai
Thanks Meter: 27
 
More
Quote:
Originally Posted by iamashwin

Check the download section of the code website. there choose the best busybox file that suits you
download it. replace that from the apktool data folder.

I know this is off topic but....
I want to flash ur mod perfomances v2 whih u posted on sungsonic forum before 8t got hacked
do u still use it and if yes, on sshd v5?
pls tell me how to install on tab 2 and will it affect the sound audio video quality of sshd?
 
 
20th October 2013, 04:31 PM |#12  
Member
Thanks Meter: 10
 
More
thanks...
21st October 2013, 10:47 AM |#13  
iamashwin's Avatar
Senior Member
Flag Mysore
Thanks Meter: 378
 
Donate to Me
More
Quote:
Originally Posted by royal_rocker

I know this is off topic but....
I want to flash ur mod perfomances v2 whih u posted on sungsonic forum before 8t got hacked
do u still use it and if yes, on sshd v5?
pls tell me how to install on tab 2 and will it affect the sound audio video quality of sshd?

Check your PM
The Following User Says Thank You to iamashwin For This Useful Post: [ View ] Gift iamashwin Ad-Free
15th November 2013, 11:09 PM |#14  
guy4jesuschrist's Avatar
Senior Member
Thanks Meter: 140
 
More
Quote:
Originally Posted by emkeene

I don't have my own computer, so I was poking around looking for a solution to work with apk files on my phone and found this:

http://code.google.com/p/apktool/

The apktool folder has to be in the root of your sd card. I was able to successfully decompile and recompile my framework-res.apk with no errors.

Instructions:
Download the archive apktool4.0_armhf.zip from http://code.google.com/p/apktool/downloads/list
Download the updated apk file Apktool4.0.apk as well
Extract/unzip archive to /sdcard/apktool
Install the updated Apktool4.0.apk
Open app from app drawer, and have fun using it!

So please try this out, and let me know what you think!

Thanks so much for this! It was a big help, since I couldn't get apktool up and running on my Mac...plus, this seems much more convenient!
The Following User Says Thank You to guy4jesuschrist For This Useful Post: [ View ] Gift guy4jesuschrist Ad-Free
20th December 2013, 08:17 PM |#15  
matthew0776's Avatar
Senior Member
Flag Chicago
Thanks Meter: 8,774
 
Donate to Me
More
I cant seem to get apks to recompile it says ok...But i dont see recompiled apk anywhere...? decompile seems ok. Are there any steps are procedures that i need to know. i have apk installed and running. Just cant recompile apks.

Here's what it says when it's done


/sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/AndroidManifest.xml:166: error: Error: Resource is not public. (at 'enabled' with value '@android:bool/config_telephony_use_own_number_for_voicemail').
/sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/AndroidManifest.xml:173: error: Error: Resource is not public. (at 'enabled' with value '@android:bool/config_telephony_use_own_number_for_voicemail').
Exception in thread "main" brut.androlib.AndrolibException: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/lix/aapt4.4, p, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4-893803, -F, /data/data/per.pqy.apktool/APKTOOL3688796583016004073.tmp, -I, ?/apktool/framework/1.apk, -S, /sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/res, -M, /sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/AndroidManifest.xml]
at brut.androlib.Androlib.buildResourcesFull(Androlib .java:434)
at brut.androlib.Androlib.buildResources(Androlib.jav a:362)
at brut.androlib.Androlib.build(Androlib.java:285)
at brut.androlib.Androlib.build(Androlib.java:258)
at brut.apktool.Main.cmdBuild(Main.java:233)
at brut.apktool.Main.main(Main.java:88)
Caused by: brut.androlib.AndrolibException: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/lix/aapt4.4, p, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4-893803, -F, /data/data/per.pqy.apktool/APKTOOL3688796583016004073.tmp, -I, ?/apktool/framework/1.apk, -S, /sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/res, -M, /sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/AndroidManifest.xml]
at brut.androlib.res.AndrolibResources.aaptPackage(An drolibResources.java:481)
at brut.androlib.Androlib.buildResourcesFull(Androlib .java:415)
... 5 more
Caused by: brut.common.BrutException: could not exec command: [/data/data/per.pqy.apktool/lix/aapt4.4, p, --min-sdk-version, 19, --target-sdk-version, 19, --version-code, 19, --version-name, 4.4-893803, -F, /data/data/per.pqy.apktool/APKTOOL3688796583016004073.tmp, -I, ?/apktool/framework/1.apk, -S, /sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/res, -M, /sdcard/Download/Contacts4.4/system/priv-app/Contacts_src/AndroidManifest.xml]
at brut.util.OS.exec(OS.java:89)
at brut.androlib.res.AndrolibResources.aaptPackage(An drolibResources.java:475)
... 6 more
I: Using Apktool 2.0.0-Beta7 on Contacts_src
I: Copying classes.dex file...
I: Building resources...
The Following 2 Users Say Thank You to matthew0776 For This Useful Post: [ View ] Gift matthew0776 Ad-Free
29th December 2013, 08:39 AM |#16  
ummarrkhan's Avatar
Senior Member
Flag Srinagar,Jammu & Kashmir
Thanks Meter: 83
 
Donate to Me
More
Quote:
Originally Posted by emkeene

I don't have my own computer, so I was poking around looking for a solution to work with apk files on my phone and found this:

http://code.google.com/p/apktool/

The apktool folder has to be in the root of your sd card. I was able to successfully decompile and recompile my framework-res.apk with no errors.

Instructions:
Download the archive apktool4.0_armhf.zip from http://code.google.com/p/apktool/downloads/list
Download the updated apk file Apktool4.0.apk as well
Extract/unzip archive to /sdcard/apktool
Install the updated Apktool4.0.apk
Open app from app drawer, and have fun using it!

So please try this out, and let me know what you think!

when I am trying to decompile it says
sh: Can't open /data/data/per.pqy.apktool/mydata/tool.sh
The Following 2 Users Say Thank You to ummarrkhan For This Useful Post: [ View ] Gift ummarrkhan Ad-Free
29th December 2013, 10:58 AM |#17  
Shaftamle's Avatar
Recognized Themer
Flag Ellicott City
Thanks Meter: 5,339
 
Donate to Me
More
Quote:
Originally Posted by ummarrkhan

when I am trying to decompile it says
sh: Can't open /data/data/per.pqy.apktool/mydata/tool.sh

Is the apktool folder on the root of your devices storage?

Sent from a Shaftamle Galaxy S4
"Thanks Button" is always appreciated!
http://mycolorscreen.com/Shaftamle/
The Following User Says Thank You to Shaftamle For This Useful Post: [ View ] Gift Shaftamle Ad-Free
29th December 2013, 11:19 AM |#18  
ummarrkhan's Avatar
Senior Member
Flag Srinagar,Jammu & Kashmir
Thanks Meter: 83
 
Donate to Me
More
Quote:
Originally Posted by Shaftamle

Is the apktool folder on the root of your devices storage?

Sent from a Shaftamle Galaxy S4
"Thanks Button" is always appreciated!
http://mycolorscreen.com/Shaftamle/

yes that is on root directory like this /sd card/apktool
The Following User Says Thank You to ummarrkhan For This Useful Post: [ View ] Gift ummarrkhan Ad-Free
6th January 2014, 11:46 AM |#19  
ElRongMcBong's Avatar
Senior Member
Flag Neuss
Thanks Meter: 81
 
More
Yesterday i found this wonderful stuft and i can say: Its works perfekt on Samsung s4 (i9505)
Then i must make a fullwipe and install the app again.
But for now, i get only this Error:
/data/data/per.pqy.apktool/mydata/apktool2.sh: line6: /data/data/per.pqy.apktool/lix/jvm/java-7-openjdk-armhf/jre/bin/java: Permission denied
My Phone is rootet (SuperSu v1.89)
And i have Busybox (v1.21.1)
Wha t cai do, that Apktool for Android works again???
Please help !!!
The Following User Says Thank You to ElRongMcBong For This Useful Post: [ View ] Gift ElRongMcBong Ad-Free
7th January 2014, 03:08 AM |#20  
ummarrkhan's Avatar
Senior Member
Flag Srinagar,Jammu & Kashmir
Thanks Meter: 83
 
Donate to Me
More
Quote:
Originally Posted by SimonGleinert

Yesterday i found this wonderful stuft and i can say: Its works perfekt on Samsung s4 (i9505)
Then i must make a fullwipe and install the app again.
But for now, i get only this Error:
/data/data/per.pqy.apktool/mydata/apktool2.sh: line6: /data/data/per.pqy.apktool/lix/jvm/java-7-openjdk-armhf/jre/bin/java: Permission denied
My Phone is rootet (SuperSu v1.89)
And i have Busybox (v1.21.1)
Wha t cai do, that Apktool for Android works again???
Please help !!!

use 4.1 version
Im also using that working perfectly on my galaxy s
The Following User Says Thank You to ummarrkhan For This Useful Post: [ View ] Gift ummarrkhan Ad-Free
7th January 2014, 02:07 PM |#21  
ElRongMcBong's Avatar
Senior Member
Flag Neuss
Thanks Meter: 81
 
More
Thx, i test it, but its dont work again.
Then i change the Kernel...and its work
I think the StockKernel make problem, but its no problem for me.
I never use the StockKernel...i only use the StockKernel if i need AllShare for play EmulatorGames on my TV
The Following User Says Thank You to ElRongMcBong For This Useful Post: [ View ] Gift ElRongMcBong Ad-Free
Post Reply Subscribe to Thread

Tags
apk, apktool, decompile, edit, tool

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes