Remove All Ads from XDA

[Q] Potential Galaxy S4 battery issue?

7 posts
Thanks Meter: 0
By AdmiralAqbar, Junior Member on 16th April 2014, 04:45 AM
Post Reply Email Thread
Hi all,

Hoping i posted this in the correct section but i'll start off.

So i've had my S4 for about a year and a half now, a couple days ago the phone's started to act up. It turned off, wouldn't turn back on, i did the typical battery pull but the weird thing is when i did, the phone would vibrate right after i put it in, the GS4 logo comes up and then it just shuts off. I've tried to charge it and it won't work, tried doing a battery pull and then putting it back in then quickly plugging the charger in before it vibrates and nothing. Does anyone know what my issue could be? I can post some pictures to help reference but any knowledge on this would be greatly appreciated.

I'm on the latest Kit Kat update, running on rogers.
Attached Thumbnails
Click image for larger version

Name:	1420654_10152316525303550_1549718951_n.jpg
Views:	57
Size:	66.7 KB
ID:	2689015   Click image for larger version

Name:	10259439_10152316525308550_2101940999_n.jpg
Views:	58
Size:	50.6 KB
ID:	2689016  
30th August 2014, 12:04 AM |#2  
Junior Member
Thanks Meter: 0
I hate to bump such an old thread, but I've looked and looked and haven't found many threads with this issue. So, might as well bring the issue to the front so it's visible.

I'm having this exact issue as of this morning. The phone shows the Samsung logo after booting up for a bout 1-2 seconds before turning off. Won't power on until the battery is pulled/replaced. Only powers on for 1-2 seconds again.

If it's plugged into the charger, the same thing happens, except instead of the Samsung logo, it's the empty battery logo with the cogwheel, before turning off 1-2 seconds later.

Worked fine last night, this morning, nothing.

Anyone experienced/resolved this issue?
1st September 2014, 04:42 AM |#3  
Junior Member
Thanks Meter: 0
Unfortunately, the exact same thing is happening with my phone as well now. About two hours ago I was playing a game and then the internet stopped working. Less than a minute later the phone turned off and now I can't boot up past the logo that is displayed for like a second.
1st September 2014, 03:21 PM |#4  
jd1639's Avatar
Recognized Contributor
Thanks Meter: 5,152
Donate to Me
Can you guys get into download mode? If so I'd Odin the stock firmware and see if the problem goes away.

Sent from my Nexus 5 using XDA Free mobile app
1st September 2014, 03:47 PM |#5  
Thanks Meter: 0
if all else fails you could pm OP and see what he did. he never posted again so may have got it working.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes