FORUMS
Remove All Ads from XDA

[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,134 posts
Thanks Meter: 14,610
 
By zhuhang, Recognized Contributor on 15th March 2013, 05:42 AM
Post Reply Email Thread
4th March 2018, 10:32 PM |#27081  
Alxoom33's Avatar
Senior Member
Flag New York
Thanks Meter: 1,634
 
More
Quote:
Originally Posted by JT1510365

I would never donate to the viper devs mostly because this audio mod never works for me. I tried installing v2.5.0.5 but it says failed on my galaxy s4 running kirk at due to a busy box error which I know isn't a problem because busy box works for everything else. What do I have to do to get this to work on my phone it doesn't seem like this audio mod ever works in my opinion. I tried everything do I have to set seeing to permissive what do I have to do I'm not the only one with the issue

You have an older phone. Try installing an earlier version of Viper which may be compatible with the old S4.

Sent from my Pixel 2 XL using Tapatalk
5th March 2018, 12:00 AM |#27082  
x.trinity's Avatar
Senior Member
Thanks Meter: 125
 
More
Quote:
Originally Posted by Alan Jose

Hi @Clark789
The simplest way to have viper on android oreo8.1 is to install magisk 16.0, then install the viper4android module from ahrion that can be found within the magisk app -> downloads section (in the main app) .You can even choose if you want the 2.3.4.0 or 2.5.0.5 drivers during install. It works straight after installing, and without any configuration needed

It doesn't require SElinux permissive mode

Happy installing

Ive just got Google Play Store warning notification VIPER4Android may harm my phone and its strongly recommended to uninstall the app.
5th March 2018, 12:37 AM |#27083  
shaggyskunk's Avatar
Recognized Contributor
Flag IDK
Thanks Meter: 15,799
 
More
Quote:
Originally Posted by x.trinity

Ive just got Google Play Store warning notification VIPER4Android may harm my phone and its strongly recommended to uninstall the app.

I'm not sure of the reason for your post?
But if it's to laugh at Google then that's fine 🤡

If it's because you are concerned - Don't be - It's just Google being Google... I'm actually a bit surprised that Google doesn't have a "Freaking Stroke" about having SuperSU & ALL the other Root apps that are available on the Store..... 🐧
5th March 2018, 01:04 AM |#27084  
x.trinity's Avatar
Senior Member
Thanks Meter: 125
 
More
Quote:
Originally Posted by shaggyskunk

I'm not sure of the reason for your post?
But if it's to laugh at Google then that's fine 🤡

If it's because you are concerned - Don't be - It's just Google being Google... I'm actually a bit surprised that Google doesn't have a "Freaking Stroke" about having SuperSU & ALL the other Root apps that are available on the Store..... 🐧

Yep, good point.
From my perspective it was more along the lines of curiosity in regard RR/O has permissive SE mod, by default, and can't be switched to enforcing. Besides I had seen that kind of warning notification for the first time.
5th March 2018, 01:22 AM |#27085  
Alxoom33's Avatar
Senior Member
Flag New York
Thanks Meter: 1,634
 
More
Quote:
Originally Posted by x.trinity

Ive just got Google Play Store warning notification VIPER4Android may harm my phone and its strongly recommended to uninstall the app.

It's because it has the ability to change Selunix to permissive mode in Settings/Enter developer mode.

Sent from my Pixel C using Tapatalk
5th March 2018, 01:33 AM |#27086  
x.trinity's Avatar
Senior Member
Thanks Meter: 125
 
More
Quote:
Originally Posted by Alxoom33

It's because it has the ability to change Selunix to permissive mode in Settings/Enter developer mode.

Sent from my Pixel C using Tapatalk

As Ive wrote, my SE is already permissive and cant be changed to enforcing.
5th March 2018, 01:45 AM |#27087  
shaggyskunk's Avatar
Recognized Contributor
Flag IDK
Thanks Meter: 15,799
 
More
Quote:
Originally Posted by x.trinity

As Ive wrote, my SE is already permissive and cant be changed to enforcing.

Yeah that's not the reason - Even on Roms with SELinux Enforcing Google Play still says that you should "uninstall the harmful app".... If Google is so concerned about Security - They really ought to up their own vetting of apps that they make money from.... And if Security was truly the issue - Root apps should all be triggering the same warning... 🐧
5th March 2018, 01:48 AM |#27088  
Alxoom33's Avatar
Senior Member
Flag New York
Thanks Meter: 1,634
 
More
Quote:
Originally Posted by x.trinity

As Ive wrote, my SE is already permissive and cant be changed to enforcing.

If Google determines an app has the ability to chang the SE state to permissive it flags it as unsafe.
It dosn't matter what your SE state is.

Sent from my Pixel C using Tapatalk
5th March 2018, 02:16 AM |#27089  
el.musthofa's Avatar
Senior Member
Flag Bojonegoro
Thanks Meter: 41
 
More
Quote:
Originally Posted by JT1510365

I would never donate to the viper devs mostly because this audio mod never works for me. I tried installing v2.5.0.5 but it says failed on my galaxy s4 running kirk at due to a busy box error which I know isn't a problem because busy box works for everything else. What do I have to do to get this to work on my phone it doesn't seem like this audio mod ever works in my opinion. I tried everything do I have to set seeing to permissive what do I have to do I'm not the only one with the issue

You're very unlucky, Man.
I never left my phone without V4A.
I just learn the old phone must installed by old version too.
5th March 2018, 02:49 AM |#27090  
Member
Thanks Meter: 10
 
More
I have a Samsung SGH-i337 Galaxy S4. I had Viper on my old S4 but this one is not working. I am running the stock 0K3 ROM. My old S4 had OK2. I have tried multiple versions and have made the changes to build.prop. I think the problem is flashing supolicy.zip. I used flashfire as before but when it reboots, it hangs on the white AT&T screen. I can force a reboot but that makes me think the flash was unsuccessful. What do I have to do here?
5th March 2018, 02:58 AM |#27091  
JT1510365's Avatar
Senior Member
Flag South Lyon
Thanks Meter: 1,915
 
More
Quote:
Originally Posted by el.musthofa

You're very unlucky, Man.
I never left my phone without V4A.
I just learn the old phone must installed by old version too.

Yep i finally got it working on my s4 and man i feel so stupid this mod is awesome i was so stupid to not think about trying an older version lol
Post Reply Subscribe to Thread

Tags
best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes