FORUMS
Post Reply Email Thread


This is new Android distribution based on Linux, Android and Archos stock os, using SDE from Archos.

Features:
  • Easy install method for external (SDcard) and Internal storage
  • EXT4 (much faster than ext3, can store files >4GB comparing to FAT32)
  • Full read/write access to every part of system
  • root (su + superuser.apk) out of the box
  • new services like: samba, sshd, vpnc, openvpn, dvbt, nfs4
  • 3G/usb tether support
  • Possibility to remove some google/Archos apps
  • Swap memory in RAM (CompCache) or on disk by default or when you need it
  • No 300MB limit for apps (and no faulty app2sd required)
  • You can have SD card Class 8/10 - that can be much faster than internal flash (check this thread)
  • Many new new kernel modules (usbserial, ntfs, 3G modems, nfs4, cifs, hfs, iptables etc.)
  • DVB-T support for selected tuners
  • updated modules, firmware (like WiFi)
  • User friendly UrukConfig application
  • ... and much, much more - to much to mention all here - please read changelog

Since 1.0 release main documentation source for UrukDroid is on it's WiKi. Please use it as a first and primary information source for UD.

Link to project (googlecode) page is: http://code.google.com/p/urukdroid

Update (10.09.2015)
Since code.google.com is no longer working (read only for limited time) - here are working links to latest (and final) release of UrukDroid: Dropbox,

I hope that new, much more detailed and complete documentation will help you use UrukDroid at it's full potential.
The Following 100 Users Say Thank You to $aur0n For This Useful Post: [ View ] Gift $aur0n Ad-Free
1st January 2011, 01:43 PM |#2  
$aur0n's Avatar
OP Senior Member
Thanks Meter: 509
 
Donate to Me
More
Changelog, proposed futures
Changelog:

UrukDroid 1.6 (02.01.2012) "DOV FUS LOS Wahl ko Daar Sivaas!"
  • [CHANGE] Incorporated changes from Archos firmware 2.4.19, 2.4.65, 2.4.80 and 2.4.81
  • [CHANGE] Updated superuser apk and binaries
  • [FIX] Fixed some library linking
  • [NEW] Changed top bar button size to 32px permanently
  • [NEW] New overclock module from milestone-overclock to change CPU voltage and max frequencies on the fly
  • [CHANGE] Added overclock support to CPUGovernor service
  • [FIX] Restored proper busybox binary
  • [NEW] New patches on kernel from December update from Archos git
  • [NEW] Full iptables support (with NAT, conntrack etc) - so everything is now possible (redirect, proxies etc)
  • [NEW] Full kernel timing for power consumption monitoring
  • [NEW] Recompiled WiFi? and HDMI drivers
  • [NEW] Added python 2.7, iotop (for watching i/o operations), PowerTOP (for power consumption monitoring - but it's not as useful as on x86)
  • [NEW] Added ntfs-3g support - full read/write support for NTFS file systems (need to be used manually, vold does not use it)
  • [CHANGE] Added UrukDroid? Rescue Menu - Repair submenu with disabling overclocking (for those who made their device unbootable with overclocking) and Dalvik cache cleaner
  • [NEW] New feature in cpugovernor script (genconf, current)
  • [CHANGE] New features in update subsystem
    scripts now tries to keep /data/.tmp directory cleaner,
    for those with disk shortage /data/.tmp can be now symlink to directory on sdcard
    updater now checks if you have enough free space in /data/.tmp before it begin installation
    update process now can be during bootup (better one) if you have enough free space on rootfs, or on running system (not so nice - this is default behavior until UD 1.6 release)
  • [CHANGE] restoring backup in Rescue Menu now erases partition before restore (until now it was just overwriting)
  • [FIX] added (again ) xbox pad kernel support (was missed out in new kernel compilation)
  • [FIX] fixes scp/sftp-server (on some configuration refused to start child processes)

UrukDroid 1.5 (16.0.2011) Manamana!
  • [CHANGE] Since UrukDroid? 1.1 (both beta1/2/3 and release candidate 1/2/3) had stability and compatibility issues - that I was unable to trace down (too many changes on changes etc.) - I've decided to implement all stuff from beginning on fresh OS. Since all "reverse engineering" stuff was already made and I already have required knowledge - It should be the fastest method. So entire system is cleaned up, updated to latest binaries - and so far looks good . That's why I've bumped version to 1.5 - just to make it a bit more visible it's not a straight continuation of 1.0/1.1.
  • [FIX] No more "soft reboots" (system reloaded it's graphics UI part)
  • [FIX] No more turning off WiFi issue (but it happens that WiFi can't pop in after full reboot - another reboot is required)
  • [FIX] CIFS startup on boot (Issue 57)
  • [CHANGE] Update process should be now more chatty and report more errors
  • [CHANGE] Reverted back WPA service (which enable UrukDroid? WPA supplicant with AdHoc? support) - since some people reported problems with adding new networks with Uruk version of WPA supplicant.
  • [CHANGE] Merged changes from Archos 2.3.28 OS
  • [NEW] New wpa_supplicant - hopefully with all features and without most of known problems (sometimes it still refuses to start)
  • [CHANGE] Updated modules and kernel
  • [FIX] Fix camera support for A43
  • [CHANGE] Merged changes from Archos 2.3.26 OS
  • [CHANGE] Redesigned services to output more reliable status
  • [FIX] Mediascanner fixes (did not rescan data sometimes)
  • [NEW] Introduced in 1.0 "Rescue Menu" now fully functional (RM)
  • [NEW] RescueMenu now have Alternative OS? boot feature
  • [NEW] RescueMenu now have "bare metal" backup/restore functionality
  • [NEW] Update process will now communicate with user with help of UrukConfig
  • [NEW] Enabled cgroups
  • [FIX] "Moved" boot image on A101
  • [FIX] 3Gmodem_init.sh fixes
  • [NEW] You can dissable boot from SDCard by naming any of it's partition "noboot" ('[email protected]:/root# e2label /dev/block/mmcblk2p1 noboot')
  • [NEW] patch (by Sibere) increasing USB current in Host mode
  • [NEW] New default apps in UrukDroid 1.5: WiFi Manager, FileExpert, QuickPic, Opera browser

UrukDroid 1.0 (30.04.2011)
  • [FIX] sshfs missing files fix
  • [FIX] EasyInstall: changed datafs max size from 2GB to 1.95GB (for market to work), fixed partition sizes for A101 16GB when doing internal install with resize, fixed installation for A70H devices
  • [NEW] small script to copy UrukDroid files from SDCard (external) to Internall (copy_from_sd_to_internal.sh)
  • [CHANGE] Changed behaviour of dvb service (device configuration)
  • [FIX] Added some missing modules for DVB support
  • [CHANGE] New kernel modules for more dvb devices (but it requires manual loading and testing)
  • [NEW] rsync tool
  • [CHANGE] swap service now can work on swap partition (or like before on swap file), also after mounting sdcard ext4 partition
  • [NEW] Ad-Hoc WiFi connection support by default (networks are visible with "*" on beginning of it's SSID)
  • [CHANGE] Some new progress indicators during install/upgrade
  • [NEW] Simple Animation during late phase of bootup
  • [NEW] New service: cifs (to load cifs modules)
  • [NEW] Added cgroups kernel setting
  • [NEW] Moved some modules dependencies (cifs,ntfs,dvb) to /etc/modprobe.d

UrukDroid 0.7 (28.02.2011) you're damn right it's a gift!!
  • [NEW] NFSv4 client support
  • [NEW] FS-Cache (cachefilesd) support for NFS (local disk cache for NFS files)
  • [NEW] sshfs support
  • [FIX] OpenVPN fix - thanks to nenadr
  • [FIX] PPtP fix - thanks to nenadr
  • [NEW] vpnc tool for using Cisco VPN connections
  • [NEW] vpnc UrukDroid service
  • [CHANGE] Updated to libc6 2.11 (and all binaries recompiled/changed because of it - big change)
  • [NEW] new gnu tools: nmap
  • [NEW] EasyInstall now allows installing UrukDroid on internal (mmcblk1) storage in A70 and A101
  • [NEW] Integrated 3G USB modem and RNDIS USB tethering service by nenadr
  • [CHANGE] New iobench.sh (with new bonnie++ test)
  • [CHANGE] Changed device fingerprint to work better with google market (enable download some missing apps)
  • [CHANGE] Merged Archos 2.1.8 firmware changes
  • [CHANGE] Changed DVB subsystem support and kernel/modules dependencies to work with new v4l2 modules (it will brake compatibility with most other kernels probably)
  • [FIX] Changes it UrukUpdate mechanism to work every time when file is moved to "/data/UrukUpdate"
  • [NEW] Added required modules and iptables service configuration for DroidWall (firewall) application
  • [NEW] sudo subsystem for launching properly some root tasks

UrukDroid 0.6 (11.02.2011) Eye of the Uruk... in new logo
  • [CHANGE] Merged changes from Archos firmware 2.1.2/2.1.3/2.1.4
  • [CHANGE] DVB support with LiveTV.apk from chulri (for selected cards, there are more modules then listed in /etc/uruk.conf/dvb - but it requires to do some experiment and report it back)
  • [CHANGE] Changed Uruk service to work better with new UrukConfig
  • [NEW] New services: openvpn, mediascanner
  • [NEW] IO Benchmark tool: iobench.sh
  • [NEW] Possibility to turn off mediascanner and use it on demand only
  • [FIX] Fixed mount_sdcard.sh script to work with 2.1.2 ext3 partitions
  • [NEW] Updated boot sequence with progress during upgrade/install
  • [NEW] You can hide soft buttons (Archos buttons) with UrukConfig
  • [NEW] Easy Install method - no need to know anything about Linux - just plug and wait...
  • [NEW] Kernel modules for 3g dongle

UrukDroid 0.5 (27.01.2011) Tom Bombadil... in red
  • [NEW] CompCache (aka ramzswap) support
  • [NEW] New CPU governor - interactive. Ported from XDA CyanogenMOD
  • [NEW] DVB: applied patches by chulri, Siano SMS1XXX USB support
  • [NEW] DVB: modules from outside kernel tree
  • [NEW] Some more GNU tools: gzip utils, zip utils, unzip utils, nc (NetCut for DVB streaming)
  • [CHANGE] New services model - so they can be easily run/configured with help of UI
  • [NEW] New kernel modules: usbnet, lzo
  • [NEW] Mediascanner modification - it should has much, much smaller impact on system performance
  • [NEW] sqlite3 (3.5.9) installed, for easy database file manipulation
  • [NEW] after restart of UrukDroid it will boot once again to Uruk without need of pressing any buttons, to boot on stock OS please use boot menu
  • [FIX] mount_sdcard.sh fixed so it will mount first ext4 partition on sdcard if exist, and will not interfere with Vold if its vfat
  • [CHANGE] New update/upgrade/flash model - everything done on UrukDroid - no boot menu required
  • [NEW] New application to configure UrukDroid - UrukConfig.apk. Installed with this release. Can be uninstalled in default way.
  • [FIX] Fixed corrupted logo in A101
  • [NEW] Unified kernel for UrukDroid on SDCard and internal storage (A70S/A101)
  • [CHANGE] Services ENABLED with this release: CpuGovernor, CompCache

UrukDroid 0.4.2 (21.01.2011)
  • Just extracted as a separate update file GoogleMarket

UrukDroid 0.4.1 (15.01.2011) Myyy preciousssss...
  • Some more tools like: bc, proc utils, vim, tcpdump, bzip2, tar etc.
  • Android apps (Market, Maps, Talk, Calendar, Contact, Feedback, Locator, Updater) by default
  • Samba (3.2.5) support for sharing /mnt/storage (internal and sdcard storage) from Archos
  • Dropbear SSH server
  • Backported modprobe, depmod etc. tools for modules management
  • WiFI driver recompiled, WiFi HW firmware update (from 6.1.0.0.335 to 6.1.5.44.7)
  • Initial DVB-T support (Afatech AF9005, Afatech AF9015, DiBcom DiB0700, Terratec CinergyT2/qanu)
  • Bootlogo with progress steps
  • Cleanups of initramfs and rootfs
  • EXT4 drivers backported from 2.6.30 - some mount changes (to prevent config files corruption)
  • Initial A70H support
  • SDCard/HD layout changed
  • Autoupgrade service and installation helper
  • ADB fixes
  • Removed two apps. TelephonyProvider.apk, Phone.apk
  • Since 0.4 all services are DISABLED by default, to enable it edit proper config file in /etc/uruk.conf/

UrukDroid 0.3 (9.01.2011) Rise my Uruk... not yet Hai :P
  • iptables, ntfs support
  • some more USB modules: usbserial, pl2303
  • fixed bluetooth problem (not working in Uruk 0.2)
  • automounting improvements (much more bulletproof)
  • new configuration files (/etc/uruk.conf/) to enable/disable features
  • new Uruk services (/etc/uruk.d/)
  • some more GNU utils openssh-client, coreutils
  • USB charging enabled (NOT tested!!!) - It would required much more power then standard USB in PC can give, use USB wall/car charges or double/triple USB cables

UrukDroid 0.2 (5.01.2011) Go GNU release
  • "smart" automounting script (that will mount ext4/vfat third partition from sdcard in RIGHT place, AFTER internal storage is mount)
  • plenty of useful GNU tools: whole e2fstools (mkfs, fsck for ext2/ext3/ext4), parted (for partition resize, format etc.), vfat tools, new toolbox, mtr, top, strace, bash - and much more (look in /usr/local/bin and /usr/local/sbin)
  • swap memory ON by default (50MIB file /swap01.file)
  • required compiled libraries libparted, libncurses, libe2fs... etc. (look in /usr/local/lib)
  • new text editor in text mode: nano (my favourite)
  • some init.rc cleanups
  • kernel changes (mostly toward console output)
  • fixed small (but problematic) misconfiguration in Archos (yep original one) Android in linking /etc/mtab

UrukDroid 0.1 (30.12.2010) Initial "release"
  • recompiled kernel with ext4, nfs4, fb console
  • added su and superuser.apk
  • bootup changes (to make it work)

Features planed in next releases:
  • backup scripts
  • proxy settings
  • CynanogenMOD parts backported
  • OC/UC kernel be default
The Following 23 Users Say Thank You to $aur0n For This Useful Post: [ View ] Gift $aur0n Ad-Free
8th January 2011, 01:58 AM |#3  
Junior Member
Thanks Meter: 7
 
More
Wink class 10 vs class 4 sdhc cards
Quote:
Originally Posted by $aur0n

Code:
[email protected]:/tmp$ sync; date; dd if=/dev/zero of=test.file bs=1M count=100 2>/dev/null; sync; date
Wed Jan  5 19:02:28 CET 2011
Wed Jan  5 19:02:34 CET 2011
[email protected]:/tmp$ bc -q
scale=4
100/(34-28)
16.6666
quit

Your test got me courious about the difference between class 10 and class 4 sdcards so I ran a test on my laptop (I couldn't get dd to create a test.file greater than 100 bytes on my G-Tablet running VEGN-TAB beta 5.).

Verbatium microSDHC 4GB class 4:
Code:
$ sync; date; dd if=/dev/zero of=test.file bs=1M count=100 2>/dev/null; sync; date
Fri Jan  7 17:27:33 PST 2011
Fri Jan  7 17:27:44 PST 2011
$ bc -q
scale=4
100/(44-33)
9.0909
quit
SanDisk microSDHC 8GB class 10:
Code:
$ sync; date; dd if=/dev/zero of=test.file bs=1M count=100 2>/dev/null; sync; date
Fri Jan  7 17:30:54 PST 2011
Fri Jan  7 17:31:21 PST 2011
$ bc -q
scale=4
100/(62-34)
3.5714
quit
I don't feel so bad about spending the extra bucks, now, for a class 10 card.
8th January 2011, 02:21 AM |#4  
Senior Member
Thanks Meter: 155
 
More
I get "su not found" when I am in Android Terminal

I am at step 3
Quote:

Code:

su
mount -t ext4 /dev/block/mmcblk2p2 /data.new
cp -rp /data/* /data.new/
umount /data.new/


please help
8th January 2011, 05:10 AM |#5  
Junior Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by cnewsgrp

I get "su not found" when I am in Android Terminal

I am at step 3



please help

Did you make sure when it was rebooting to hold down the volume key and then boot from the developers edition? If not you were in the normal android os with out root.
8th January 2011, 12:33 PM |#6  
Senior Member
Thanks Meter: 155
 
More
Quote:
Originally Posted by cnewsgrp

I get "su not found" when I am in Android Terminal
I am at step 3

Quote:

su
mount -t ext4 /dev/block/mmcblk2p2 /data.new
cp -rp /data/* /data.new/
umount /data.new/


please help

$aur0n: Can you please help me? I cannot start step 3 because I cannot get su working on my Android Emulator
8th January 2011, 01:21 PM |#7  
Junior Member
Thanks Meter: 2
 
More
No su... you are most probably Not in developer mode..
12th January 2011, 01:39 PM |#8  
Senior Member
Thanks Meter: 155
 
More
Will it be possible to install this in Internal SD card and boot from it normally instead of SD at some future release? Maybe create the 1GB and 500 MB partitions on internal SD Card
12th January 2011, 01:46 PM |#9  
$aur0n's Avatar
OP Senior Member
Thanks Meter: 509
 
Donate to Me
More
Quote:
Originally Posted by Kashban

Tried writing to the ntfs device... not working, neither archos file explorer, nor root explorer. No error message in root explorer, though, just nothing showing up even on refreshing.

Perhaps Vold is mounting it in ro (read only) mode. Check
Code:
mount | grep -i ntfs
Quote:
Originally Posted by bthoven

Usb charges not work for me too, both from pc usb port and 1-amp adapter. Charger port still works as normal.(0.3 upgrade)

Like I said and wrote - it's enabled, I though it works (witch would be great form me) - but it's quite "rapid" development - so..

Quote:
Originally Posted by cnewsgrp

Will it be possible to install this in Internal SD card and boot from it normally instead of SD at some future release? Maybe create the 1GB and 500 MB partitions on internal SD Card

It is possible - but it won't be supported - if you read previous post you will see this method is enough complex for most of the people. Doing this on internal storage is more complicated and potentially harmful.
12th January 2011, 01:57 PM |#10  
Senior Member
Thanks Meter: 44
 
More
Quote:
Originally Posted by $aur0n

Perhaps Vold is mounting it in ro (read only) mode. Check

Code:
mount | grep -i ntfs

Flags show (rw,nosuid,nodev...). According to this it's in R/W Mode, root explorer stating the same. Message from Root explorer is always "folder created successfully", "successfully copied" and the like, but actually nothing has been written to it. Looks like any write stream is going to >dev/null.

Tried to delete as well... to no avail.
Post Reply Subscribe to Thread

Tags
archos, ext4, gen8, root, urukdroid

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes