FORUMS
Remove All Ads from XDA
Honor 7x
Win an Honor 7X!
Post Reply Email Thread
I'm new here so please correct me if I'm in the wrong forum, but I'm a longtime lurker and this site has been immeasurably helpful so thank you all

Anyways I just recently picked up a E4GT for Virgin Mobile off eBay. I got the VILLUMINATI CM11.0 4.4.2 ROM installed and I'm absolutely loving it--KitKat is sleek and fast, the new camera's great, all that. I'm very interested in trying out the new ART runtime (redundant acronyms are redundant), however when I switch the phone from Dalvik to ART everything seems to run just fine but I cannot get any mobile data to work. I get basic phone reception, so voice and SMS work but no data.

I'm running the FJ12 Virgin modem (as CM11 requires an ICS modem and that is the only one I can find anywhere for a VM D710), the CM11-20140428 unofficial build, and the included 3.0.64-CMgb61 kernel (packaged with CM11.0 it would seem).

So I'm wondering if anyone else has used ART with this phone on VM, and if so does your data work/did you find a way around it? Or can I use a Sprint modem flash with the VM phone? I know it's a Sprint kernel and that's fine, but I figure the modem firmware is a little different.

Anyways, thanks in advance for any help!
9th May 2014, 03:03 AM |#2  
OP Member
Flag Map. Ref. 41°N 93°W
Thanks Meter: 5
 
More
So after switching back to Dalvik, clearing all caches, switching back to ART, and sending a text, 3G came back. I'll update on any issues I find with ART later.

Sent from my SPH-D710 using XDA Free mobile app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes