FORUMS
Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Help Me Please! My Nook Tablet has never been rooted. I've been using the stock rom for over two years. I've been reading a new book for about 5 or 6 days. I thought my nook died when I tried to turn it on so I plugged it into an outlet. Left it there for about 4 hours. When I went to read, it would not turn on. I assumed maybe the charger got unplugged so I plugged the nook back in then tried to turn it on it would just go to the black "N" screen, turn completely black then go back to the black "N" screen. It does this only when its plugged into the wall or laptop. Once I unplug it it just turns completely black and does nothing, Would rooting it possibly fix this? Please help.

Additional Info:
I've never used an SD Card.
Everything was on internal memory.

Please help. Thanks
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes