FORUMS
Remove All Ads from XDA

Root cause for Gear 2 high battery consumption found, at least for non-Samsung phones

185 posts
Thanks Meter: 63
 
By mpogr, Senior Member on 21st May 2014, 06:13 AM
Post Reply Email Thread
2nd August 2014, 04:18 AM |#91  
Senior Member
Flag Jakarta
Thanks Meter: 7
 
More
To make kill_contacts permanent, you can create service so that it will automatically start on reboot

create file named kill_contacts.service
Code:
[Unit]
Description=Automatically Kill Contacts Every 2 Minutes

[Service]
ExecStart=/sbin/kill_contacts

[Install]
WantedBy=multi-user.target
push this file to /etc/systemd/system
change mod to 644
enable service
start service
Code:
c:\sdb root on
c:\sdb push kill_contacts.service /etc/systemd/system
c:\sdb shell
sh-3.2#chmod 644 /etc/systemd/system/kill_contacts.service
sh-3.2#systemctl enable /etc/systemd/system/kill_contacts.service
sh-3.2#systemctl start kill_contacts.service
check running service using :
Code:
journalctl -u kill_contacts.service
The Following 2 Users Say Thank You to wiedz For This Useful Post: [ View ] Gift wiedz Ad-Free
 
 
2nd August 2014, 06:55 AM |#92  
OP Senior Member
Flag Melbourne
Thanks Meter: 63
 
More
Quote:
Originally Posted by wiedz

To make kill_contacts permanent, you can create service so that it will automatically start on reboot

create file named kill_contacts.service

Code:
[Unit]
Description=Automatically Kill Contacts Every 2 Minutes

[Service]
ExecStart=/sbin/kill_contacts

[Install]
WantedBy=multi-user.target
push this file to /etc/systemd/system
change mod to 644
enable service
start service
Code:
c:\sdb root on
c:\sdb push kill_contacts.service /etc/systemd/system
c:\sdb shell
sh-3.2#chmod 644 /etc/systemd/system/kill_contacts.service
sh-3.2#systemctl enable /etc/systemd/system/kill_contacts.service
sh-3.2#systemctl start kill_contacts.service
check running service using :
Code:
journalctl -u kill_contacts.service

Thanks mate, I was too lazy to dig all this out...
2nd August 2014, 06:56 AM |#93  
OP Senior Member
Flag Melbourne
Thanks Meter: 63
 
More
Quote:
Originally Posted by ahmedmsvb

Hello,

I think the issue was solved for me without root (at least error "

Code:
E W-CONTACTS2-CONSUMER: ct-sap-svc-parser-contacts.c: __ct_sap_svc_get_default_number_str(998) > [0;31m* Critical * contacts_record_get_str() Failed(-61)[0;m
" stopped appearing).

The steps followed were:
1- Remove contacts with special characters.
2- Remove Google account
3- Add Google account again.
4- Restart phone
5- Factory reset Gear 2 Neo, perform the pairing again (without using the data restore option in Gear Manager).
6- Select only Google account in the "Contacts to Display" option in your Contacts app from the phone.


Notes:
- During the issue, I was getting the above mentioned error +200 times each single second. This means the Gear was trying >200 times a second, and this is the cause of battery drain.
- After applying the steps [1-6], the error no longer appears in my log file +20 minutes now.

Hope this helps someone else.



[Edit]: 1 hour since the solving the issue with <1% battery consumption

Sorry mate, tried this before, it helps, but only temporarily. Sooner or later (e.g. after Gear/phone reboot), the issue comes back...
2nd August 2014, 05:29 PM |#94  
JimSmith94's Avatar
Senior Member
Flag Irving, TX
Thanks Meter: 505
 
Donate to Me
More
I had to change "ExecStart=/sbin/kill_contacts" to "ExecStart=/bin/kill_contacts" because that's where you originally said to push kill_contacts to, but it's running now. Thanks!
2nd August 2014, 11:19 PM |#95  
Member
Thanks Meter: 0
 
More
The fix has been very useful for me, I have a very long Gear 2 battery (previous normal was 2 days, then becomes ½ day, after the root fix becomes 1 week).

I'm interested to try your fix below without root. Which part of the contact that should not have special characters? Any way to filter it easily in Google contacts? Lastly, is this 'fix' stable for few days running?

Quote:
Originally Posted by ahmedmsvb

Hello,

I think the issue was solved for me without root (at least error "

Code:
E W-CONTACTS2-CONSUMER: ct-sap-svc-parser-contacts.c: __ct_sap_svc_get_default_number_str(998) > [0;31m* Critical * contacts_record_get_str() Failed(-61)[0;m
" stopped appearing).

The steps followed were:
1- Remove contacts with special characters.
2- Remove Google account
3- Add Google account again.
4- Restart phone
5- Factory reset Gear 2 Neo, perform the pairing again (without using the data restore option in Gear Manager).
6- Select only Google account in the "Contacts to Display" option in your Contacts app from the phone.


Notes:
- During the issue, I was getting the above mentioned error +200 times each single second. This means the Gear was trying >200 times a second, and this is the cause of battery drain.
- After applying the steps [1-6], the error no longer appears in my log file +20 minutes now.

Hope this helps someone else.



[Edit]: 1 hour since the solving the issue with <1% battery consumption

3rd August 2014, 05:10 AM |#96  
Junior Member
Flag Riyadh
Thanks Meter: 0
 
Donate to Me
More
Working [Even after restart]
Quote:
Originally Posted by OngL

The fix has been very useful for me, I have a very long Gear 2 battery (previous normal was 2 days, then becomes ½ day, after the root fix becomes 1 week).

I'm interested to try your fix below without root. Which part of the contact that should not have special characters? Any way to filter it easily in Google contacts? Lastly, is this 'fix' stable for few days running?

Hello,

For me:
- Some contact names were having special characters.
- Sorry, I don't know a way to filter it easily in Google contacts.
- The fix is stable till now (~1% per hour consumption and 25% per day [Pedometer is on always]).
- I double checked by restarting my gear (and the phone), and examining the dlog_main file --> our error didn't appear in it
3rd August 2014, 02:40 PM |#97  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by mpogr

Code:
C:\Users\blah\Downloads> c:\tizen-sdk\tools\sdb push kill_contacts /sbin
C:\Users\blah\Downloads> c:\tizen-sdk\tools\sdb root on
C:\Users\blah\Downloads> c:\tizen-sdk\tools\sdb shell
# chmod 755 /sbin/kill_contacts
# systemd-run --unit=kill_contacts.nonsamsung --description="Automatically Kill Contacts Every 2 Minutes" /sbin/kill_contacts
Hope it helps. Remember to run the service (repeat the last command) after each Gear restart!

I got this message after doing sdb push "can not close remote file with failed msg 'Read-only file system'.
please help.
Attached Images
File Type: jpg sdbpush.JPG - [Click for QR Code] (29.7 KB, 131 views)
3rd August 2014, 04:55 PM |#98  
Senior Member
Flag Jakarta
Thanks Meter: 7
 
More
Ah, forget to make the system rw.
Code:
 c:\sdb shell mount -o remount, rw /
4th August 2014, 11:50 PM |#99  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by wiedz

Ah, forget to make the system rw.

Code:
 c:\sdb shell mount -o remount, rw /

Thanks! Now my drain rate is 8-10% in 6 hours with gesture on.
9th August 2014, 10:43 AM |#100  
Skin1980's Avatar
Recognized Developer
Thanks Meter: 6,248
 
Donate to Me
More
@mpogr

I sent u a PM, or at least i think that i sent u ( sorry but i cant see in my output folder)
10th August 2014, 02:36 AM |#101  
Member
Thanks Meter: 3
 
More
root Works fine for me.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes