FORUMS
Remove All Ads from XDA

[REF]ERROR CODES AND SOLUTIONS - for ROM Update Utility[ONLINE]

9,588 posts
Thanks Meter: 5,368
 
By dsixda, Inactive Recognized Developer on 5th August 2008, 09:26 PM
Post Reply Email Thread
14th August 2008, 10:17 PM |#11  
dsixda's Avatar
OP Inactive Recognized Developer
Flag Ottawa
Thanks Meter: 5,368
 
More
Hi guys, the Wiki is still being updated. You can contribute with your own info as well if you find new error codes w/ solution.
 
 
14th August 2008, 10:22 PM |#12  
Junior Member
Thanks Meter: 0
 
More
HTC Touch Breakdown
Hello guys!

I just upgraded my touch to the touch surface 1.31 software. Everything went fine, but as soon as i put the sd card back, the phone restarts and gives the smart screen. After that, I reinstalled an original ROM, then installed the touch surface again (because there was a fault on the sd card, which i fixed) but now i have the same problem. You guys think it's the sd card which causes the problems?

Now the 2nd problem is, when I start the phone, i directly get the bootscreen (with those colors). USB connectivity is ok (not with activesync, but just to flash it) The problem is, the original rom which i used first does not install...
It gets to 3% and says ERROR 294: INVALID VENDER ID.
I'm getting really desperate and it made me suffer a big headache,, Does someone know what to do?

Thx in advance!
14th August 2008, 10:24 PM |#13  
dsixda's Avatar
OP Inactive Recognized Developer
Flag Ottawa
Thanks Meter: 5,368
 
More
Search.

http://forum.xda-developers.com/showthread.php?t=415051
14th August 2008, 10:32 PM |#14  
Junior Member
Thanks Meter: 0
 
More
Thank you for your fast reply!

The thread u posted says for me:

ERROR 294 (Invalid Vendor ID):

Device is half CID-unlocked, so your device is likely showing g_cKeyCardSecurityLevel = 0 in MTTY. To be completely unlocked (00), flash the proper USPL onto your device.


How can i flash the prober uspl onto my device then?
14th August 2008, 10:34 PM |#15  
dsixda's Avatar
OP Inactive Recognized Developer
Flag Ottawa
Thanks Meter: 5,368
 
More
Quote:
Originally Posted by xMissy

Thank you for your fast reply!

The thread u posted says for me:

ERROR 294 (Invalid Vendor ID):

Device is half CID-unlocked, so your device is likely showing g_cKeyCardSecurityLevel = 0 in MTTY. To be completely unlocked (00), flash the proper USPL onto your device.


How can i flash the prober uspl onto my device then?

Did you flash any USPL to get the Touch Surface installed on your device?
You might have an Elf and flashed the Elfin USPL (which is wrong). Or You have an Elfin and flashed the Efl USPL (wrong again). Anyways, check the sticky thread at the top of the page.. the one that says "AVOID CONFUSION AND DAMAGE"..
14th August 2008, 10:42 PM |#16  
Junior Member
Thanks Meter: 0
 
More
Ah you are right.

I have flashed the ELF_USPL_1.17.0000 on it, but as you told, i appear to have an elfin (128/256).

What do you suggest i should do?

BTW, the Bootscreen says:
IPL 2.20.0002
SPL 2.26.0000

Maybe that information will help?
14th August 2008, 11:09 PM |#17  
dsixda's Avatar
OP Inactive Recognized Developer
Flag Ottawa
Thanks Meter: 5,368
 
More
Quote:
Originally Posted by xMissy

Ah you are right.

I have flashed the ELF_USPL_1.17.0000 on it, but as you told, i appear to have an elfin (128/256).

What do you suggest i should do?

BTW, the Bootscreen says:
IPL 2.20.0002
SPL 2.26.0000

Maybe that information will help?


Your bootscreen still says 2.26, so that means you don't have 1.17 (the patched SPL, or also known as USPL) on it.

Unzip the following file..


- Copy Cert_SPCS.cab and EnableRapi.cab to your device, run them and then reset your device.
- Remove SIM card and memory card.
- Run elf-uspl.exe in Windows, wait for the white screen and then let the Rom Update Utility flash IPL 2.27 and USPL 2.28.
- If the white screen does not appear, reset and run elf-uspl.exe again.
- Now you can flash any cooked ROM you want straight from the Rom Update Utility (no need to remove anything or wait for a white screen.. just run the Utility to flash it, that's all)

Good luck.
Attached Files
File Type: zip IPL_2.27_USPL_2.28.0000.zip - [Click for QR Code] (1.42 MB, 253 views)
15th August 2008, 07:17 PM |#18  
Junior Member
Thanks Meter: 0
 
More
Well this all won't work

I found out that i have:

Device ID: ELF010050
CID ID: HTC__E11

The problem is I can't find an original rom for it, so if anyone has it, PLEASE upload it this would help me and many more people
15th August 2008, 08:45 PM |#19  
dsixda's Avatar
OP Inactive Recognized Developer
Flag Ottawa
Thanks Meter: 5,368
 
More
Quote:
Originally Posted by xMissy

Well this all won't work

I found out that i have:

Device ID: ELF010050
CID ID: HTC__E11

The problem is I can't find an original rom for it, so if anyone has it, PLEASE upload it this would help me and many more people


What do you mean it won't work? You have to be more specific if anyone can help you. What did you do and what error message, etc. did you see?

EDIT: I forgot that you are stuck at the boot loader. So all you need to do is simply run the RomUpdateUtility (don't run Cert or EnableRapi or elf-uspl.exe) and flash the ROM instead. Did you try that?
16th August 2008, 09:47 AM |#20  
Junior Member
Thanks Meter: 0
 
More
Yupp, I tried that. I've tried many rom's but all won't work. Sometimes i get the wrong id error, sometimes vendor id, it's all because the roms were not for my touch (i think). It's really hard to fix this i've spent 3 days searching all over the internet and this forum, but still no cure..

I guess i just need an original rom for dev/cid: ELF010050/HTC__E11
Too bad it's nowhere on the internet
16th August 2008, 10:05 AM |#21  
dsixda's Avatar
OP Inactive Recognized Developer
Flag Ottawa
Thanks Meter: 5,368
 
More
Quote:
Originally Posted by xMissy

Yupp, I tried that. I've tried many rom's but all won't work. Sometimes i get the wrong id error, sometimes vendor id, it's all because the roms were not for my touch (i think). It's really hard to fix this i've spent 3 days searching all over the internet and this forum, but still no cure..

I guess i just need an original rom for dev/cid: ELF010050/HTC__E11
Too bad it's nowhere on the internet

Your SPL says 2.20 so I'm assuming you have the USPL for Elfin installed. Did you run MTTY and see what it said for the CardSecurityLevel?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes