FORUMS
Remove All Ads from XDA

[HOW TO]Jtag a HTC Touch Elf(in)

714 posts
Thanks Meter: 23
 
By captainstu72, Senior Member on 1st April 2010, 01:31 PM
Post Reply Email Thread
22nd April 2010, 12:03 PM |#21  
captainstu72's Avatar
OP Senior Member
Flag Fareham
Thanks Meter: 23
 
More
Hey,

I've not let this thread die! I've been busy with work and sorting a car out for my fiancee...

I have remade my circuit, and need to get this onto the phone tonight. I found out I also had a broken wire on my last setup, which was clearly going to be a bit of an issue.

My new circuit is about 10cms long, so will be good to see if this works!

Also, does anyone know if the wattage makes a difference on the resistors? I haven't seen anything yet that say. I am using 0.25w.

Have you guys tried this yet? Or are you awaiting my findings before you have a go?

Stu
 
 
23rd April 2010, 05:52 PM |#22  
Member
Flag Surabaya - Hero City
Thanks Meter: 4
 
More
Talking
Hi Stu..I'm sorry..I've been very very busy this week. I even haven't a chance to take care my positions in Forex Trading this week, just doing set and forget (my hobby to watch prices move..LOL, small money in micro account......hehehe...that's why I need to see my Touch alive so I can see prices wherever I go)

Ok, back to business...
So, I've read in an article that I have translated, that we can not make the cable longer than 30 cm (I guess?)
Is this your first problem before so you can't connect to your board?
Can you please post the photos of your activities with your experiment. At least I can know, how to do it? Sorry Stu, I am really blind on this, I need to learn from U.

Actually I tried to PM this Russian in that forum, but somehow, I can not send him PM (seems that he does not accept PM). If I can reach him, I'm sure our problem could be solved. The Logic is, there's no way that we can not reset this chip to its factory default. There's got to be a way.. I wish some HTC's Technicians read this thread and give us a clue, how to bring life to our dead ELF?

Regards,
bom81
23rd April 2010, 09:11 PM |#23  
captainstu72's Avatar
OP Senior Member
Flag Fareham
Thanks Meter: 23
 
More
Okay, so I have tried once more tonight, I have remade my circuit (pics will be posted tomorrow along with what I have tried) Alas, nothing has changed, the device is still bricked.

I am wondering if this Elfin is just Fubar... I do have a second, but i can't do that as it is a work phone!

Does anyone have a bricked elf they are willing to sell to me in the interest of research? I will be posting on the marketplace tomorrow the same. If so, please send me a PM and we can come to an arrangement - I can provide my ebay details etc so you can check out my feedback if you are concerned.

Sorry for the lack of results!

Stu

(annoyed it didn't work!)
23rd April 2010, 11:15 PM |#24  
captainstu72's Avatar
OP Senior Member
Flag Fareham
Thanks Meter: 23
 
More
Post
Attached are some photos of my setup. Hope these help.
Attached Thumbnails
Click image for larger version

Name:	Photo013-002.jpg
Views:	179
Size:	42.4 KB
ID:	314881   Click image for larger version

Name:	Photo019-002.jpg
Views:	139
Size:	31.1 KB
ID:	314882   Click image for larger version

Name:	Photo016-001.jpg
Views:	141
Size:	43.1 KB
ID:	314883  
26th April 2010, 10:36 AM |#25  
Member
Flag Surabaya - Hero City
Thanks Meter: 4
 
More
Stu..to do this JTAG, do we just need the motherboard only and we do not need any other components to be connected to the motherboard?

Also I read that doing JTAG is loading a fresh bootloader to the device. So, in your plan, where to download the bootloader for this device? Or our objective is just to make this device get into the bootloader?
26th April 2010, 07:02 PM |#26  
captainstu72's Avatar
OP Senior Member
Flag Fareham
Thanks Meter: 23
 
More
Hey Bom, I'm not sure, this is something I treid to test, even modded my case to accomodate the cables better. But as I had no luck generally, I am not able to say, I'm trying to get hold of another to test some more, i'm even after some broken ones so that i know they work first to make sure the method does work. It could be worth trying either way, again what is the worst that is going to happen.

Stu
27th April 2010, 01:24 AM |#27  
Member
Flag Surabaya - Hero City
Thanks Meter: 4
 
More
Wink
Stu..just IMHO.

When I Plug in the charger to my device, the orange light even does not light on. Someone said to me, this could be happen if the IC Power is broken.

What about yours? When you plug the charger to your device, does the orange light turn on?

In my article, one of the symtomps said that the JTAG will do if the orange light is on when we plug in the charger. If this is the condition that must be met to do the JTAG, I'm worried that my device does not meet the requirement to do the JTAG.

What do you think?

BTW, I'll open my device tomorrow and try the JTAG as yours and I'll report what ever happen here. Actually I've got all I need, but sadly, I forgot to bring my tools to open the device today. ( i have no time at home, I plan to do this on the rest time of my working hours)

Ps : I found an interesting thing on my device. this morning I tried to charge my friend's battery using my dead ELF. there's no reaction on device. no light on, no response. But the battery getting warmer. After half an hour, I release the battery from my dead device, and put it on my friend's touch. The battery was 3% when I charge to my dead device, but after it's charged, it's 45% !!! means that my device can charge battery, but the device can not sense that there's a charge action being done on the device. I think that's because the OMAP Processor is on a dead state, so it can not detect there's that action. I don't know, this is the power failure on the board, or the OMAP Processor problem? but i'm quite happy, hopefully I'll be able to resurrect this dead elf.
27th April 2010, 01:32 AM |#28  
Member
Flag Surabaya - Hero City
Thanks Meter: 4
 
More
Hi Stu, I've read one of the link you have provided :

On step 3, the article said (someone JTAG his IPAQ) :
"Part 3 - Reflashing the Bootloader
We need to make the iPaq believe that the battery is present, or it will refuse to work. So you have to short the two leftmost pins of the battery connector on the mainboard, and hold down the battery switch with a piece of duct tape. Connect the power supply to the Ipaq. You need to connect the mainboard to the button board to do this, or you can use GND and the VCC pin directly. Connect the JTAG cable to your PC and the iPaq."


Have you consider this condition when you do the JTAG? May be you were fail because you did not "cheat" the Touch that the battery is present.

Regards,
Bom81
27th April 2010, 08:07 AM |#29  
captainstu72's Avatar
OP Senior Member
Flag Fareham
Thanks Meter: 23
 
More
Quote:
Originally Posted by bombom81

Stu..just IMHO.

When I Plug in the charger to my device, the orange light even does not light on. Someone said to me, this could be happen if the IC Power is broken.

What about yours? When you plug the charger to your device, does the orange light turn on?

In my article, one of the symtomps said that the JTAG will do if the orange light is on when we plug in the charger. If this is the condition that must be met to do the JTAG, I'm worried that my device does not meet the requirement to do the JTAG.

What do you think?

BTW, I'll open my device tomorrow and try the JTAG as yours and I'll report what ever happen here. Actually I've got all I need, but sadly, I forgot to bring my tools to open the device today. ( i have no time at home, I plan to do this on the rest time of my working hours)

Ps : I found an interesting thing on my device. this morning I tried to charge my friend's battery using my dead ELF. there's no reaction on device. no light on, no response. But the battery getting warmer. After half an hour, I release the battery from my dead device, and put it on my friend's touch. The battery was 3% when I charge to my dead device, but after it's charged, it's 45% !!! means that my device can charge battery, but the device can not sense that there's a charge action being done on the device. I think that's because the OMAP Processor is on a dead state, so it can not detect there's that action. I don't know, this is the power failure on the board, or the OMAP Processor problem? but i'm quite happy, hopefully I'll be able to resurrect this dead elf.

Thats the same as what I had on mine - a nice battery charger basically. it should be recoverable from that state (I think so anyways, or else this thread I started has no use!)

Quote:
Originally Posted by bombom81

Hi Stu, I've read one of the link you have provided :

On step 3, the article said (someone JTAG his IPAQ) :
"Part 3 - Reflashing the Bootloader
We need to make the iPaq believe that the battery is present, or it will refuse to work. So you have to short the two leftmost pins of the battery connector on the mainboard, and hold down the battery switch with a piece of duct tape. Connect the power supply to the Ipaq. You need to connect the mainboard to the button board to do this, or you can use GND and the VCC pin directly. Connect the JTAG cable to your PC and the iPaq."


Have you consider this condition when you do the JTAG? May be you were fail because you did not "cheat" the Touch that the battery is present.

Regards,
Bom81

I did try with the battery in the device, completely assembled, to see if that was any use, no luck unfortunatly. This battery was fine, as I had charged ti to 100% and was showing as 4.14Vs, same as the one I have in my work(ing)ELF.

I'll give it another go with shorting them out, I'm also going to try another variation, with some 2.2k ohm resistors coming off the main 5 pins and then taking that to VCC.

I'm sure something will work with this, I'm hoping to get another device soon so that I can test some more, failing that, I may risk my working device. If I can do it with that, I know the other was dead, and then consequently helps you guys out too.

(If anyone reading has a spare elf thats just gathering dust.... PM me)

Stu
29th April 2010, 08:05 AM |#30  
captainstu72's Avatar
OP Senior Member
Flag Fareham
Thanks Meter: 23
 
More
Well, I have now ordered a JTAG Interface from the internet, which I'm going to try when that turns up, to see if it is just how I am making the circuit. Hopefully this will arrive soon, hopefully by the weekend, so I can test then.

I am still trying to get hold of another ELF/Vogue to test this on as well to elimiate the fact my broken elfin is far to broken.

Bom, Let me know how yours goes, I do understand that you can only do yours in your working break.

Stu
29th April 2010, 09:23 AM |#31  
Member
Flag Surabaya - Hero City
Thanks Meter: 4
 
More
Talking
Stu !!!!

You're gonna really love this !!!

I'm connected to my processor using HJTAG and the circuit which using IC !

I am now going to No Ice . hope everything will go smooth

But I am now confusing...what bootloader software I must load to my device? Is it IPL or SPL? I've made a thread in ROM Development Section but had not been answered yet
Post Reply Subscribe to Thread

Tags
bricked, dead, elf, jtag, touch

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes