Remove All Ads from XDA
Post Reply Email Thread
I was trying to get rid of my "custom" status so I could take 4.4.2 OTA (I'm on 4.3). I had removed supersu and busybox and viper (the only things I had done with root anyway) and it wasn't going away. In hindsight, I think it was the build.prop changes for viper. In any case, I got the brilliant idea that the xbin directory itself, even though it was empty, was the issue and I deleted it. Now towelroot says it worked, but I'm thinking with no xbin directory it just silently fails. Obviously, without root, I can't put the xbin directory back.

Am I totally screwed or is there a way to fix this without wiping my phone?
29th June 2014, 03:21 AM |#2  
OP Senior Member
Thanks Meter: 115
So I ran the verizon upgrade assistant...

It pushed 4.4.2 to my phone.

Then it said the data partition was corrupt and needed to be reset to factory.

But instead I restarted the phone.

And it finished the upgrade. And the xbin directory is back. And, after initially still showing the status as custom, it now says "official".

And then towelroot didn't seem to work... So I installed supersu and it failed, but then after a reboot I had full root access again.

For the record, that left daemonsu, dexdump, su, sugote, sugote-mksh, and vril-dump in my xbin directory. Stock (right after the upgrade) had dexdump and vril-dump only in xbin.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes