FORUMS
Remove All Ads from XDA

[APP] Official ViPER4Android Audio Effects (FX v2.5.0.5) - New Features & 7.0 Support

4,103 posts
Thanks Meter: 14,327
 
By zhuhang, Recognized Contributor on 15th March 2013, 05:42 AM
Post Reply Email Thread
16th July 2017, 12:29 PM |#25981  
Senior Member
Flag Nijmegen
Thanks Meter: 48
 
More
Quote:
Originally Posted by ultradj83

Well I see in the apk many directories seems to contain the same files in a twentieth of languages...

Yeah you are right, but those files are incomplete. You can also see it when comparing these file sizes to the English file, the English file size contains way more text. Maybe good to know is that this app automatically selects the language according to the system language. So if my system language is Spanish, v4a should be Spanish. But is actually English because the file is incomplete.

Edit: you can also make the language file complete yourself and put it in the correct values folder.
The Following User Says Thank You to Mr_White_214 For This Useful Post: [ View ] Gift Mr_White_214 Ad-Free
 
 
16th July 2017, 06:30 PM |#25982  
ForgottenDude's Avatar
Senior Member
Flag Mumbai
Thanks Meter: 446
 
More
Magisk 13.2
AEX 4.4 (7.1.2)
ENFORCING SELinux.

Viper works perfectly (flashed magisk module)

Sent from my Redmi Note 4 using XDA Labs
The Following User Says Thank You to ForgottenDude For This Useful Post: [ View ] Gift ForgottenDude Ad-Free
16th July 2017, 07:54 PM |#25983  
holozis_HUN's Avatar
Senior Member
Flag Tompa
Thanks Meter: 17
 
More
Quote:
Originally Posted by Brasscat82

It no longer seems to be in the OP, but your selinux needs to be set to Permissive.

If you have already done this, make sure you are installing the latest version for nougat with the I/O fix.

Thanks! But... WHere can I set the SELinux to permissive? WHen I used custom roms, the SELinux was originally Permissive, but now at Stock rom don't really find it. Where can I set it to permissive?
16th July 2017, 08:40 PM |#25984  
Senior Member
Thanks Meter: 121
 
More
Quote:
Originally Posted by holozis_HUN

Thanks! But... WHere can I set the SELinux to permissive? WHen I used custom roms, the SELinux was originally Permissive, but now at Stock rom don't really find it. Where can I set it to permissive?

See my post one page back, I just explained this to someone else
16th July 2017, 08:52 PM |#25985  
holozis_HUN's Avatar
Senior Member
Flag Tompa
Thanks Meter: 17
 
More
Quote:
Originally Posted by Brasscat82

See my post one page back, I just explained this to someone else

Tried with set to permissive and to enforcing + installed the i/O fixed version but the driver status still write "no no, unsopported, sampling rate:0 etc" ...... WHen I got time try to test more, but it seems not working...
16th July 2017, 08:57 PM |#25986  
Senior Member
Thanks Meter: 121
 
More
Quote:
Originally Posted by holozis_HUN

Tried with set to permissive and to enforcing + installed the i/O fixed version but the driver status still write "no no, unsopported, sampling rate:0 etc" ...... WHen I got time try to test more, but it seems not working...

Is the master power on? This has thwarted several people.
It is also possible that your kernel.doesnt support permissive toggling.
16th July 2017, 11:25 PM |#25987  
holozis_HUN's Avatar
Senior Member
Flag Tompa
Thanks Meter: 17
 
More
Quote:
Originally Posted by Brasscat82

Is the master power on? This has thwarted several people.
It is also possible that your kernel.doesnt support permissive toggling.

master power is on.

my kernel version is: 3.18.31-velvet-r3.1. This is a custom kernel. I don't really know if it supports SELinux or not, im not able to write anything to it's topic (i haven't enough permission or what...) so i can't ask if it supports or not.

I really love Viper 4 Android, and want to use this, and im sad that i can't
17th July 2017, 04:59 AM |#25988  
boofman's Avatar
Senior Member
Thanks Meter: 247
 
More
Quote:
Originally Posted by holozis_HUN

master power is on.

my kernel version is: 3.18.31-velvet-r3.1. This is a custom kernel. I don't really know if it supports SELinux or not, im not able to write anything to it's topic (i haven't enough permission or what...) so i can't ask if it supports or not.

I really love Viper 4 Android, and want to use this, and im sad that i can't

Does your Viper come with a Disable SELinux at the Settings>Developer Options? It worked for me.
The Following User Says Thank You to boofman For This Useful Post: [ View ] Gift boofman Ad-Free
18th July 2017, 01:25 AM |#25989  
Senior Member
Thanks Meter: 35
 
More
Two issues. Viper crashed while using convolver and trying out different ir samples. Never happened before. Could it be a bad IRS file? I just added more so not sure if one of those samples did it.
For loading and switching between profiles. I'd have to toggle power on and off to get the effect to work. Any input on this? Thanks.
The Following User Says Thank You to cpnfantstk For This Useful Post: [ View ] Gift cpnfantstk Ad-Free
18th July 2017, 07:39 AM |#25990  
popthosegaskets's Avatar
Senior Member
Flag Singapore
Thanks Meter: 734
 
More
Quote:
Originally Posted by Mr_White_214

Are you on stock rom or a custom rom? I remember sense ROMs having issues with v4a, but you can always try yourself.

I've used V4A on my HTC M8 on Sense ROM with no problems.

Sent from my SM-G920I using XDA Labs
18th July 2017, 08:45 AM |#25991  
Junior Member
Thanks Meter: 0
 
More
Can't install the driver. Rooted, Lineage OS 14.1 Samsung SIII GT-I9300. SELinux to permissive. Root access to apps and ADB. Still can't install it. Please help thanks.
Post Reply Subscribe to Thread

Tags
best settings, convolver, cure tech+, fx xhifi, irs impulse response sample, settings, viper4android v4a, virtual headphone surround engine+

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes