FORUMS
Remove All Ads from XDA

[GUIDE] One Click How to Root the GSM & CDMA Desire with Unrevoked 3.21

647 posts
Thanks Meter: 653
 
Post Reply Email Thread
22nd September 2010, 11:36 PM |#21  
Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by djR3Z

For those having trouble connecting, try installing HTC Sync and then uninstalling it. There are drivers associated with it that are usually needed.

Thanks, just giving that a go...

...

Got there in the end.
 
 
23rd September 2010, 12:09 AM |#22  
newstar's Avatar
Senior Member
Thanks Meter: 33
 
More
Quote:
Originally Posted by djR3Z


You're now rooted!

Well bro , so thanx for such awsome article ... please also write an article how to get back orignal recovery with links and how to unroot .. please for ota updates
Regards

Sent from my HTC Desire
23rd September 2010, 12:54 AM |#23  
Junior Member
Thanks Meter: 1
 
More
So I'm rooted. However, now my phone complains about low memory? What stuff that was installed by unrEVOked can be safely deleted? I'm not interested at the moment in installing other roms, just in controling some apps better and have full control over the phone. Hoped I could remove some standard HTC apps (like the Stock app) but until now I'm not very succesfull
23rd September 2010, 01:14 PM |#24  
hensk's Avatar
Senior Member
Flag Skopje
Thanks Meter: 157
 
More
what about vanila roms,we or I`ve rooted phone
I need only to instal amon ra
I install drivers but when ran unrevoked3 ,cant recognise my phone or ...
is hire " charge only" make problems?
23rd September 2010, 03:48 PM |#25  
Junior Member
Thanks Meter: 0
 
More
Please help, i trying to root my Desire 0.93 and there is still error: Backup CID is missing.
23rd September 2010, 04:33 PM |#26  
heavyhms's Avatar
Senior Member
Flag Modena
Thanks Meter: 34
 
More
Quote:
Originally Posted by Alsajosora

Hmmm,
I have followed the above guide to the letter and it seems to go throught the motions but ends on an
"internal error couldn't find misc"
error message......
I am running a stock O2 Froyo Desire with HBoot .93.......Any ideas?

Same problem on european No-brand desire (lastest hboot and FOTA official update. NEVER modified or rooted).
"internal error: couldn't find misc" on MACOS, no phone detected under linux (ubuntu 9.10 and 10.4)

a little addiction:
Now procedure start under linux also, but i have the same MACOS error ("internal error: couldn't find misc" )
on hboot (0.93) screen also i don't have the HBOOT USB entry
23rd September 2010, 05:57 PM |#27  
Member
Thanks Meter: 1
 
More
Quote:
Originally Posted by TH1882FC

Thanks, just giving that a go...

...

Got there in the end.

hi
the htc sync installation fixed it.
did the 4 steps then aborted.
worked a treat.
thanks
The Following User Says Thank You to baadsha For This Useful Post: [ View ] Gift baadsha Ad-Free
23rd September 2010, 07:37 PM |#28  
Senior Member
Thanks Meter: 29
 
More
USB Driver problem
I had the same issue as several others have reported.

I followed the steps correctly (with the exception that my HBOOT 0.93 does not have the 5th menu item, HBOOT USB).

When I plugged in the phone (Charge Only, USB Debugging), unrevoked3 just sat there, saying "Waiting for device..."

Fortunately, I also had the same success reported by others. I unplugged my phone, installed HTC Sync (complete), then immediately uninstalled it.

I have did figure one thing out, tho.

After I originally loaded the HBOOT drivers from unrevoked, Device Manager showed "Android HBOOT Driver" while USB was connected and the phone was in HBOOT menu.
However, when I rebooted the phone, Device Manager only identified "ADB", and contained the Yellow Exclamation mark of unknown device. I think this will be a key for anyone trying this; if you've never installed HTC Sync, then you'll get this result, and unrevoked3 won't find the device.

After uninstalling HTC Sync, when I plugged the phone in, several USB drivers installed themselves (the result screen is attached). The one that says "My HTC" was the one that previously said "ADB".

During the unrevoked reflashing process, there were multiple USB drivers installing themselves, including USB Mass Storage.

Hope this helps some others
Attached Thumbnails
Click image for larger version

Name:	Desire USB drivers AFTER HTC Sync.png
Views:	922
Size:	9.3 KB
ID:	406658  
The Following User Says Thank You to ScottHW For This Useful Post: [ View ] Gift ScottHW Ad-Free
24th September 2010, 03:00 AM |#29  
Member
Flag Singapore
Thanks Meter: 4
 
More
hi guys. after i plug in my desire in its bootloader mode, in my device manager i have already see Android Bootloader Interface is listed under Android Phone. I haven't done anything yet. So does this mean i can proceed to rooting my phone?
24th September 2010, 07:30 AM |#30  
alessandro_xda's Avatar
Senior Member
Flag Bologna
Thanks Meter: 57
 
More
i was struggled during the past months because i wanted to root my phone (because i need more memory and i'd like a2sd) but i had no chance to backup my datas because my phone is (of course) not rooted.

reading this thread i realized that using unrevoked all my datas and apps won't be affected by the rooting procedure... is it true??

the second question is: does it work on xp64bit?

please answer YES to both question so i'll root it right now!!!

bye
Alessandro
24th September 2010, 08:54 AM |#31  
Member
Thanks Meter: 32
 
More
i find it's easiest to just load a linux livecd of some kind and then run the linux version of unrevoked, much less of a hassle than screwing with the custom hboot drivers in windows.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes