FORUMS
Remove All Ads from XDA

Completely hide the virtual keys in A70

68 posts
Thanks Meter: 13
 
By akmalhisyam, Member on 25th June 2011, 12:45 AM
Post Reply Email Thread
28th June 2011, 12:55 AM |#21  
Senior Member
Thanks Meter: 357
 
Donate to Me
More
Quote:
Originally Posted by arpruss

Another option is to hide them mostly--edit the right board_properties file and set their width to something really small, like 10 pixels. Then they remain usable (though the label will be cut-off), but they take up very little screen space.

Here's what a thinned down button bar looks like on my A43:


To generate this, just do a search and replace on virtualkeys.A43, replacing 800:480:54 with 827:480:27 in the whole file. (Make sure you save a copy as a backup.)

This might give a nice compromise between usability and not cutting off apps too much. Or for a much moral radical thinning, one can do 840:480:14, but that'll only be usable with a stylus or fingernail.

You can also add other keys with other functionalities, but unfortunately they don't get labeled.
 
 
9th July 2011, 05:42 PM |#22  
sibere's Avatar
Retired Recognized Developer
Flag Paris
Thanks Meter: 376
 
More
Quote:
Originally Posted by akmalhisyam

I dont know if you guys already know this.
But I just found out that you can completely hide the virtual keys completely, not moving it to the notification bar.

Here's how to do it:
1. Make sure your filesystem is r/w
2. Use root explorer, rename folder /system/board_properties to other name (i just put "z" in the end of the name)
3. Reboot!

I've test it in Urukdroid 1.1b2 and it works like charm. Buttons mode still can be used, but i prefer Button Savior. New version of Button Savior is perfect, no more bug like before.

Try it and tell me if it works!

Hum not working for me

I had a local.prop made by urukconfig.
I have deleted that file, renamed /system/board_properties to /system/board_propertiez, rebooted my uruk 1.0 and... The button bar is back !

EDIT:

Had to add ro.board.has_soft_keys=yes to /data/local.prop to get completely rid of the soft buttons.
I now have this in /data/local.prop
Code:
ro.board.has_buttonbar=no
ro.board.has_soft_keys=yes
The Following 2 Users Say Thank You to sibere For This Useful Post: [ View ] Gift sibere Ad-Free
9th July 2011, 06:20 PM |#23  
Member
Thanks Meter: 81
 
More
Quote:
Originally Posted by sibere

Hum not working for me

I had a local.prop file with soft_keys set to no (to move soft keys to notification bar).
I have deleted that file, renamed /system/board_properties to /system/board_propertiez, rebooted my uruk 1.0 and... The button bar is back !

EDIT:

Had to add ro.board.has_soft_keys=yes to /data/local.prop to get completely rid of the soft buttons.
I now have this in /data/local.prop

Code:
ro.board.has_buttonbar=no
ro.board.has_soft_keys=yes

I too am having this problem. I even have completely deleted the board_properties folder. Before installing URKDroid I could just rename the folder, but for some reason it still finding it somewhere else with in the system.

Edit:
Cool I'll give it a try.


Edit: Edit:

IT WORKED!! Thanks!!!
13th July 2011, 12:33 AM |#24  
Senior Member
Thanks Meter: 150
 
More
Thanks!! It worked for my A101. I did have to move folder first, then rename and move back. Button Savior (Pro version) is so much better than the default soft buttons.
13th July 2011, 07:30 PM |#25  
Junior Member
Thanks Meter: 0
 
More
Quote:
Originally Posted by msticninja

Anyone with Chulri's R/W root, try this:
Go into the board_properties folder, find the file that relates to your model(mine is an A101, so my file was virtualkeys.A101IT), and rename it(add .old to the end of it), and reboot.

Perfekt :) thanks, this was for me the easiest way to do this. I did this in Chulri's root 2.3.81 using the Terminal Emulator.

wow finaly these ugly buttons are gone
14th July 2011, 12:05 AM |#26  
jakkrith's Avatar
Senior Member
Flag Bangkok
Thanks Meter: 18
 
More
@sibere

Thank you very much for your suggestion. I had done hide the virtual key in A101IT already.



1. Install app "Button Savior"
2. renamed folder /system/board_properties to /system/board_propertiez
3. edit file /data/local.prop (as you suggestion)
4. reboot my device
5. Install app "LCD Density Changer" and set density to 150 (Reduce size of status bar)

I'm very happy with full screen games.

Thanks to @akmalhisyam too for this thread.
14th July 2011, 05:35 PM |#27  
sibere's Avatar
Retired Recognized Developer
Flag Paris
Thanks Meter: 376
 
More
Hi!

I know that you had done it already, but renaming the folder didn't work for me so I had to come with the other solution.

If one want to stick with standard LCD density, you can use a patched framework with 32px size icons. search for it on the dev threads, it shoud be quite easy to find and it worked really well on my A70it
15th July 2011, 01:44 AM |#28  
wokker666's Avatar
Member
Flag Detroit
Thanks Meter: 15
 
More
Make very well sure....
Quote:
Originally Posted by sibere

Hum not working for me

I had a local.prop made by urukconfig.
I have deleted that file, renamed /system/board_properties to /system/board_propertiez, rebooted my uruk 1.0 and... The button bar is back !

EDIT:

Had to add ro.board.has_soft_keys=yes to /data/local.prop to get completely rid of the soft buttons.
I now have this in /data/local.prop

Code:
ro.board.has_buttonbar=no
ro.board.has_soft_keys=yes

Just to let you guys know, if you DO NOT make the changes to /system/board_properties, and you make the ro.board.has_soft_keys=yes change to local.prop, it will fry the touchscreen.... Only way to recover is to do a fresh install thru SDE, or if you can get into /data WITHOUT the use of the screen....

Just a warning.......
16th July 2011, 03:43 PM |#29  
sibere's Avatar
Retired Recognized Developer
Flag Paris
Thanks Meter: 376
 
More
Quote:

Quote:

Hum not working for me



I had a local.prop made by urukconfig.

I have deleted that file, renamed /system/board_properties to /system/board_propertiez, rebooted my uruk 1.0 and... The button bar is back !



EDIT:



Had to add ro.board.has_soft_keys=yes to /data/local.prop to get completely rid of the soft buttons.

I now have this in /data/local.prop



ro.board.has_buttonbar=no

ro.board.has_soft_keys=yes



Just to let you guys know, if you DO NOT make the changes to /system/board_properties, and you make the ro.board.has_soft_keys=yes change to local.prop, it will fry the touchscreen.... Only way to recover is to do a fresh install thru SDE, or if you can get into /data WITHOUT the use of the screen....



Just a warning.......

good to know!
didn't happened to me coz I renamed the relevant virtualkeys file before doing the ro tweak.

Sent from my A70S using the XDA mobile application powered by Tapatalk
16th July 2011, 07:34 PM |#30  
Member
Thanks Meter: 81
 
More
Quote:
Originally Posted by wokker666

Just to let you guys know, if you DO NOT make the changes to /system/board_properties, and you make the ro.board.has_soft_keys=yes change to local.prop, it will fry the touchscreen.... Only way to recover is to do a fresh install thru SDE, or if you can get into /data WITHOUT the use of the screen....

Just a warning.......

This did not happen to me. All I did was place the modified local.prop file in the /data/local folder and my keys were gone. I never renamed the board_properties. Although when the keyboard was active it only filled about 85% of the screen, once I changed the a101 file with in the board_properties folder by renaming it, the keyboard now fills the full screen along the bottom.
17th July 2011, 11:09 AM |#31  
Senior Member
Thanks Meter: 734
 
More
doesn't work for me.
I tried moving and renaming the folder, and moving renaming and editing the a43 file.
editing the local.prop file didn't help much either.
I'm on urukdroid 1.0
Post Reply Subscribe to Thread

Tags
archos 70, virtual keys

Guest Quick Reply (no urls or BBcode)
Message:
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes