Remove All Ads from XDA
Post Reply Email Thread

It's not CWM, but this is the stock 3e recovery + adb root access, allowing you to use adb to back up other partitions, restore, etc. etc.

Flash the pda-recovery-root.tar with Odin using the same instructions as for the Root kernel.

If someone who has not yet rooted could flash this and do the following from adb in recovery after:

adb shell dd if=/dev/block/mmcblk0p8 of=/tmp/stock-kernel.img
adb pull /tmp/stock-kernel.img
adb shell rm /tmp/stock-kernel.img
then upload stock-kernel.img that would be good for making a return-to-stock odin image
The Following 17 Users Say Thank You to Da_G For This Useful Post: [ View ] Gift Da_G Ad-Free
19th February 2012, 01:21 AM |#2  
Senior Member
Thanks Meter: 18
Keep up with the awesome work brotha.
19th February 2012, 01:34 AM |#3  
Uncle Irish's Avatar
Senior Member
Thanks Meter: 849
You're a maniac!!

<insert witty signature here>
19th February 2012, 01:55 AM |#4  
Account currently disabled
Thanks Meter: 147
I wake up to this! Nice! I cant wait for proper CWM.
19th February 2012, 02:06 AM |#5  
ahmarchi's Avatar
Senior Member
Flag Greensboro
Thanks Meter: 181
Tomorrow will be a great day as I'm holding mine

Sent from my MB860 using xda premium
19th February 2012, 03:27 AM |#6  
Thanks Meter: 10
telus galaxy note
hi, i tried to back up the kernel for the canadian telus galaxy note with the adb root you have there but when i use adb to run the commands i get an error message saying permission denied. does it work with the canadian version?
19th February 2012, 03:37 AM |#7  
Da_G's Avatar
OP Inactive Senior Recognized Developer / Moderator Emeritus
Flag Riverside, CA
Thanks Meter: 1,560
Donate to Me
Hi, I haven't tested with anything other than the AT&T GNote. Do you get the # root prompt in adb? You likely wouldn't even have adb without the mod working, what error do you get for what command exactly?
19th February 2012, 03:42 AM |#8  
Thanks Meter: 10
when i run

adb shell dd if=/dev/block/mmcblk0p8 of=/tmp/stock-kernel.img

i get

/dev/block/mmcblk0p8: cannot open for read: Permission denied

then again do i have to be in recovery mode fir before i run adb? just figured out how to get into recovery.
19th February 2012, 03:52 AM |#9  
Junior Member
Thanks Meter: 3
Since I'm in Canada with the Rogers variant I was going to upload the stock kernel, but somehow I just cannot get into recovery to pull it, I've tried vol up+power, both volumes+power, and obviously vol down+ power is download mode. It's almost embarrassing haha.
I've always made good use of what the dev's have done for us since my N1, I figured I could give back at least a little
19th February 2012, 03:55 AM |#10  
Thanks Meter: 10
looks like i had to be in recovery mode. how big is the kernel suppose to be mine shows about 10MB

---------- Post added at 10:55 PM ---------- Previous post was at 10:53 PM ----------

to get into recovery mode hold vol + and vol - and turn on the phone holding the volume keys and release the power key
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes