Remove All Ads from XDA
H10 Turbo

[Q] QPST and getting T-Mobile HSPA+/LTE Bands

49 posts
Thanks Meter: 4
By ruidh, Member on 5th March 2014, 05:03 AM
Post Reply Email Thread
I have a new I9505G running Kit Kat 4.4.2. It consistently gets HPSA but does not get HPSA+ or LTE even though I am in a T-Mobile LTE service area (New York City).

I called Google device support and they referred me to this Youtube

It advises installing a phoneutil.apk on the phone and QPST on a Windows computer. I verified that the Samsung USB drivers are installed. But where I reach the step where I enter *#0808# on the phone to get to the menu where I can select DM+MODEM+ADB the procedure fails. Entering *#0808# gets me "USSD code running..." shown briefly before showing "Unable to process request" and an OK button. Without this step, the Samsung USB Modem drivers did not show under Ports in Device Manager when the phone is connected via USB. I have used the original S4 USB cord. No com ports show with 0 in the Phone column in QPST and I am led to believe that I can't install the 337_AWS.qcn file to get the additional bands.

My bootloader *is* unlocked (and the phone is rooted). I read this thread which refers to *#0808# as well. I

I even tried the older *#7284# with the same result.
22nd March 2014, 01:38 PM |#2  
Senior Member
Thanks Meter: 244
I'm having a similar issue with some USSD Codes. I can access *#*#4636#*#* but not *#7284# or many other USSD codes.

I have the I9505G running Android 4.4.2. It's rooted and unlocked. I installed the phoneutil.apk, but I think it's not working properly in the latest KitKat.
26th March 2014, 04:57 PM |#3  
OP Member
Thanks Meter: 4
I did get the LTE bands working with a new SIM. Apparently mine was so old that it only supported 3G.
Post Reply Subscribe to Thread

i9505 qpst aws t-mobile lte

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes